Adium

Opened 15 years ago

Closed 12 years ago

Last modified 8 years ago

#750 closed enhancement (fixed)

I'd like to be able to toggle Proxies on and Off through AppleScript

Reported by: bdaniel@lmi.net Owned by: applmak
Milestone: Adium 1.3 Component: AppleScript
Version: Severity: normal
Keywords: AppleScript Proxy Setting Cc:
Patch Status:

Description

Perhaps I have a special case, but since I noticed the Applescript support you already have, I am excited that the following might be possible:

Make the setting for Proxy Settings (at least on/off) Apple-Scriptable. Would I would love would be some sort of syntax like this:

tell application "Adium" to set proxy on account 1 to "on"


The reason I would like to do this is that sometimes I am behind a VPN with firewall, and I would like a quick way, such as AppleScript, to switch the proxies on multiple serves from on to off (and from off to on).

Change History (21)

comment:1 Changed 15 years ago by Evan Schoenberg

Milestone: Adium X 1.0Adium X 0.90
Owner: changed from nobody to Evan Schoenberg
Status: newassigned

Seems reasonable. I'll add this to the dictionary by 0.90.

comment:2 Changed 15 years ago by Evan Schoenberg

Cc: evan.s@… added

comment:3 Changed 14 years ago by David Smith

Milestone: Adium X 0.90 (Old)Adium X 0.90

comment:4 Changed 14 years ago by Chris Forsythe

field_haspatch: 0

Is this something we still want for 1.0, or should I move it past evan?

comment:5 Changed 14 years ago by Evan Schoenberg

Milestone: Adium X 1.0
Owner: changed from Evan Schoenberg to nobody
Status: assignednew

Turns out that scripting the preferences is a big project. If someone interested in Applescript wants to tackle making more of Adium applescriptable, cool. We're not going to block any release on this enhancement.

comment:6 Changed 14 years ago by bdaniel

Might another way be to just link the proxy setting to the standard system preferences, so that the Location control panel could control it? Might not help with scripting, but more users may use Location to change proxies and other settings.

comment:7 Changed 14 years ago by Evan Schoenberg

Resolution: wontfix
Status: newclosed

An excellent point. There's no reason for this to be applescriptable; the user should just select "Use Systemwide SOCKS5 Proxy" or "Use Systemwide HTTP Proxy" for their proxy settings, and configure their system appropriately.

I have no idea why I that hasn't occurred to me or anyone else previously :)

comment:8 Changed 14 years ago by dbingham

Resolution: wontfix
Status: closedreopened

I disagree with the consensus to just use systemwide settings rather than allow this to be AppleScript-able. I am in an environment where I need to have my system proxy settings set to my one proxy server and my chat set to a different proxy server. This is obviously supported by just manually setting the HTTP proxy setting in Adium, but without the AppleScript-ability, I can't easily toggle this value when I go home where I don't have any proxies. Almost all of my other system settings are handled by using an AppleScript to switch them, it would be great to be able to do the same with Adium instead of requiring another manual step.

Thanks.

comment:9 in reply to:  8 Changed 13 years ago by Pieter Barrezeele

I second that. I would even ask the extension of being able to script every account setting. Several times a week, I am on a network where my only way to get online is to tunnel my outbound Adium connections. For this reason, I have to change the server to "localhost" and back to the real server several times a week.

Thanks.

comment:10 Changed 13 years ago by Jordan

Component: Adium CoreScripting
Milestone: Needs feedback from users
Patch Status: None

I think better apple script support is a new summer of code project, so hoepfully something will be seen from that...

I assume this is the same in 1.0.2?

comment:11 Changed 13 years ago by Jordan

Resolution: worksforme
Status: reopenedclosed

Going to close this for now, since nobody has advocated for it (or confirmed it's continued existence) for a few months now.

Please comment with any and all updated information and I'll re-open it at that time!

comment:12 Changed 13 years ago by Evan Schoenberg

Cc: evan.s@… removed
Milestone: Needs feedback from usersSummer of Code 07
Resolution: worksforme
Status: closedreopened

I'd say this should be handed off to Matthew Joseph Handley for his SoC project to expand AppleScript, which may potentially want to address it.

comment:13 Changed 13 years ago by Russ Gonsalves

Going to chime in with my desire to have this functionality as well. Feel free to contact me regarding this as well for testing if a build is available for this.

comment:14 Changed 12 years ago by Robert

Owner: changed from nobody to Matt Handley
pending: 0
Status: reopenednew

comment:15 Changed 12 years ago by Jordan

Milestone: Summer of Code 07Needs feedback from users
Version: 0.82

Did we end up having a preferences class for AS to work with?

comment:16 Changed 12 years ago by gjoseph

jas8522: there's no preferences class for AS, afaik - i was just looking for this (in order to change a few network-unrelated settings depending on where i am)

comment:17 Changed 12 years ago by Jordan

Keywords: AppleScript, Proxy SettingAppleScript Proxy Setting
Milestone: Needs feedback from usersAdium X 1.3.x

comment:18 Changed 12 years ago by Matt Handley

Resolution: fixed
Status: newclosed

(In [23294]) Closes #750. Added ability for applescript to control proxies. This has not really been tested, as I don't have access to a proxy. Feel free to re-open this ticket, if further problems occur.

comment:19 Changed 12 years ago by Jordan

Milestone: Adium X 1.3.xAdium X 1.3

comment:20 Changed 8 years ago by d-b

CC me

My situation is that I have to use a tunnel (SOCKS) when I am at work since the firewall only allows outgoing traffic on port 80 and 443 (my SSH server answers on 443). Since all other network traffic should go the regular route (otherwise I can't use the intranet etc), ie., not using the tunnel, I can't use the systemwide proxy setting.

Pidgin has a good solution for this: you can set a general proxy and then on account level, you can select to use either the general proxy or an account specific proxy. I suggest you copy this solution and offer three proxy alternatives: systemwide, Adium wide or account specific.

comment:21 Changed 8 years ago by Robert

d-b,

This ticket was marked fixed. It was about being able to toggle proxies on and off via AppleScript.

Note: See TracTickets for help on using tickets.