Adium

Opened 13 years ago

Closed 13 years ago

#7461 closed defect (fixed)

Jabber ssl_openssl_write crash

Reported by: et_alia Owned by: nobody
Milestone: Adium 1.2 Component: Service/XMPP (Jabber)
Version: Severity: major
Keywords: openssl write jabber disconnect Cc:
Patch Status:

Description (last modified by David Smith)

Hey all. Was asked to file a ticket with these steps after a brief IRC conversation. So here goes.

Steps to reproduce:

  • Open Adium with an SSL-enabled Jabber account. In this case, the server address uses non-routable IPs (and therefore will never connect).
  • While the connection is still open, click the Adium icon in the menubar and set the status of the jabber account to offline.
  • Adium will highlight the menubar, pause for a moment, and crash. This happens with the latest public beta.

OSX 10.4.10 with all the latest from Software Update as of 8/1/07. 13" White MacBook 2.16Ghz Core Duo, 2GB RAM.

Console and crashlog attached.

Attachments (2)

adium_crashlog.txt (27.2 KB) - added by et_alia 13 years ago.
adium_consolelog.txt (1.1 KB) - added by et_alia 13 years ago.

Download all attachments as: .zip

Change History (10)

Changed 13 years ago by et_alia

Attachment: adium_crashlog.txt added

comment:1 Changed 13 years ago by David Smith

Component: Adium CoreJabber
Keywords: xmpp crash added
Milestone: Adium X 1.1

comment:2 Changed 13 years ago by David Smith

Description: modified (diff)

wikiformatting

Changed 13 years ago by et_alia

Attachment: adium_consolelog.txt added

comment:3 Changed 13 years ago by David Smith

Description: modified (diff)

really fix wikiformatting. Sorry for the spam!

comment:4 Changed 13 years ago by Evan Schoenberg

Milestone: Adium X 1.1Adium X 1.1.1
Severity: normalmajor

This crash has existed since the beginning of time; many attempts have been made to fix it, to no avail. If we block 1.1 on it, we may never release :\ I'm shifting it to 1.1.1 because it'd be really cool if someone looked at it and figured out how to make openssl not do this insanity...

comment:5 Changed 13 years ago by Evan Schoenberg

Milestone: Adium X 1.1.2Waiting on libpurple

comment:6 Changed 13 years ago by Zachary West

Keywords: offline added

See also #7683 #2363

comment:7 Changed 13 years ago by Zachary West

Keywords: openssl write disconnect added; libpurple xmpp crash offline removed
Summary: Adium crash with libpurple -- setting to offline status while connecting.Jabber ssl_openssl_write crash

Title/keyword update so it's more searchable

comment:8 Changed 13 years ago by Evan Schoenberg

Milestone: Waiting on libpurpleAdium X 1.2
Resolution: fixed
Status: newclosed

This is most likely fixed in 1.2 since we've changed to a new SSL implementation rather than OpenSSL (the crash doesn't happen on GnuTLS, for example, so it seems to be implementation specific). Please reopen if this stack trace is reproduced in 1.2svn+.

Note: See TracTickets for help on using tickets.