Adium

Opened 12 years ago

Closed 8 years ago

Last modified 8 years ago

#7394 closed enhancement (fixed)

Make Address Book importing's "Format name as:" a token field

Reported by: chucker Owned by:
Milestone: Adium 1.5 Component: Adium UI
Version: Severity: normal
Keywords: Cc:
Patch Status:

Description

In Preferences -> Advanced -> Address Book -> Names, contacts imported from Address Book can currently be formatted using four hardcoded presets (through a popup menu), with two additional checkboxes for further customization if a nickname or middle name is found. This effectively gives me the choices of:

  1. choosing "First Last" and seeing everyone's real names (by which I wouldn't recognize some of them), or
  2. choosing "Use nickname if available" and seeing some people's nicknames instead, by which I might not recognize some of those people.

I thus prefer a format of "First 'Nickname' Last", e.g. "Frank 'Zombie' Miller". I understand the desire to keep things simple, but I believe a token field provides a much better UI, while also allowing for more customization (cf. also #3855, which similarly proposes a move to a token field in a different context). You could drag tokens such as "First name", "Middle name", "Nickname" and "Last name" around in your preferred order, add special characters such as a comma or an apostrophe, and end up with the kind of display you prefer (again, without making the UI needlessly complex, nor particularly unfamiliar – Apple uses this kind of UI for similar format strings).

Attachments (2)

TokenFormatRevisited.hgbundle (22.3 KB) - added by pks 8 years ago.
TokenFormatRevisited.2.hgbundle (22.3 KB) - added by pks 8 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 12 years ago by jas8522

  • Milestone set to Good idea for "later"
  • Version 1.1b3 deleted

comment:2 Changed 12 years ago by djmori

comment:3 Changed 9 years ago by Robby

  • Owner nobody deleted

Changed 8 years ago by pks

Changed 8 years ago by pks

comment:4 Changed 8 years ago by Patrick Steinhardt <steinhardt.p@…>

  • Resolution set to fixed
  • Status changed from new to closed

(In efd66da389b6) "Format names as:" is now a token field. Fixes #3116, fixes #15184, fixes #7394.

r=xnyhps

comment:5 Changed 8 years ago by Robby

  • Milestone changed from Good ideas for later to Adium 1.5

comment:6 Changed 8 years ago by Thijs Alkemade <thijsalkemade@…>

(In 61359dc577f7) Changelog the previous patch. Refs #7394

comment:7 Changed 8 years ago by Robby

Ticket #15558 has been marked as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.