Adium

Opened 13 years ago

Closed 12 years ago

#7388 closed defect (fixed)

can't re-join jabber groupchat after disconnect

Reported by: larse Owned by: nobody
Milestone: Adium 1.3 Component: Service/XMPP (Jabber)
Version: Severity: major
Keywords: Cc: Andreas Monitzer
Patch Status:

Description

When I get disconnected from the network while participating in a jabber group chat, I cannot re-join the same group chat using the same handle when connectivity comes back. Sometimes (but not always) I'll get an error message simply saying "Conflict".

This isn't new with 1.b3, AFAIK this problem has existed with the various 1.0.x versions as well.

Change History (12)

comment:1 Changed 13 years ago by Jordan

Resolution: duplicate
Status: newclosed

comment:2 Changed 13 years ago by Ilan Rabinovitch

Milestone: zzzDuplicate tickets
Resolution: duplicate
Status: closedreopened

I am unable to reproduce in this in Adium 1.1 or 1.2svn. Can you please test with a current version of Adium and let us know you are still running into this issue? I have tested on GTalk, Jabber.org, and a personal jabber server.

comment:3 Changed 13 years ago by luapffuh

I think this is just a side-effect of the way that AIChatController.m:381-392 checks to see if an extant named chat already exists before joining a new one. I don't know that this is necessarily a bug, as much as poor group chat handling?

comment:4 in reply to:  3 Changed 13 years ago by luapffuh

Replying to luapffuh:

I think this is just a side-effect of the way that AIChatController.m:381-392 checks to see if an extant named chat already exists before joining a new one. I don't know that this is necessarily a bug, as much as poor group chat handling?

Also, if you close the group chat, and then re-join it works just fine...

comment:5 in reply to:  3 Changed 13 years ago by erik006

Cc: Andreas Monitzer added

I do not believe this is true. As far as I know that "bug" (which was unreported iirc), was solved by Evan back in the summer and got committed to the SoC branch. Afaik, that change is also in trunk now.

Now, I think this is the same bug AM & I stumbled upon in the summer. It also seems to happen for me when I use a name close to my username joining an empty chat. If I remember correctly, this is a fundamental design issue, and would require a rewrite of the chatcontroller.

The related bug would be #1874

comment:6 Changed 13 years ago by erik006

priority: normalhigh
Severity: normalmajor

I believe this should be handled, since it can be a huge problem when using xmpp.

comment:7 Changed 13 years ago by Jordan

This still sounds like a duplicate of #1880 to me. If it is, then this should probably be closed, if it's not then a distinction should be made between them.

comment:8 Changed 13 years ago by erik006

This is not a duplicate for the following reason: This tickets talks about the "409 Conflict" that occurs when you try and join a jabber group chat, whereas the other ticket talks about the fact that adium doesn't join group chats automatically.

Erik

comment:9 Changed 13 years ago by Jordan

Erik,

That makes sense, but I would think Adium would attempt to autmoatically re-join the chat but it fails because of this bug. If that's true then #1880 relies completely on this ticket to be fixed, otherwise they are indeed mutually exclusive.

comment:10 Changed 12 years ago by Jordan

Milestone: Adium X 1.3

Temporary milestone. I assume this can be reproduced with the 1.2 beta?

comment:11 Changed 12 years ago by Augie Fackler

I've been seeing this on 1.2.2 and 1.2.3, for what it's worth.

comment:12 Changed 12 years ago by Evan Schoenberg

Resolution: fixed
Status: reopenedclosed

(In [23232]) im.pidgin.pidgin 2.4.2mtn @ b28057d6ade7c221b0616c3b02e86659e2d8b10b which adds a chat-join-failed signal. We then make use of it to know when joining a group chat fails (currently only works for jabber chats) and remove our reference to the corresponding AIChat. Fixes #1874. Fixes #7388.

Note: See TracTickets for help on using tickets.