Adium

Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#7381 closed defect (fixed)

Jabber Account is always offline on startup

Reported by: tgos Owned by: evands
Milestone: Adium X 1.1.2 Component: Service/XMPP (Jabber)
Version: Severity: normal
Keywords: Cc:
Patch Status:

Description

Regardless which state I had previously, when I start up Adium, my Jabber account is always offline till I set it manually to another state.

"Connect when Adium opens" is checked, but has no effect, it simply does not connect. It connects all my other accounts, though.

Do I need to send any logs or any other helpful information? Please request what you need to debug that.

It happens in all SVN builds I'm doing for the last couple of weeks.

Change History (6)

comment:1 Changed 13 years ago by Andreas Monitzer

Owner: changed from nobody to Evan Schoenberg

This seems to be caused by the reachability code. It works fine for my jabber.org account, but not for my account using a .local hostname.

comment:2 Changed 13 years ago by Evan Schoenberg

Could you try reverting [20040] and seeing if it works. This was the "fix" for #6466 and #5678, and as I suspected when I committed it, it was possible that it would break detection of reachability for local hosts.

comment:3 Changed 13 years ago by tgos

evands, you are right, reverting the 20040 change repairs Jabber connect again :)

comment:4 Changed 13 years ago by Jordan

Milestone: Adium X 1.1.2

comment:5 Changed 13 years ago by Evan Schoenberg

Resolution: fixed
Status: newclosed

(In [20628]) Reverted [20040]. Direct is a perfectly acceptable way to reach a host on the local network. It is most likely an artifact of an improper system preferences network configuration that direct is offered as a connect method for an unreachable hosts; failing that, some more thorough solution is needed. This fixes autoconnect and connect after waking from sleep / joining a network for local hosts.

Fixes #7381

comment:6 Changed 13 years ago by Evan Schoenberg

(In [20629]) Merged [20628]: Reverted [20040]. Direct is a perfectly acceptable way to reach a host on the local network. It is most likely an artifact of an improper system preferences network configuration that direct is offered as a connect method for an unreachable hosts; failing that, some more thorough solution is needed. This fixes autoconnect and connect after waking from sleep / joining a network for local hosts.

Fixes #7381

Note: See TracTickets for help on using tickets.