Adium

Opened 13 years ago

Closed 13 years ago

#7256 closed defect (fixed)

Supplying incorrect client information

Reported by: meandcat Owned by: nobody
Milestone: Adium X 1.1 Component: Adium UI
Version: Severity: normal
Keywords: Cc:
Patch Status:

Description

this is a minor bug, but therefore it's probably easy to fix: when i am logged in to an XMPP account a wrong client information is shown to my contacts: it says "libgaim 2.0.0" although it is 2.0.2 (i am using Adium 1.0.5 b2). even better would be "Adium 1.0.5/ libgaim 2.0.2" or something similar, because i think "Adium" really should appear in the client informations.

Change History (2)

comment:1 Changed 13 years ago by Jordan

Milestone: Adium X 1.1
Summary: XMPP get info window: wrong client informationSupplying incorrect client information

Just for clarification it says libpurple 2.0.0 while it should read libpurple 2.0.2. Verified on 1.0.5b3 and 1.1svn

comment:2 Changed 13 years ago by Evan Schoenberg

Resolution: fixed
Status: newclosed

(In [20159]) libpurple is now versioned at 2.0.2 as it should be. Fixes #7256. The XMPP XEP (xep-0092) offers name and version fields only, so I'm not sure how to handle displaying both 'Adium' and 'libpurple' in libpurple (iq.c:272)

Note: See TracTickets for help on using tickets.