Adium

Opened 13 years ago

Closed 12 years ago

Last modified 11 years ago

#7148 closed defect (fixed)

Emoticons don't correctly re-display after installing Safari 3

Reported by: Nebula Owned by: Catfish_Man
Milestone: Adium X 1.1.2 Component: Message View
Version: Severity: normal
Keywords: safari 3 emoticon Cc:
Patch Status: Accepted

Description

I installed the Safari 3 Public Beta today. Emoticons show correctly initially. When you click the emoticon to show the text used to create it, the text is correctly displayed. However, clicking again to restore the emoticon instead shows the blue question mark placeholder graphic.

Attachments (1)

Example.png (46.9 KB) - added by Nebula 13 years ago.
Example

Download all attachments as: .zip

Change History (10)

Changed 13 years ago by Nebula

Attachment: Example.png added

Example

comment:1 Changed 13 years ago by Marcus Hesse

I can confirm this problem and resolution as well.

comment:2 Changed 13 years ago by Tobias Rogg

Confirmed. Got the same problem! roggnroll

comment:3 Changed 13 years ago by Jordan

Keywords: safari 3, emoticonsafari 3 emoticon
Milestone: Adium X 1.1.1

Yep definitely an issue.

comment:4 Changed 12 years ago by Elliott Sprehn

The issue seems to relate to changes in how random attributes are handled on elements.

The broken adium feature works by setting the attribute 'src' on the anchor to the src of the image using a.setAttribute('src', url); but later accesses it with a.src which return undefined since that attribute doesn't exist.

The fix for this is a one liner in the Webkit Message View plugin:

Adium.app/Contents/PlugIns/WebKit\ Message\ View.AdiumPlugin/Contents/Resources/Template.html:107

			img.setAttribute('src', node.src );

Should be changed to:

			img.setAttribute('src', node.getAttribute('src') );

This fixes the bug and makes the emotes return when you click the text replacement.

It should be noted that all the Template JS and Adium JS in general should be converted to either use direct access with .attr= or setAttribute/getAttribute because how attributes are set changes the rules about how they can be accessed.

comment:5 Changed 12 years ago by Jordan

field_haspatch: 01
Patch Status: NoneInitially Included

Marking as patch included, however if you can make a diff patch for this and attach it here, it's usually preferred.

comment:6 Changed 12 years ago by David Smith

Owner: set to David Smith
Status: newassigned

Interesting. I will try this out this evening.

comment:7 Changed 12 years ago by David Smith

Resolution: fixed
Status: assignedclosed

(In [20700]) Patch from 'Zeros' on trac to fix clicking on emoticons in Safari 3. Thanks! Fixes #7148

comment:8 Changed 12 years ago by Evan Schoenberg

(In [20705]) Merged [20700] (catfish_man): Patch from 'Zeros' on trac to fix clicking on emoticons in Safari 3. Thanks! Fixes #7148

comment:9 Changed 11 years ago by Robert

Patch Status: Initially IncludedAccepted
Note: See TracTickets for help on using tickets.