Adium

Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#7106 closed defect (fixed)

Can't remove multiple blocked contacts at once from privacy settings

Reported by: beej Owned by: nobody
Milestone: Adium X 1.1.2 Component: Adium UI
Version: Severity: normal
Keywords: Cc:
Patch Status:

Description

Adium -> Privacy Settings... pulls up a dialog where one can see all the contacts they have blocked. one can select multiple contacts, but pressing the "-" key just deletes the first one, and worse yet, highlights an extra one at the bottom after doing so, leaving the user confused as to what happened.

Change History (6)

comment:1 Changed 13 years ago by Jordan

Milestone: Adium X 1.2
Summary: can't delete multiple blocked contacts at once from privacy settingsCan't remove multiple blocked contacts at once from privacy settings

Confirmed - that is extremely confusing - even more so if you select random ones and not a whole group since you don't know what has and has not been removed.

comment:2 Changed 13 years ago by Zachary West

Resolution: fixed
Status: newclosed

(In [20658]) Allows multiple contacts to be removed from the privacy list at once. Fixes #7106.

comment:3 Changed 13 years ago by Zachary West

(In [20659]) Merged [20658]: Allows multiple contacts to be removed from the privacy list at once. Fixes #7106.

comment:4 Changed 13 years ago by Zachary West

Milestone: Adium X 1.2Adium X 1.1.2

comment:5 Changed 13 years ago by Zachary West

This is a result of comparing -service of the contact with -service of the account in AIAccountPlusFieldPromotController.m. This probably also effects GTalk and Jabber in the same way.

comment:6 Changed 13 years ago by Zachary West

And totally wrong ticket. Oops!

Note: See TracTickets for help on using tickets.