Adium

Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#6873 closed defect (fixed)

Adium crashes when dragging IM window while its in the background

Reported by: jesuitx Owned by: evands
Milestone: Adium X 1.0.4 Component: Adium UI
Version: Severity: major
Keywords: crash background drag Cc:
Patch Status:

Description

Adium will crash intermittently when dragging the IM window while it is not the active application (command-dragging the window).

This has been happening for me since before 1.0. Still occurring as of 1.0.3b7.

To reproduce:

  1. Have Adium open with some conversations
  2. Load another application and have it be the frontmost
  3. Hold command and click and drag the IM window.
  4. Adium may crash immediately.

Attachments (1)

Adium.crash.log (26.3 KB) - added by Michael Miller 13 years ago.

Download all attachments as: .zip

Change History (5)

Changed 13 years ago by Michael Miller

Attachment: Adium.crash.log added

comment:1 Changed 13 years ago by Jordan

Keywords: background drag added; ui removed
Milestone: Needs dev review
priority: normalhigh
Severity: normalmajor
Version: 1.0.3b71.0.2

I couldn't reproduce with 1.1svn, but that's possibly because it's intermittent anyway. Setting to higher priority until the debug log can be examined. Also setting back to the 1.0.2 release since this isn't new for the 1.0.3 betas, but it's good you tried it in them as well!

comment:2 Changed 13 years ago by Evan Schoenberg

Milestone: Needs dev reviewAdium 1.0.4
Owner: changed from nobody to Evan Schoenberg
Status: newassigned

comment:3 Changed 13 years ago by Evan Schoenberg

Resolution: fixed
Status: assignedclosed

(In [19669]) Suppress AIClickThroughThemeDocumentButton's showPopup call, which crashes. Fixes a crash when command-dragging the area in which a document button would go in the message window. Fixes #6873

comment:4 Changed 13 years ago by Evan Schoenberg

(In [19670]) Suppress AIClickThroughThemeDocumentButton's showPopup call, which crashes. Fixes a crash when command-dragging the area in which a document button would go in the message window. Fixes #6873

Note: See TracTickets for help on using tickets.