Adium

Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#6655 closed defect (fixed)

Adium crashes on Fire log import

Reported by: swtalmnd Owned by: gbooker
Milestone: Adium X 1.1.3 Component: FireMigration
Version: Severity: normal
Keywords: fire import crash Cc:
Patch Status:

Description

Every time I try to import my Fire logs I get a crash midway through, whether as an initial import using the wizard, or a requested import after the program was running. This has been happening since I tried to switch when 1.0 first came out, and I'm now using 1.0.2 with OSX 10.4.9 on an Intel Macbook Pro. I have submitted several crash reports under the email address swtalmnd@….

Given how often I use my old chat logs for things, this crash makes the program unusable for me.

Attachments (1)

09.xhtml (1.1 KB) - added by Amy 13 years ago.
crashy Fire log

Download all attachments as: .zip

Change History (27)

comment:1 Changed 13 years ago by Jordan

Component: NoneFireMigration
Milestone: Needs feedback from users
Owner: changed from nobody to Graham Booker

Please try the Adium 1.0.3 beta - it's supposed to fix some problems with fire log imports!

comment:2 Changed 13 years ago by Amy

Downloaded beta, crashed on import, sent in a report under the same email/IM.

comment:3 Changed 13 years ago by Jordan

Milestone: Needs feedback from usersNeeds Feedback - Received

This may have to do with a corrupt fire log?

comment:4 Changed 13 years ago by Amy

The logs work just fine in Fire. If a specific entry was corrupt, how would I find it?

comment:5 Changed 13 years ago by Evan Schoenberg

(In [19541]) Added debug window logging as fire log imports occur so we can see where a log crash is happening. Refs #6655

comment:6 Changed 13 years ago by Evan Schoenberg

(In [19542]) Added debug window logging as fire log imports occur so we can see where a log crash is happening. Refs #6655. Merged [19541].

comment:7 Changed 13 years ago by Graham Booker

pending: 0

#7132 marked as duplicate of this

comment:8 Changed 13 years ago by Amy

I have submitted yet another crash report, as this new iteration of Adium, shockingly, has not fixed this bug.

comment:9 Changed 13 years ago by Zachary West

Where did you submit the crash report to?

comment:11 Changed 13 years ago by Graham Booker

Milestone: Needs Feedback - ReceivedNeeds feedback from users
Status: newassigned

Unfortunately, this gets us no closer to figuring out what is causing the crash than were we were previously. The crash is occurring within Apple's XML libraries, and so we really need a file which causes this crash in order to work around it or otherwise track down the bug.

comment:12 Changed 13 years ago by Amy

Well, how can I figure out which file is causing the crash? I'm happy to help if someone will tell me what to do.

comment:13 Changed 13 years ago by Zachary West

Check out your Console.app (In /Applications/Utilities) for the debug output that was added, and attach the contents of the file it's crashing on. You can also email gbooker directly (see AdiumDevelopers) if you are concerned about privacy.

comment:14 Changed 13 years ago by Graham Booker

Unfortunately, it only logs the files in a debug build so you need one of those.

If you can build from source, build a "Deployment-Debug" configuration. Then, when you run adium, you will have a "Debug Window" in the "Adium" menu. Check the "Log to "/Library/Logs/Adium Debug" and that file will list each file as it attempt to import it. The last file in that list is the likely culprit.

comment:15 Changed 13 years ago by Zachary West

Oh right, didn't see the first one was an AILog..

You can also download the most recent debug-built beta, that is 1.1.2b1 at http://adiumx.cachefly.net/Adium_1.1.2b1.dmg, this has a debug window and can be used to. Remember though, it's missing some fixes from release 1.1.2, so don't run it fulltime :)

comment:16 Changed 13 years ago by Amy

I don't run Adium at all on this computer, so that won't be a problem.

Apparently, the xhtml file for one of my chat logs has an error, probably something that happened during a crash -- the file ends on <envel and, obviously, there ought to be more after that. I'm going to remove it from my logs and retry the import.

Also, are you aware that there's a typo ("mettings" instead of "meetings") in the import status bar dialog box?

comment:17 Changed 13 years ago by Graham Booker

(In [20949]) Fixed a spelling mistake. Refs #6655

comment:18 Changed 13 years ago by Graham Booker

(In [20950]) Fixed a spelling mistake. Refs #6655

comment:19 Changed 13 years ago by Graham Booker

Ok, well, if that fixes the crash, still send the file (or at least a partial file which still crashes) so we can gracefully skip such errors rather than crash on them.

comment:20 Changed 13 years ago by Amy

It did fix the crash... I removed most of the body of the chat log (for privacy) but have kept in the first few lines of chat and the "buggy" part at the end, so hopefully this will still work for you.

Changed 13 years ago by Amy

Attachment: 09.xhtml added

crashy Fire log

comment:21 Changed 13 years ago by Peter Hosey

It looks like the log is incomplete. It ends with “<envel”.

comment:22 Changed 13 years ago by Amy

If you'll read all the comments, you'll see that that was exactly the problem -- the original does, as well.

comment:23 Changed 13 years ago by Graham Booker

Resolution: fixed
Status: assignedclosed

(In [20951]) Close open XML elements on broken files. Fixes #6655

comment:24 Changed 13 years ago by Graham Booker

(In [20952]) Close open XML elements on broken files. Merged [20951] Fixes #6655

comment:25 Changed 13 years ago by Robert

This needs a milestone.

comment:26 Changed 13 years ago by Zachary West

Milestone: Needs feedback from usersAdium X 1.1.3
Note: See TracTickets for help on using tickets.