Adium

Opened 15 years ago

Closed 15 years ago

Last modified 11 years ago

#65 closed defect (fixed)

Old versions suck

Reported by: tick Owned by: evands
Milestone: Adium X 1.0 Component: El Vision del Tick
Version: Severity: normal
Keywords: Cc:
Patch Status:

Description

Old versions suck Evan. You and I know it. Some of them actually cause harm, others just aren't that featureful. Find a way to get people to stop using these versions.

Change History (17)

comment:1 Changed 15 years ago by Evan Schoenberg

Owner: changed from Evands to Evan Schoenberg
Status: newassigned

comment:2 Changed 15 years ago by Chris Forsythe

Contacting old version users reporting crashers would be a good start.

comment:3 Changed 15 years ago by Evan Schoenberg

Problem: Every time we release, there are more old versions with which to deal. Solution: No more releases.

Problem solved!

comment:4 Changed 15 years ago by Chris Forsythe

bah!

NOOOZ

Just make code to like not load like adium like when like adium like users like, you know, use older like versions and a newer like version is out, like ya know?

comment:5 Changed 15 years ago by Evan Schoenberg

I really dislike expiring software. If a user doesn't want to upgrade, that's his business; there are some (fools) who prefer 0.77 to 0.80, and they probably will therefore prefer it to 0.90 and 1.0, too. They can use 0.77, it isn't hurting us... the important thing is to automatically refuse to submit crash reports. Then, either: a) They stop trying to send crash reports, well reminded every time they crash that there are now new versions available or b) They upgrade.

comment:6 Changed 15 years ago by David Smith

I wrote part of that, but had trouble hooking into the version checker and gave up on it for the time being. The version checker works very nicely internally, but is pretty useless for anything outside itself.

comment:7 Changed 15 years ago by John Don

I agree with Evands. Adium should not become expiring software, but there should be a way to refuse support on old releases. Let the stubborn user stick with his old Adium. Just make the user aware that he/she is doing so at his/her own risk- and if his/her computer blows up it is not your fault. :-D

comment:8 Changed 15 years ago by biglittledragoon

I agree with Evands and with John Don. A way to stop them to use old versions? Do you have a way to stop people to be STUPID?! Adium 0.80 is best than never!

comment:9 Changed 15 years ago by Chris Forsythe

The problem is that older software has actual problems. People use the .6x adiums which have the contact list deletion bugs in them afaik. Serious issues which could cause users real problems. I'm fine not expiring some versions, but if we find a version which could blow up jupiter, we perhaps shouldn't allow that.

It's not about the old versions not looking the same as new, it's about the fact that some of the old versions suck for users, and they don't know any better.

comment:10 Changed 15 years ago by mj_1903

Perhaps the best idea is to add code to the crash reporter to check whether the version of Adium that just crashed is the latest. If it is, handle the crash normally. If it is not, let the user know that chances are the bug has been fixed and if it is affecting them a lot then they should upgrade.

comment:11 Changed 15 years ago by biglittledragoon

If it's possible to do so, I think this idea is very good.
Maybe with a comment saying that if they want to use an old version, it's at their own risk.

comment:12 Changed 15 years ago by xpander

or just nag the hell out of them with the version checking mechanism. ALERTS UNTIL THEIR EYES BLEED AND THEIR HEAD ASPLODE!

comment:13 Changed 15 years ago by anonymous

I especially like the head asploding. I think this would really get the message across.

comment:14 Changed 15 years ago by jmelloy

We can ignore crash reports from old versions.

comment:15 Changed 15 years ago by Evan Schoenberg

Resolution: fixed
Status: assignedclosed

As suggested by mj_1903 and others, the crash reporter now refuses to submit a crash report for an old version, instead informing the user that an update is available. An update now button is provided in the dialog. Implemented in [12338].

comment:16 Changed 15 years ago by Evan Schoenberg

And merged to adium-0.8 in [12339].

comment:17 Changed 15 years ago by David Smith

Milestone: Adium X 0.90 (Old)Adium X 0.90
Note: See TracTickets for help on using tickets.