Adium

Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#6397 closed defect (fixed)

Hide contact list in screen borders shows an invisible window when exposé is working

Reported by: enkuturi Owned by: jas8522
Milestone: Adium X 1.1 Component: Adium UI
Version: Severity: minor
Keywords: expose invisible hide contact list Cc: patches@…
Patch Status: Accepted

Description

When the option “hide contact list in screen borders” is on, and press F9 (exposé, show all applications windows) the adium contact list appears as an invisible window, and when i put the mouse in the screen border, the adium contact list appears.

Attachments (3)

Pantalla 4.jpg (40.6 KB) - added by Bastian 13 years ago.
The invisible contact list
Pantalla 1.jpg (45.6 KB) - added by Bastian 13 years ago.
myPatch.diff (1.0 KB) - added by Jordan 13 years ago.

Download all attachments as: .zip

Change History (10)

Changed 13 years ago by Bastian

Attachment: Pantalla 4.jpg added

The invisible contact list

Changed 13 years ago by Bastian

Attachment: Pantalla 1.jpg added

comment:1 Changed 13 years ago by Jordan

Component: NoneAdium UI
Keywords: expose invisible hide contact list added
Milestone: Needs dev review
Patch Status: None
Severity: normalminor
Summary: hide contact list in screen borders shows an invisible window when exposé is workingHide contact list in screen borders shows an invisible window when exposé is working
Version: 1.01.0.2

Confirmed. Steps provided are valid.

Changed 13 years ago by Jordan

Attachment: myPatch.diff added

comment:2 Changed 13 years ago by Jordan

Cc: patches@… added
field_haspatch: 01
Owner: changed from nobody to Jordan
Patch Status: NoneNeeds Dev Review
Status: newassigned

comment:3 Changed 13 years ago by Jordan

My patch doesn't work if Adium is not the active window and you move your mouse over to the side of the screen to have it show - then activate expose. Working on this now.

comment:4 Changed 13 years ago by Jordan

Had a discussion on #adium-dev about this, the remaining fix I can't solve due to not having any notification via cocoa API when expose is enabled. If someone else comes up with something for that last situation, I'd love to hear it! :)

comment:5 Changed 13 years ago by Evan Schoenberg

Resolution: fixed
Status: assignedclosed

(In [19711]) If the window has slid offscreen, set it to kCGBackstopMenuLevel and have it ignore expose. Fix by Jordan (jas8522) via patch in #6397. Fixes #6397

comment:6 Changed 13 years ago by Evan Schoenberg

Thanks for the fix!

comment:7 Changed 13 years ago by Evan Schoenberg

Milestone: Needs dev reviewAdium X 1.1
Patch Status: Needs Dev ReviewAccepted
Note: See TracTickets for help on using tickets.