Adium

Opened 13 years ago

Closed 9 years ago

#6346 closed enhancement (fixed)

Switching tabs should stay in the current window

Reported by: darqmarc Owned by:
Milestone: Adium 1.4 Component: Adium UI
Version: 1.0.2 Severity: normal
Keywords: Cc:
Patch Status:

Description

In other applications, such as iTerm and various web browsers, moving through tabs should be confined to the window you are in. Cycling through windows can be accomplished by pressing Command-`. It would be nice if we could at least make this an option.

My personal use case is keeping personal discussions in one window and work related discussions in another. One stays minimized when not in use, the other tends to stay up (depending on where I am it can vary which), and it can be a tad annoying when switching through tabs in one pops up another window.

Change History (10)

comment:1 Changed 13 years ago by jas8522

  • Component changed from None to Adium UI
  • Milestone set to Adium X 1.1
  • Patch Status set to None
  • Summary changed from Switching tabs should stay in the current window to Switching between tabs works accross separate windows
  • Type changed from enhancement to defect
  • Version set to 1.1svn

I can confirm this occurs in 1.0.2 and while I do not normally have more than one chat window open with multiple tabs in each, this would be annoying if I did. I also think this is more of a bug than an enhancement...

Setting milestone to Adium X1.1 since that is the target for revised tab management if I'm not mistaken.

comment:2 follow-up: Changed 13 years ago by cbarrett

  • Summary changed from Switching between tabs works accross separate windows to Switching tabs should stay in the current window
  • Type changed from defect to enhancement
  • Version changed from 1.1svn to 1.0.2

I think this an enhancement, really. Our current behavior is fine, I believe it's deliberately set up to work the way it does.

Chagnging back to enhancement.

One question, jas, does it happen on 1.1svn? Changing the version to 1.0.2 for now.

comment:3 in reply to: ↑ 2 Changed 13 years ago by Catfish_Man

Replying to cbarrett:

I believe it's deliberately set up to work the way it does

It's broken by design then :P

comment:4 Changed 13 years ago by jas8522

Yep that was the version I had tested it in.

comment:5 Changed 12 years ago by evands

  • Milestone changed from Adium X 1.1 to Adium X 1.2
  • pending set to 0

Shifting this off 1.1; we're feature-frozen for 1.1, and this would be an enhancement to the current implementation, not fixing a bug in it.

comment:6 Changed 12 years ago by evands

  • Milestone changed from Adium X 1.2 to Adium X 1.3

I'd rather not mess with this for 1.2; we have enough on that plate already.

comment:7 Changed 12 years ago by jas8522

  • Milestone changed from Adium X 1.3 to Adium X 1.4

comment:8 Changed 11 years ago by Robby

  • Milestone changed from Adium 1.4 to Good idea for "later"

comment:9 Changed 9 years ago by Robby

  • Owner nobody deleted

comment:10 Changed 9 years ago by wixardy

  • Milestone changed from Good idea for "later" to Adium 1.4
  • Resolution set to fixed
  • Status changed from new to closed

This was fixed months ago and I still don't like it.

def06ccb99eb When cycling chats (using "Next Chat" and "Previous Chat") stay in the current window. Do nothing if outside of a chat window.

Note: See TracTickets for help on using tickets.