Adium

Opened 14 years ago

Closed 14 years ago

Last modified 11 years ago

#6273 closed defect (fixed)

Assertion in -[AIContactController addListObject:toMetaContact:] is being hit in 1.0

Reported by: evands Owned by:
Milestone: Adium X 1.0.1 Component: Adium UI
Version: Severity: normal
Keywords: Cc:
Patch Status:

Description

just updated to adium 1.o, then it crash upon starting msn messenger
OS Version:	Version 10.3.9 (Build 7W98)
Language:	en
Exception:	NSInternalInconsistencyException
Reason:	Invalid parameter not satisfying: ![listObject isKindOfClass:[AIListGroup class]]
Stack trace:
     1	-[AIContactController addListObject:toMetaContact:] (in Adium)
     2	-[AIContactController groupListContacts:] (in Adium)
     3	-[AIContactController _moveContactLocally:toGroup:] (in Adium)
     4	-[AIMetaContact addObject:] (in Adium)
     5	-[AIContactController _performAddListObject:toMetaContact:] (in Adium)
     6	-[AIContactController contactWithService:account:UID:] (in Adium)
     7	_contactLookupFromBuddy (in AdiumLibgaim)
     8	_buddy_added_cb (in AdiumLibgaim)
     9	_gaim_signal_emit_vargs (in Libgaim)
    10	_gaim_signal_emit (in Libgaim)
    11	_msn_user_add_group_id (in Libgaim)
    12	_msn_got_lst_user (in Libgaim)
    13	_lst_cmd (in Libgaim)
    14	_msn_cmdproc_process_cmd (in Libgaim)
    15	_read_cb (in Libgaim)
    16	___CFSocketPerform (in CoreFoundation)

I don't know how a group is possibly getting in here, but we should find the root cause.

Change History (3)

comment:1 Changed 14 years ago by Evan Schoenberg

Resolution: fixed
Status: newclosed

(In [18869]) This assert isn't helping anything; just log and abort. Fixes #6273

comment:2 Changed 14 years ago by Evan Schoenberg

(In [18870]) This assert isn't helping anything; just log and abort. Fixes #6273. Merged [18869]

comment:3 Changed 11 years ago by Zachary West

Component: MetaContactAdium UI

Removing 'Meta Contact' component.

Note: See TracTickets for help on using tickets.