Adium

Opened 15 years ago

Last modified 9 years ago

#627 new enhancement

Selecting text at beginning of line auto-selects timestamp/previous line

Reported by: adiumx@happywaffle.com Owned by:
Milestone: Good ideas for later Component: Adium Core
Version: Severity: minor
Keywords: text message limit handle Cc:
Patch Status:

Description

When double-clicking the first word of a message, or when dragging to select a whole line and the cursor reaches the first word, Adium auto-selects part of the timestamp at the beginning of the line. If there is a previous message from the same sender, Adium also auto-selects the previous line. This makes selecting text for copy-pasting more difficult than it should be.

Tested using the "Eclipse" message style.

To reproduce, double-click the first word of any message, and the timestamp (and previous line, if there is one from the same sender) will partially select.

Change History (8)

comment:1 Changed 15 years ago by adamiser

Component: Core AdiumXtras

This is message style specific, but I'm not aware of a way to control selection within a webkit view.

comment:2 Changed 14 years ago by Chris Forsythe

field_haspatch: 0

Does this happen in any other message styles?

comment:3 Changed 14 years ago by Evan Schoenberg

Resolution: fixed
Status: newclosed

(In [14288]) Updated Eclipse message style from dzhim. Fixes #627. Fixes #729. Fixes #999.

comment:4 Changed 14 years ago by Evan Schoenberg

(In [14289]) Merged [14288]: Updated Eclipse message style from dzhim. Fixes #627. Fixes #729. Fixes #999.

comment:5 Changed 14 years ago by chadsinge@…

Resolution: fixed
Status: closedreopened

I've updated my copy of the message style, even restarted adium, but there still seems to be a problem when selecting the first word from a block of multiple messages from the same user.

comment:6 Changed 13 years ago by Jordan

Component: XtrasAdium Core
Keywords: message limit handle added; select removed
Milestone: Good idea for "later"
Patch Status: None
Type: defectenhancement
Version: 0.811.0.2

comment:7 Changed 12 years ago by Carlos Morales

comment:8 Changed 9 years ago by Robert

Owner: anybody deleted
Note: See TracTickets for help on using tickets.