Adium

Opened 14 years ago

Closed 13 years ago

#6101 closed defect (fixed)

Adium sometimes fails to open chat window.

Reported by: darmok Owned by:
Milestone: Adium 1.2 Component: Adium UI
Version: Severity: major
Keywords: chat window Cc: dantearmok@…
Patch Status:

Description

Start with Adium b20, connected, idle, only Contacts window open, then hide it. Friend sends me a message via AIM. Adium quacks properly, becomes unhidden, and displays the Contacts window. Console.log files with the expected "Message History: Loading log file" and umpteen Message Context Display: Parsing message time attribute" messages; no error messages. But the actual chat/message window is sometimes never displayed! At this point, others can message me also and still no window is displayed. Selecting the last person to message me in the Window menu sometimes brings up the chat/message window. But sometimes it doesn't. Selecting previous people that messaged me from that menu, or even hitting cmd-1 etc, never brings up the window. Only double-clicking on the contact in the Contacts window reliably brings up the chat/message window.

From adium's debug log:

12:51:22: (Libgaim: msn) S: NS 000: QNG 41
12:51:46: (Libgaim: oscar) incomingim_ch1: unknown TLV 0x0016 (len 4)
12:51:46: (Libgaim: oscar) incomingim_ch1: unknown TLV 0x0013 (len 1)
12:51:46: (Libgaim: oscar) Received IM from PButterfos with 1 parts
12:51:46: (Libgaim: oscar) PButterfos has an icon
12:51:46: (Libgaim: oscar) Parsing IM part, charset=0x0000, charsubset=0x0000, datalen=24
12:51:46: (Libgaim: buddyicon) Wrote file /Users/dan/Library/Application Support/Adium 2.0/Users/Default/libgaim/icons/113b4904
12:51:46: (Libgaim: buddyicon) Uncached file b220f53f
12:51:46: Buddy icon update for pbutterfos
12:51:46: [buddy icon: pbutterfos got data]
12:51:46: [AIChat: 6ce35c0 initForAccount]
12:51:46: chatWithContact: Added <<<AIChat: 0x6ce35c0>:<new>>> [<NSCFSet: 0x659870> (<AIChat: 0x68dfe10>:Yahoo!.ahungry14u, <AIChat: 0x6ce35c0>:<new>)]
12:51:46: gaim openChat:<AIChat: 0x6ce35c0>:AIM.pbutterfos for AIM.pbutterfos
12:51:46: adiumGaimConvWriteIm: Received <HTML>:-)  Hi Dan</HTML> from pbutterfos
12:51:46: Updating security details for <AIChat: 0x6ce35c0>:AIM.pbutterfos
12:51:48: Content is {<AIContentEvent: 0x6cd7110> :<Source=<AIListContact:6c2bc20 AIM.pbutterfos>> <Destination=<ESGaimAIMAccount:6f8e10 3>:darmok> <Message=Tuesday, January 2, 2007{NSFont = "Helvetica 12.00 pt. P [] (0x06c4ba40) fobj=0x066bf470, spc=3.33"; }>}

My config:
300-MHz PowerMac G3 B&W w/ 384 MB RAM, OS X 10.4.8, AdiumX 1.0b20
Accounts: 3 AIM, 2 ICQ, 1 GoogleTalk, 1 MSN, 3 Yahoo (two disabled).
iBubble Status, Yahoo emoticons, Adiumy Green dock icon, Pastel Blue color theme, Tiny (with user icons) list layout, Regular window, Opacity 100%, Resize vert & horiz, Mockie Brown - Icon Left, Show user icons, Lucinda Grande 12, Show received message fonts & colors, No custom backgrounds, Custom name format "Alias (User Name)", Log messages, Show up to 42 lines of history, always.

  • Dan.

Attachments (2)

adium-no-window.zip (138.5 KB) - added by Dan 14 years ago.
Screen snapshot and leaks report.
Adium-hide-issue.mov (798.3 KB) - added by Jfro 13 years ago.
Video of it in action

Download all attachments as: .zip

Change History (33)

Changed 14 years ago by Dan

Attachment: adium-no-window.zip added

Screen snapshot and leaks report.

comment:1 Changed 14 years ago by Evan Schoenberg

  • Are Pat and Paul in your screen shot contacts for whom you have an open chat but the message window isn't displayed?
  • When you double click to open a message window (which you say does show the window properly), are the previously sent messages displayed (the ones which didn't trigger the window initially)?
  • If you select Pat or Paul from the Window menu and press Cmd-M for minimize, what happens?
  • If you select Pat or Paul from the Window menu and press Cmd-W for close, what happens? Does the entry in the Window menu disappear?

comment:2 Changed 14 years ago by Dan

...Um, need to "update" my original... With b20, if I have a message window open, say something, then close that contact's tab (or the whole window), then quickly opt-click on the desktop or dock icon to make Adium hide... when the contact replies, and I bring Adium forward, the message window *never* shows up. It is consistantly missing. I don't remember this being so consistant previously.

Your q's:

Yes, in this particular case, I'd been chatting with Pat. The window was properly there when I hid the app (option-click on the dock icon). When Paul's first message came in, the dock icon jumped and displayed his name. I clicked on the dock icon, the Contacts window came up, his name came off the dock icon, - but as you see in the snapshot, there was no message window at all.

Yes, when the window is displayed after double-clicking on the contact's name in the Contacts window, the chat window contains all the messages - history plus the ones that had just come in. Nothing missing.

When the window isn't there, hitting cmd-M either before or after selecting either contact from the Windows menu, makes the window's icon show up in the dock! Hitting it again just beeps. Once the minimized window is in the dock, selecting from the Windows menu works.

Pressing cmd-W, when the window is missing, does cause the checked person in the Window menu to disappear.

Would a sample of Adium while the window is missing help?

HTH,

  • Dan.

comment:3 Changed 14 years ago by Evan Schoenberg

I don't think a sample would help. Thanks for your responses.

Does this only happen to you coming out of the situation in which Adium was hidden?

comment:4 Changed 14 years ago by Dan

So far it seems so. I can't recall having the chat window go AWOL when Adium was just pushed into the background.

comment:5 Changed 14 years ago by Evan Schoenberg

So (1) Adium is hidden, (2) you receive a new message, (3) Adium comes to the front automatically but doesn't display the message window?

Adium really shouldn't be unhiding itself... that might be a separate bug in and of itself, if that's what's happening. Is (3) accurate?

comment:6 Changed 14 years ago by Evan Schoenberg

Milestone: Adium X 1.0Needs feedback from users

comment:7 Changed 14 years ago by Dan Rogers

I am also experiencing this bug. Here is my process, similar to the above post.

While Adium is running (1) Cmd+H to hide Adium, (2) I recieve a *new* message, and am notified via the dock icon. (3) I click the dock icon, and the only window that appears is the contact list.

This happens, even if my chat window was already open with other chats open in tabs.

Unfortunately, the only workaround I've found is to right click the dock icon, then select a chat window from the menu to get it to appear again. Strange and unintuitive.

comment:8 in reply to:  7 Changed 14 years ago by Dan Rogers

And I would like to add that this is using version 1.0

comment:9 in reply to:  7 Changed 14 years ago by Jensen Gelfond

Replying to danro: I have having the exact same problem as danro. It does not happen 100% of the time, but when it does happen it occurs just like he says in his 3 step process. The way I can get back to my chat window is to right-click on the dock icon and select one of my contacts. I was using Adium .89.1 and then upgraded to 1.0 and this started happening. This is on an Intel Macbook with OS 10.4.8. Please let me know if you need more information!

comment:10 in reply to:  7 Changed 14 years ago by Schlaeps

Replying to danro: If you press Cmd+M when you return to Adium, you should be able to click on the minimized chat in the dock to make it appear again.

At least, that's what I've been doing (I've been experiencing this since the 1.0 beta).

comment:11 Changed 14 years ago by Eric Hodel

I get this too, especially if Adium is hidden.

Double-clicking a contact in my contact list will force the window to come up.

If I have message windows open, then hide adium, then get messaged, unhiding Adium won't bring up the window. Usually I do this by clicking a growl notification, but also through cmd-tab.

When you double click to open a message window (which you say does show the window properly), are the previously sent messages displayed (the ones which didn't trigger the window initially)?

Yes, once the window is shown it behaves as if it was always open.

comment:12 Changed 14 years ago by Eric Richie

Milestone: Needs feedback from usersNeeds Feedback - Received

comment:13 Changed 14 years ago by chagrins

This seems to be a more informative version of #6380.

comment:14 Changed 14 years ago by Eric Richie

Milestone: Needs Feedback - ReceivedAdium X 1.0.3
Version: 1.0b201.0.1

comment:15 Changed 13 years ago by Eric Richie

Milestone: Adium X 1.0.3Adium X 1.1

comment:16 Changed 13 years ago by Eric Richie

Milestone: Adium X 1.1Adium X 1.0.3

comment:17 Changed 13 years ago by Chris Forsythe

Milestone: Adium X 1.0.3Adium X 1.2

comment:18 Changed 13 years ago by Chris Forsythe

Milestone: Adium X 1.2Good idea for "later"

Moving to the good idea milestone, move back individually if you intend to work on these.

comment:19 in reply to:  7 Changed 13 years ago by Lukasz Pogoda

Replying to danro:

I am also experiencing this bug. Here is my process, similar to the above post.

While Adium is running (1) Cmd+H to hide Adium, (2) I recieve a *new* message, and am notified via the dock icon. (3) I click the dock icon, and the only window that appears is the contact list.

This happens, even if my chat window was already open with other chats open in tabs.

Unfortunately, the only workaround I've found is to right click the dock icon, then select a chat window from the menu to get it to appear again. Strange and unintuitive.

I'm experiencing exactly the same problem! What is interesting, in my case it was introduced in 1.0.1 -- since some update I'm very often having the same problem.

I think it should be milestones to 1.0.3/1.2, but NO later.

comment:20 in reply to:  description Changed 13 years ago by Andrea

Please solve this problem... this is not a good idea for "later", is a really annoying problem that makes all scream everytime it happens.

Thanks

comment:21 Changed 13 years ago by Chris Forsythe

Milestone: Good idea for "later"Adium X 1.2
Severity: majorblocker

I had moved all tickets which weren't set as blocker off the 1.2 milestone. This was one of those tickets. Moving to 1.2, setting to blocker. If need be this can be pushed to 1.3, but no later than that.

comment:22 Changed 13 years ago by Augie Fackler

Owner: changed from nobody to Augie Fackler
pending: 0

Changed 13 years ago by Jfro

Attachment: Adium-hide-issue.mov added

Video of it in action

comment:23 Changed 13 years ago by Dan

This problem is hitting me much more often now, OS X 10.4.9 and Adium 1.1b3. If there's any further info / testing I can do to help with this, please let me know.

comment:24 Changed 13 years ago by Evan Schoenberg

Resolution: fixed
Status: newclosed

(In [20876]) When handling a 'reopen' request - a dock click, for example - we have our own handling of what window should be displayed which intelligently looks for the right chat to select. Doing our own handling, however, means that the full unhide behavior would not occur as NSApp normally would do. We now call -[NSApp unhide:] to ensure that all windows are approrpiately unhidden. Fixes #6101

comment:25 Changed 13 years ago by Evan Schoenberg

(In [20877]) Merged [20876]: When handling a 'reopen' request - a dock click, for example - we have our own handling of what window should be displayed which intelligently looks for the right chat to select. Doing our own handling, however, means that the full unhide behavior would not occur as NSApp normally would do. We now call -[NSApp unhide:] to ensure that all windows are approrpiately unhidden. Fixes #6101

comment:26 Changed 13 years ago by Jordan

Resolution: fixed
Status: closedreopened
Version: 1.0.11.1.4

See #8362 I *think* these are describing the same situation.

comment:27 Changed 13 years ago by Peter Hosey

(In [21723]) Let AppKit do some of the work for us in our AIInterfaceController's implementation of -handleReopenWithVisibleWindows:. Specifically:

  • Use the visibleWindows argument, which seems reliable as of 10.4.10. I have no idea what misbehavior the former comment was referring to; if anybody knows and can reproduce it after this commit, feel free to file a ticket documenting it fully, and a radar if appropriate, and revert this commit.
  • Nothing specified why we returned NO. The correct response is YES.

Refs #6101. Refs #8362. Doesn't fix either one.

comment:28 Changed 13 years ago by Augie Fackler

Owner: Augie Fackler deleted
Status: reopenednew

comment:29 Changed 13 years ago by Dan

This is still hapening in Adium 1.2b1

comment:30 Changed 13 years ago by Jordan

Since (for some reason) I didn't specify it here when I referenced the other ticket, #8362 has excellent steps to reproduce the bug every time.

comment:31 Changed 13 years ago by Evan Schoenberg

Resolution: fixed
Status: newclosed

(In [21903]) When activating a chat, makeKeyAndOrderFront: needs to be called if the window is not key or it is not visible. It may be key but not visible if the application was previously hidden with it key. Fixes #6101. Fixes #8362 (where excellent steps to reproduce were found, allowing a fix to be made quickly).

Note: See TracTickets for help on using tickets.