Adium

Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#5845 closed defect (fixed)

Adium crashes on opening a chat window

Reported by: beezum88 Owned by: nobody
Milestone: Adium X 1.0.2 Component: Service/AIM
Version: Severity: major
Keywords: Cc:
Patch Status:

Description

I use AIM exclusively. The e-mail used on the crash report is beezum88@…

Every time a chat window opens on Adium, whether the window opened because someone sent me a message or if I opened one to send a message, the program unexpectedly quits. The problem is easily reproducible by simply opening Adium and opening a new chat. I also reproduced the problem the other direction by opening iChat under a different screenname and sending a message to the screenname that Adium was signed on to. Adium receives the message and stays open until I switch focus to Adium, at which point, the program immediately quits and the crash reporter opens.

After restarting the computer, the problem goes away for a while, but returns quite soon.

I have attached two text files of the console log, the first is a log of what happens when I send a message from Adium. The second is a log of what happens when I receive a message in Adium.

I have run through the troubleshooting page with no success. I would like to continue to use Adium because it is so much more customizable than Fire or iChat, so if this problem could be fixed as soon as possible, I would appreciate it.

-Benton

Attachments (7)

Log of Adium Crash 1.txt (9.1 KB) - added by Benton Greene 13 years ago.
Log of crash while sending message
Log of Adium Crash 2.txt (10.1 KB) - added by Benton Greene 13 years ago.
Log of crash when receiving message
Adium.crash.log (69.1 KB) - added by rainbowglitter87 13 years ago.
rainbowglitter87's crash log - from new window opening (someone sent me an IM)
Adium.exception copy 1.log (169 bytes) - added by Nicky 13 years ago.
Adium.exception copy 4.log (169 bytes) - added by Nicky 13 years ago.
GDB Output.txt (568 bytes) - added by noleli 13 years ago.
Adium.crash.2.log (61.0 KB) - added by ryangs 13 years ago.
ryangs crash log

Download all attachments as: .zip

Change History (36)

Changed 13 years ago by Benton Greene

Attachment: Log of Adium Crash 1.txt added

Log of crash while sending message

Changed 13 years ago by Benton Greene

Attachment: Log of Adium Crash 2.txt added

Log of crash when receiving message

comment:1 Changed 13 years ago by Peter Hosey

Please don't set priority, or submit the same ticket twice.

comment:2 Changed 13 years ago by Benton Greene

Sorry, I forgot to say what version I was using: Adium X 0.89.1 (this is what it says in "about Adium")

comment:4 Changed 13 years ago by Peter Hosey

beezum88: Please try the AdiumBeta and let us know whether it solves your problem.

comment:5 Changed 13 years ago by Eric Richie

Milestone: Needs feedback from users

Changed 13 years ago by rainbowglitter87

Attachment: Adium.crash.log added

rainbowglitter87's crash log - from new window opening (someone sent me an IM)

comment:6 in reply to:  5 Changed 13 years ago by rainbowglitter87

Replying to edr1084: AdiumBeta fixed this problem for me! Thanks! :)

comment:7 Changed 13 years ago by Eric Richie

Resolution: fixed
Status: newclosed

Sounds good.

comment:8 in reply to:  5 Changed 13 years ago by rconne1@lsu.edu

Resolution: fixed
Status: closedreopened

Replying to edr1084: suffering same crash issue with 0.89.1 on OSX, using AIM, Yahoo!, and MSN; tried 1.0b17; the issue persists.

Changed 13 years ago by Nicky

Attachment: Adium.exception copy 1.log added

Changed 13 years ago by Nicky

Attachment: Adium.exception copy 4.log added

comment:9 in reply to:  description Changed 13 years ago by Nicky

This problem occurs repeatedly on my computer as well. I exclusively use AIM and whenever I open a chat window or recieve a message from another user, adium crashes. I am currently using Mac OS X Version 10.4.8 and Adium 1.0b21. I have tried restarting, downloading the current version (0.89.1) and 1.0b20, and resetting my preferences both for this screen name ('what serendipity') and another.

I have attached two crash logs from today.

comment:10 Changed 13 years ago by Evan Schoenberg

Please try this:

  1. Quit Adium
  2. Move ~/Library/Preferences/com.adiumX.adiumX.plist to the desktop (or somewhere else out of the way)
  3. Load Adium and try again.

Any change?

comment:11 Changed 13 years ago by Nicky

No, it didn't work.

comment:12 Changed 13 years ago by Evan Schoenberg

We need a gdb backtrace to find the cause of this crash. Please see RunningAdiumInGDB and let me know if you have any questions about the instructions. Thanks!

comment:13 Changed 13 years ago by Evan Schoenberg

comment:14 Changed 13 years ago by noleli

I'm experiencing this crash in 1.0.1b1 (and 1.0). It seems to be when it's looking to fill in the message history, but that's just a guess. I'm attaching the GDB output.

Changed 13 years ago by noleli

Attachment: GDB Output.txt added

comment:15 in reply to:  14 ; Changed 13 years ago by Evan Schoenberg

Replying to noleli:

I'm experiencing this crash in 1.0.1b1 (and 1.0). It seems to be when it's looking to fill in the message history, but that's just a guess. I'm attaching the GDB output.

Does this happen only when opening a message window to certain contacts?

comment:16 in reply to:  15 Changed 13 years ago by noleli

Replying to evands:

Replying to noleli:

I'm experiencing this crash in 1.0.1b1 (and 1.0). It seems to be when it's looking to fill in the message history, but that's just a guess. I'm attaching the GDB output.

Does this happen only when opening a message window to certain contacts?

Now that you mention it, yes it does. Should I send you the most recent chat transcript? Delete blist.xml, maybe? Thanks.

comment:17 Changed 13 years ago by Evan Schoenberg

blist.xml wouldn't be relevant, but the most recent chat transcript would be. Please:

  1. Move the most recent transcript to your desktop.
  2. Check if opening a message window now crashes (it shouldn't)
  3. Send it to me.

Thanks :)

comment:18 Changed 13 years ago by noleli

Works great in b3, thanks to Evan's help. :)

comment:19 Changed 13 years ago by Evan Schoenberg

Glad your crash is fixed, noleli. Sadly, I can't close the ticket, as it turns out (looking at the original crash logs) that you actually changed subjects mid-ticket and we fixed an unrelated crash :)

comment:20 Changed 13 years ago by ryangs

I'm encountering this same problem: Adium crashes before any chat window can open, whether it is incoming or outgoing.

comment:21 Changed 13 years ago by ryangs

I should note that I have tried moving the preferences file and the chat logs to the desktop before starting Adium; neither helps.

Changed 13 years ago by ryangs

Attachment: Adium.crash.2.log added

ryangs crash log

comment:22 Changed 13 years ago by ryangs

I was able to fix this problem by deleting my Window Positions.plist. Seems like this problem may be caused by Adium trying to draw the chat window in a screen space that no longer exists. Immediately prior to this problem developing, I had been using my PowerBook with a larger external monitor, and moved the chat windows outside of the 1024x768 area of my internal PowerBook screen. Once I was back to just this internal screen, the space where the chat windows were previously no longer existed, which I'm guessing is what caused the crash.

comment:23 Changed 13 years ago by Evan Schoenberg

Milestone: Needs feedback from usersAdium X 1.0.2

comment:24 Changed 13 years ago by Chris Forsythe

Severity: majorblocker

Setting this to block 1.0.2

comment:25 Changed 13 years ago by Evan Schoenberg

Can you reproduce this problem, perhaps by using the external screen again? I can't reproduce it. I tried the following:

  1. Powerbook resolution is set to 1280x800.
  2. Position a contact's chat window such that it is at maximum x and y coordinates
  3. Close it
  4. Set resolution to 800x600
  5. Open contact's chat window

Adium behaves as I would expect, putting the window at the edge of the available space. I'll look at the code now and see if I can find any path to destruction...

comment:26 Changed 13 years ago by Evan Schoenberg

I'm going to protect against the condition even though I can't reproduce it, as it makes the behavior cleaner in any case. Please reopen if you still have this problem in 1.0.3.

comment:27 Changed 13 years ago by Evan Schoenberg

Resolution: fixed
Status: reopenedclosed

(In [19126]) Make sure that newly opened windows which restore to a saved frame do so to an on-screen location. Hopefully fixes #5845

comment:28 Changed 13 years ago by Evan Schoenberg

(In [19127]) Merged [19126]: Make sure that newly opened windows which restore to a saved frame do so to an on-screen location. Hopefully fixes #5845

comment:29 Changed 13 years ago by Evan Schoenberg

Erm, I meant in 1.0.2.

Note: See TracTickets for help on using tickets.