Adium

Opened 13 years ago

Closed 9 years ago

Last modified 9 years ago

#5790 closed enhancement (fixed)

Management of AIM multiple sessions without having to go through aolsystemmsg

Reported by: mixduptransistor Owned by:
Milestone: Adium 1.5 Component: Service/AIM
Version: Severity: normal
Keywords: block aol system message Cc:
Patch Status: Accepted

Description

If you block aolsystemmsg using the standard block feature, the messages still get through. Perhaps there could be a quick and easy way to tell adium to ignore and drop those messages (don't deliver them) since AOL's servers won't honor a block request. Honestly, I know I'm signed on in two places :)

Attachments (3)

aim-multiple-login-preference.tar.gz (14.6 KB) - added by joshperry 11 years ago.
Patch adding multiple login preference to aim accounts
ESPurpleOscarAccountView.nib.zip (24.0 KB) - added by Robby 9 years ago.
aim-multiple-login-preference.patch (7.2 KB) - added by Robby 9 years ago.

Download all attachments as: .zip

Change History (29)

comment:1 Changed 13 years ago by cbarrett

  • Owner changed from nobody to edr1084

This is definitely a dupe, I don't know the original ticket number. Assigning to edr so he can find it :P

comment:2 Changed 13 years ago by edr1084

  • Keywords block aol system message added
  • Milestone set to Possible Third Party Plugins
  • Owner edr1084 deleted

If it's a dupe I can't find any trace of the other ticket... I'm going to put this in the Possible Third Party Plugins milestone in case someone wants to work on it.

comment:3 in reply to: ↑ description Changed 13 years ago by davidswelt

I second that. These messages are annoying.
Instead of blocking it, I would rather have it reply with a '1' automatically and not display the message any further.

comment:4 Changed 12 years ago by evands

  • Milestone changed from Possible Third Party Plugins to Adium X 1.3.1
  • Owner set to evands
  • Patch Status set to None
  • pending set to 0
  • Status changed from new to assigned
  • Summary changed from Enable a way to block aolsystemmsg messages to Management of AIM multiple sessions without having to go through aolsystemmsg

We currently are considered an 'old client' by the AIM server because we don't send a multiple login preference.

aim_send_login() should send a MULTICONN_FLAGS tlv with our preference; we then won't be prompted.

comment:5 Changed 12 years ago by djmori

comment:6 Changed 11 years ago by evands

We do:

	/*
	 * If set, old-fashioned buddy lists will not work. You will need
	 * to use SSI.
	 */
	aim_tlvlist_add_8(&tlvlist, 0x004a, 0x01);

which is the 'recent client who wants multiple sessions' preference.

We could instead send 0x02 for 'we know about multiple sessions but want to bump other instances offline when we connect'.

comment:7 Changed 11 years ago by TheDodger

I propose to make this a per account or global advanced preference.

comment:8 Changed 11 years ago by evands

  • Milestone changed from Adium X 1.3.1 to Adium X 1.3.2

comment:9 Changed 11 years ago by evands

  • Milestone changed from Adium 1.3.2 to Good idea for "later"
  • Owner changed from evands to nobody
  • Status changed from assigned to new

I'm not going to be doing this any time soon.

comment:10 Changed 11 years ago by joshperry

I'm willing to do some work on this, as I'm getting fed up with the unblockable messages from aolsystemmsg on each computer logged into AIM. As evands mentioned, libpurple already sends 0x01(multiple session aware), so why are we still getting these annoying messages?

I would prefer to have AIM continue working as it does with multiple accounts logged in but without sending the messages if there is a tlv to accomplish that.

If sending 0x02 to kick off other logins is the only way to suppress aolsystemmsg then I'll wire it up to the account preferences. This shouldn't be too hard as a bool was added to aim_send_login for this purpose already (http://pidgin.im/pipermail/commits/2008-June/008834.html)

Josh

comment:11 follow-up: Changed 11 years ago by zacw

A cleaner solution might be a dialog tailored for the situation:

"You're signed onto (x) locations. What would you like to do?

[ ] Never show this message again.

(First responder, Disconnect others) (Return, Nothing)"

or something.

comment:12 in reply to: ↑ 11 Changed 11 years ago by joshperry

That is a good idea but I don't know if the server sends information back to the client about multiple logins. I believe it is all handled server side, having aolsystemmsg notify the user directly.

This will be easier than I thought, there is already a boolean account preference in libpurple "allow_multiple_logins" that defaults to false. I should be able to easily just add that preference to the adium account and UI.

Josh

comment:13 Changed 11 years ago by zacw

Well, it definitely does: you get an IM about it. Just parse and prevent the IM display. The account preference plus the dialog is nice (a "don't ask me again" + "disconnect others" could flag that preference in the account options, which would be clean).

Changed 11 years ago by joshperry

Patch adding multiple login preference to aim accounts

comment:14 Changed 11 years ago by joshperry

I've created a patch for adding the preference. Let me know what you think.

zacw: I like the idea, but as this is my first contrib, and actually my first coding against an obj-c app I wanted to keep it simple. I'll look at what it would take to process aolsystemmsg messages as they come in, display a dialog, store the preference from that dialog, and suppress future specific messages from aolsystemmsg based on that preference.

comment:15 Changed 10 years ago by jwz

Just adding my voice to the crowd of people who want to be able to block messages from aolsystemmsg.

Isn't 3 years long enough to languish in the bug system?

joshperry submitted a patch 9 months ago. Is there something wrong with it?

comment:16 Changed 10 years ago by edr1084

  • Patch Status set to Needs Dev Review

comment:17 Changed 10 years ago by sam1am

Also wanted to chime in with hopes that this can be implemented, if not in core then in a plugin. I downloaded the patch but I don't know how to install it. :/

comment:18 in reply to: ↑ description Changed 10 years ago by danwelcome

I also agree that this would be a great feature to be implemented in core or in a plugin. I would think there would be a lot of users out there that like to be logged into multiple computers (or on their iPhone with an IM client like Beejive) at the same time without being bombarded with aol system msg IMs every time their computer awakes from sleep.

I have also downloaded the patch like sam1am, but haven't found a way to install it. :(

comment:19 Changed 10 years ago by Robby

  • Milestone changed from Good idea for "later" to Adium 1.4

comment:20 Changed 10 years ago by Robby

Ticket #13121 has been marked as a duplicate of this ticket.

comment:21 Changed 10 years ago by zacw

  • Milestone changed from Adium 1.4 to Adium 1.5

Pushing to 1.5.

comment:22 Changed 9 years ago by stevecheckoway

I got fed up with the AOL systemmsgs a few weeks ago and wrote a PlugIn to disable them. It was really pretty trivial thanks to the excellent PlugIn API. http://www.adiumxtras.com/index.php?a=xtras&xtra_id=7560 I'm surprised no one did this before.

comment:23 Changed 9 years ago by Robby

  • Owner nobody deleted

Changed 9 years ago by Robby

Changed 9 years ago by Robby

comment:24 Changed 9 years ago by Robby

I've attached the files included in the compressed file for easier inspection.

I'm sorry we have left this patch lying around for so long. Hopefully, we can get this added for 1.5.

comment:25 Changed 9 years ago by Frank Dowsett <wixardy@…>

  • Resolution set to fixed
  • Status changed from new to closed

(In bdf6043f7816) Add a preference for AIM: allow multiple sign in locations defaulting to true. Fixes #5790, initial patch from Josh Perry.

comment:26 Changed 9 years ago by wixardy

  • Patch Status changed from Needs Dev Review to Accepted
Note: See TracTickets for help on using tickets.