Adium

Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#5634 closed defect (fixed)

Deletion of ICQ contacts when moving them from one group to another while they're offline

Reported by: Robby Owned by: durin42
Milestone: Adium X 1.0.5 Component: Service/ICQ
Version: Severity: major
Keywords: icq move group delete authorization Cc:
Patch Status:

Description

I moved four contacts from one group to another. The two contacts that were online made no problems but the other two were "deleted", I had to readd them and have them authorize me. One of them was a metacontact and the ICQ number was still there but the person was falsely displayed as offline (-> authorization lost).

This is probably a duplicate of #5130, I am not sure. If it is, it would narrow down the problem to the moving of offline contacts.

Change History (32)

comment:1 Changed 13 years ago by Robert

Problem still exists in b15. It seems, this problem only affects contacts that require authorization.

comment:2 Changed 13 years ago by Chris Forsythe

Milestone: Needs feedback from users
Owner: changed from nobody to Eric Richie

Needs repro

comment:3 Changed 13 years ago by Eric Richie

Keywords: TicketTaskForce added

comment:4 Changed 13 years ago by Robert

By the way, problem still present in Adium X 1.0.1.

comment:5 Changed 13 years ago by Eric Richie

Milestone: Needs feedback from usersNeeds Feedback - Received

comment:6 Changed 13 years ago by Robert

I don't think this has gone. It's a serious bug, a lot worse than #6641 for example. :(

Severity: normal?

comment:7 Changed 13 years ago by Jordan

Component: NoneICQ
Patch Status: None
Severity: normalmajor
Version: 1.0.1

Can also refer to #6358 for similar problem

comment:8 Changed 13 years ago by Jordan

Keywords: icq move group delete authorization added; TicketTaskForce removed
Milestone: Needs Feedback - ReceivedNeeds feedback from users
priority: normalhigh
Version: 1.0.11.0.2

Another similar ticket: #6793

Can anyone try the 1.0.3 beta and attach a debug log for the time(s) when this happens? That will help out the devs alot...

Thanks!

comment:9 Changed 13 years ago by Robert

I'll check once 1.0.3 is final.

comment:10 Changed 13 years ago by Jordan

Any update Robby? You won't be able to get a debug log with a final version however...

comment:11 in reply to:  10 Changed 13 years ago by Phil

This might be a stupid question, but where do I find the debug logs (running 1.0.4b2)

console.app shows nothing but "Adium: CMSCreateDataProviderOrGetInfo : Invalid colorspace type", but that has nothing todo with this bug and happens right at login.

comment:12 Changed 13 years ago by Jordan

You will need to use beta1 since that's the only beta version that has the debug window of the 1.0.4 beta series.

comment:13 in reply to:  12 Changed 13 years ago by Phil

ok, here is what happens during the buddymove in the debug log.

i just XXXXXed the last digits of the ICQ numbers. if you need anything else, please let me know

20:55:41: (Libpurple: oscar) ssi: moving buddy 2865XXXXX from group Buddies to group Family & Friends
20:55:41: listObjectRemoteGroupingChanged: <AIListContact:9a074b0 ICQ. 2865XXXXX >: remoteGroupName Family & Friends --> <AIListGroup:7803ea0 Group.Family & Friends>
20:55:41: Moving <AIListContact:9a074b0 ICQ. 2865XXXXX > to <AIListGroup:7803ea0 Group.Family & Friends>
20:55:42: (Libpurple: oscar) ssi: status is 0x000a for a 0x0008 action with name no item
20:55:42: (Libpurple: oscar) ssi: Action 0x0008 was unsuccessful with error 0x000a
20:55:42: adiumPurpleNotifyMessage: type: 0

Unable To Add
Could not add the buddy 2865XXXXX for an unknown reason.  The most common reason for this is that you have the maximum number of allowed buddies in your buddy list. 
20:55:43: (Libpurple: oscar) ssi: status is 0x0000 for a 0x0009 action with name Family & Friends
20:55:44: (Libpurple: oscar) icq response: 41 bytes, 1927XXXXX, 0x07da, 0x0049
20:55:46: (Libpurple: util) Writing file blist.xml to directory /Users/phil/Library/Application Support/Adium 2.0/Users/Default/libpurple
20:55:47: (Libpurple: oscar) icq response: 41 bytes, 1927XXXXX, 0x07da, 0x004a
20:55:52: (Libpurple: util) Writing file blist.xml to directory /Users/phil/Library/Application Support/Adium 2.0/Users/Default/libpurple

comment:14 Changed 13 years ago by Robert

I tried moving one contact that required authorization when he was offline. It was no problem.

comment:15 Changed 13 years ago by Robert

On 1.0.3 final, btw.

comment:16 Changed 13 years ago by Jordan

Milestone: Needs feedback from usersNeeds dev review

Interesting... I'm going to submit this for dev review anyway just in case that debug log holds any helpful info.

comment:17 Changed 13 years ago by Robert

Ok, there is still a problem (the same?) existing.

What I did:

I asked my friend on ICQ whom I had added both to my ICQ and my AIM account to go offline for 30 seconds. I then moved him into another group ("B). When he returned he appeared online ("away", in the contact list), I thought the problem was gone. So, then, I moved him back to the original group ("A").

Then I saw in "Informationen über [contact] ("information about [contact]" in English"?) that, on ICQ, he was still in the group I moved him when he was offline ("B"). I also had lost authorisation on at least one of the accounts, I am not quite sure which, so asked him to "re-authorise" me. He did so, but I don't know whether it was my ICQ or my AIM account he authorised. After he had done so, he was in group "B" on both ICQ and AIM.

comment:18 in reply to:  16 Changed 13 years ago by Phil

on another note: it also happened with an contact now who was _online_ using 1.0.4b3. so, sorry, no debug log :-(

comment:19 Changed 13 years ago by Jordan

Milestone: Needs dev reviewWaiting on libpurple
Version: 1.0.21.0.3

Don't know how I missed this before, but #p576.

comment:20 Changed 13 years ago by Jannis

I am using 1.0.4, and I have the same problem--even some offline moved contacts have fully disappeared and aren't even visible in icq2go! It were mostly plain ICQ contacts (no metacontacts) I moved.

comment:21 Changed 13 years ago by Mark Doliner

I think this was fixed in libpurple on 05/29/2007. I don't know if that change has made it's way into Adium yet, but I'd be interested in hearing if it fixes the problem for you guys.

comment:22 Changed 13 years ago by Augie Fackler

Owner: changed from Eric Richie to Augie Fackler
pending: 0

comment:23 Changed 13 years ago by Jordan

Milestone: Waiting on libpurpleNeeds dev review
Version: 1.0.31.0.4

Agreed - this should now be fixed [see the pidgin ticket on the matter]. Submitting for dev review.

comment:24 Changed 13 years ago by Jordan

Resolution: fixed
Status: newclosed

This is now fixed as of Adium 1.0.5b (Libpurple 2.0.2 update)

comment:25 Changed 12 years ago by Robert

Milestone 1.0.5, then, I guess.

comment:26 in reply to:  24 Changed 12 years ago by lpp

The same problem appears for me in Adium X 1.2.5

comment:27 Changed 12 years ago by Jordan

I haven't seen this with my ICQ contacts since 2007 when it was reported as fixed. Please ensure you have completed every single one of the TroubleshootingTips. If you continue to experience this problem, open a new ticket with a debug log attached of the event occurring. Don't bother to open the ticket if you cannot get the debug logging (see CurrentAdiumDebug).

comment:28 Changed 12 years ago by Jordan

Milestone: Needs dev reviewAdium X 1.0.5

comment:29 in reply to:  27 Changed 12 years ago by lpp

Replying to jas8522:

I haven't seen this with my ICQ contacts since 2007 when it was reported as fixed. Please ensure you have completed every single one of the TroubleshootingTips. If you continue to experience this problem, open a new ticket with a debug log attached of the event occurring. Don't bother to open the ticket if you cannot get the debug logging (see CurrentAdiumDebug).

Here is a debug log: 13:23:48: (Libpurple: oscar) ssi: moving buddy {Friend} from group A to group B 13:23:48: (Libpurple: oscar) ssi: SNAC error 1 13:23:48: (Libpurple: oscar) ssi: status is 0x0000 for a 0x000a action with name no item 13:23:49: (Libpurple: blist) Updating buddy status for {Me} (ICQ) 13:23:49: (Libpurple: oscar) ssi: status is 0x000e for a 0x0008 action with name no item 13:23:49: adiumPurpleRequestInput: {

"Cancel Callback" = <08b0b814 >; "Cancel Text" = Cancel; "Default Value" = "Please authorize me!"; Masked = 0; Multiline = 1; "OK Callback" = <08b11de8 >; "OK Text" = OK; "Primary Text" = "Authorization Request Message:"; userData = <087a2fd0 >;

} 13:23:49: (Libpurple: oscar) ssi: status is 0x0000 for a 0x0009 action with name A 13:23:49: (Libpurple: oscar) ssi: status is 0x0000 for a 0x0009 action with name B 13:23:50: (Libpurple: oscar) icq response: 42 bytes, {Me}, 0x07da, 0x0051 13:23:51: (Libpurple: blist) Updating buddy status for {Friend} (ICQ) 13:23:53: (Libpurple: util) Writing file blist.xml to directory /Users/michael/Library/Application Support/Adium 2.0/Users/Default/libpurple 13:23:53: (Libpurple: util) Writing file /Users/michael/Library/Application Support/Adium 2.0/Users/Default/libpurple/blist.xml

where {Friend} is a friend's ICQ number and {Me} is mine ICQ number. When the authorization request dialog appeared I just click "Cancel" and don't lose authorization from my friend. And can move them from one group to another without this dialog anymore.

comment:30 in reply to:  27 ; Changed 12 years ago by lpp

Replying to jas8522:

I haven't seen this with my ICQ contacts since 2007 when it was reported as fixed. Please ensure you have completed every single one of the TroubleshootingTips. If you continue to experience this problem, open a new ticket with a debug log attached of the event occurring. Don't bother to open the ticket if you cannot get the debug logging (see CurrentAdiumDebug).

Here is a debug log:

13:23:48: (Libpurple: oscar) ssi: moving buddy {Friend} from group A to group B
13:23:48: (Libpurple: oscar) ssi: SNAC error 1
13:23:48: (Libpurple: oscar) ssi: status is 0x0000 for a 0x000a action with name no item
13:23:49: (Libpurple: blist) Updating buddy status for {Me} (ICQ)
13:23:49: (Libpurple: oscar) ssi: status is 0x000e for a 0x0008 action with name no item
13:23:49: adiumPurpleRequestInput: {
    "Cancel Callback" = <08b0b814 >; 
    "Cancel Text" = Cancel; 
    "Default Value" = "Please authorize me!"; 
    Masked = 0; 
    Multiline = 1; 
    "OK Callback" = <08b11de8 >; 
    "OK Text" = OK; 
    "Primary Text" = "Authorization Request Message:"; 
    userData = <087a2fd0 >; 
}
13:23:49: (Libpurple: oscar) ssi: status is 0x0000 for a 0x0009 action with name A
13:23:49: (Libpurple: oscar) ssi: status is 0x0000 for a 0x0009 action with name B
13:23:50: (Libpurple: oscar) icq response: 42 bytes, {Me}, 0x07da, 0x0051
13:23:51: (Libpurple: blist) Updating buddy status for {Friend} (ICQ)
13:23:53: (Libpurple: util) Writing file blist.xml to directory /Users/michael/Library/Application Support/Adium 2.0/Users/Default/libpurple
13:23:53: (Libpurple: util) Writing file /Users/michael/Library/Application Support/Adium 2.0/Users/Default/libpurple/blist.xml

where {Friend} is a friend's ICQ number and {Me} is mine ICQ number. When the authorization request dialog appeared I just click "Cancel" and don't lose authorization from my friend. And can move them from one group to another without this dialog anymore.

comment:31 in reply to:  30 Changed 12 years ago by lpp

Additional: When I closed "Adium debug" and opened "Adium" again I found that my friend is invisible for me -- I lost his authorization and can't re-request it again. I deleted him and added again, he authorized me and it appears online. So, I should had not to click "Cancel" in previous situation. So this is a real bug, please help.

comment:32 Changed 12 years ago by Jordan

lpp: please ensure you have tried this in a fresh OS X user account (just to be absolutely sure it's not the result of an old set of preferences causing a problem or something similar). Also, try adding me (46939242), wait for my authorization (I'll send you a message once I've sent my request), then try moving me to another group and we'll see if it happens then as well - in the brand new OS X user account. I will then also be able to test it by moving you to another group on my end.

Note: See TracTickets for help on using tickets.