Adium

Opened 13 years ago

Closed 12 years ago

Last modified 12 years ago

#5561 closed defect (fixed)

Messages prefpane preview will only display outgoing messages in Lucida Grande

Reported by: adium Owned by:
Milestone: Adium 1.2.5 Component: Message View
Version: Severity: regression
Keywords: message view font Cc:
Patch Status:

Description

The outgoing font in message views appears to be stuck in Arial (or at least, it is for me...). I wrote the message style shown, so I know damn well it doesn't specify a font! This seems to occur whether or not there's a default font specified in Info.plist, too.

Attachments (2)

Picture 4.png (138.3 KB) - added by adium 13 years ago.
Demonstation of the issue
Picture 11.png (99.0 KB) - added by mathuaerknedam 13 years ago.
Stockholm with Arail & Lucida Grande

Download all attachments as: .zip

Change History (24)

Changed 13 years ago by adium

Attachment: Picture 4.png added

Demonstation of the issue

comment:1 Changed 13 years ago by Evan Schoenberg

Milestone: Adium X 1.0
Severity: normalregression

comment:2 in reply to:  description Changed 13 years ago by adium

Ok, so a correction: in the preview display, it's actually stuck in Lucida Grande; though I think I'm still right that this is no matter what font is set as default.

In chat windows, I've realised that it's using Arial as that's what my outgoing font is set to. I'd assumed that changing the display settings in preferences would also work for my font, but it seems, strangely, I'm wrong on that count.

comment:3 Changed 13 years ago by David Smith

Milestone: Adium X 1.0
Resolution: worksforme
Status: newclosed

Correct. You can change your font via OSX's formatting palette (command-t or the format menu). Making this less confusing is being discussed in #1882. If I'm misunderstanding the issue, please reopen :)

comment:4 Changed 13 years ago by Evan Schoenberg

Resolution: worksforme
Status: closedreopened

The 'correction' comment was just irrelevant to the originally reported issue :)

comment:5 Changed 13 years ago by Jordan

Patch Status: None
Resolution: fixed
Status: reopenedclosed

I believe this is now fixed.

comment:6 Changed 13 years ago by mathuaerknedam

I'm not sure when this might have regressed, but as of 1.2svn, The problem is back. Except that the outgoing message will only display as Lucida Grande. I'll attach a screenshot that shows that "Gotta run; catch ya later ;)" is a different font.

Changed 13 years ago by mathuaerknedam

Attachment: Picture 11.png added

Stockholm with Arail & Lucida Grande

comment:7 Changed 13 years ago by mathuaerknedam

Oh, and just so it's clear, this problem is only in the preview on messages pane of the prefs, not in actual messages.

comment:8 Changed 13 years ago by Trevin Ward

pending: 0
Resolution: fixed
Status: closedreopened
Version: 1.0b131.2svn

Reoping as it has been reported that this has reappeared.

comment:9 Changed 13 years ago by mathuaerknedam

FWIW, the summary/title above specifies Arial, but the actual font that's "stuck" is Lucida Grande.

comment:10 Changed 12 years ago by Zachary West

Milestone: Adium X 1.2
Summary: Outgoing font stuck in ArialPreview Font for Message Styles Stuck on Lucida Grande

comment:11 Changed 12 years ago by Chris Forsythe

Milestone: Adium X 1.2Adium X 1.3

Can anyone reproduce this?

Due to the work for the SoC stuff being on 1.2, I'm moving this to 1.3.

comment:12 Changed 12 years ago by hawkman

Yes. Under 1.1.2, the outgoing messages in the preview pane will not display the font chosen under Text Display:. The size, however, will be respected. Choose a completely wacky font to demonstrate this.

comment:13 Changed 12 years ago by Jordan

refs with screen capture #7766

comment:14 Changed 12 years ago by mathuaerknedam

FWIW, I'd summarize this as "messages prefpane preview will only display outgoing messages in Lucida Grande". This problem is limited to the prefpane preview; real chats are fine.

comment:15 Changed 12 years ago by Jordan

Summary: Preview Font for Message Styles Stuck on Lucida GrandeMessages prefpane preview will only display outgoing messages in Lucida Grande

comment:16 Changed 12 years ago by Evan Schoenberg

The preview chat specifies a particular font for the outgoing message but has no font specified for the incoming one. This is supposed to allow one to demonstrate in real time the effects of the "show received message fonts" checkbox.

The intended behavior is:

  • With 'show received message fonts' enabled, the outgoing message is in Lucida Grande and the incoming one is on the font specified in the pref pane.
  • With 'show received message fonts' disabled, both incoming and outgoing messages display in the font specified in the pref pane.

comment:17 Changed 12 years ago by mathuaerknedam

Weird.

The current behavior is:

  • With 'show received message fonts' enabled, the outgoing message is in Lucida Grande and the incoming one is Comic Sans.
  • With 'show received message fonts' disabled, the outgoing message is in Lucida Grande and the incoming one is in the font specified in the pref pane.

comment:18 in reply to:  17 Changed 12 years ago by Evan Schoenberg

Oops, I got 'incoming' and outgoing' backwards in my post.

Replying to mathuaerknedam:

The current behavior is:

  • With 'show received message fonts' enabled, the outgoing message is in Lucida Grande and the incoming one is Comic Sans.
  • With 'show received message fonts' disabled, the outgoing message is in Lucida Grande and the incoming one is in the font specified in the pref pane.

The incoming message is behaving exactly as it intended. The outgoing message is misbehaving.

comment:19 Changed 12 years ago by Jordan

Milestone: Adium X 1.3Adium X 1.2.5

Matching this up with #9524 and #9523 as they are all problems with the messages prefpane styles.

comment:20 Changed 12 years ago by Jordan

Version: 1.2svn1.2.4

comment:21 Changed 12 years ago by Evan Schoenberg

Resolution: fixed
Status: reopenedclosed

(In [23034]) I see no reason to force default attributes for decoded text to Lucda Grande 12; if the incoming HTML doesn't specify a font or size, we should produce an NSAttributedString which similarly doesn't specify. Along with [23033], fixes #5561 and fixes #9524.

comment:22 Changed 12 years ago by Evan Schoenberg

(In [23035]) Merged [23033] and [23034]: I see no reason to force default attributes for decoded text to Lucda Grande 12; if the incoming HTML doesn't specify a font or size, we should produce an NSAttributedString which similarly doesn't specify. Along with [23033], fixes #5561 and fixes #9524.

Note: See TracTickets for help on using tickets.