Adium

Opened 13 years ago

Closed 12 years ago

Last modified 12 years ago

#5551 closed defect (fixed)

Contacts saying "Came Back" when actually disconnecting

Reported by: adium Owned by: nobody
Milestone: Adium 1.3 Component: Service/AIM
Version: Severity: normal
Keywords: Cc:
Patch Status:

Description

I am running the latest rev [17784] on 10.4.7 (using AIM)

It seems that when contacts sign off the inline (status notifier in message) and the growl alert both say "<contact> Came back" when a contact signs off. This happens even when the contact was not away when they sign off. I'm not sure but it seems to be happening mostly with meta contacts, but it might be any contact (I'll pay better attention next time). I'm guessing it has something to do with joscar, but I'm not sure so I won't mark it.

Change History (30)

comment:1 Changed 13 years ago by Chris Forsythe

Milestone: Needs feedback from users

We switched aim libraries to libgaim, does this still occur?

comment:2 Changed 13 years ago by Eric Richie

Milestone: Needs feedback from usersAdium X 1.0.3
Version: 1.0svn1.0.1

This is definitely still an issue because I'm seeing it myself. Assigning to 1.0.3 for now but we can move it accordingly.

comment:3 Changed 13 years ago by Eric Richie

Milestone: Adium X 1.0.3Adium X 1.1

comment:4 Changed 13 years ago by Colin Barrett

Cc: evan@… added
Patch Status: None

Has anyone spent time debugging this? This is going to need a bit of time to debug, I suspect. Evan?

comment:5 Changed 13 years ago by Evan Schoenberg

I can't reliably reproduce this, though I've seen it before. Maybe it's client dependent? What is the remote contact using (protocol. client, version) when this happens?

comment:6 Changed 13 years ago by Eric Richie

I've definitely seen this with Adium on AIM. I'll watch my list and update if I see any others.

comment:7 Changed 13 years ago by Evan Schoenberg

To be clear: So other side is using Adium, too?

comment:8 in reply to:  7 Changed 13 years ago by Eric Richie

Replying to evands:

To be clear: So other side is using Adium, too?

You are correct sir.

comment:9 Changed 13 years ago by Matt

I had always assumed this was a bug on the other person's client, not having seen it happen to anyone using Adium. It makes more sense that it's something in the other person's client, but if that client is Adium, then it could be in libpurple/gaim. Sure they were using adium, edr?

comment:10 Changed 13 years ago by Eric Richie

Umm... unless David and Evan don't drink their own kool-aid... then yes, I'm quite sure. Like I said, I'll keep watching.

comment:11 Changed 13 years ago by Eric Richie

Version: 1.0.11.0.3

comment:12 Changed 13 years ago by Eric Richie

Also confirmed for PC AIM users. Appears when they go idle as well.

comment:13 Changed 13 years ago by Brady Lee

I have also seen this. Though in my case the user is using Trillian over MSN. It appears to happen only when his connection has dropped. Not when he manually clicks disconnect. I suspect it has to do with the automatic idle/away feature. has it only happens if we haven't spoken in 5 or 10 minutes.

comment:14 Changed 13 years ago by Chris Forsythe

pending: 0

We have known crashers addressed in 1.1, along with the ability to stop supporting 10.3 with the release of 1.1. Is this issue worth blocking that?

comment:15 Changed 13 years ago by Chris Forsythe

Milestone: Adium X 1.1Adium X 1.3

Moving out of the 1.1 milestone, if someone disagrees with me, please discuss.

comment:16 Changed 13 years ago by Evan Schoenberg

I did [20106] while investigating this, but it should not have changed this problem. I could not reproduce it with Adium [20106] to any of:

  • Adium [20106]
  • AIM for Mac
  • AIM for Windows

Can anyone detail steps to reproduce?

comment:17 Changed 13 years ago by Evan Schoenberg

That's [20107], actually

comment:18 Changed 13 years ago by Eric Richie

Sigh... just saw this again while talking to chris on aim... current svn... all he did was quit. We tried again and it didn't do it again. He had no available message up, not away, etc.

comment:19 Changed 12 years ago by Michael Richardson

This is happening to me on Google Talk and AIM and meta contacts when talking with people using Adium and Trillian. Anything I can do to help debug this?

comment:20 Changed 12 years ago by Julian Bennett Holmes

I've definitely seen this with the other side using Adium, and using other clients, on both OS X and Windows.

comment:21 Changed 12 years ago by Jordan

Milestone: Adium X 1.3Known problems which need steps to reproduce

Anyone who has seen this in the past:

  1. Have you seen it recently?
  2. Can you find any reason why it might be happening some times but not others?
  3. Do you remember if it only happens with metacontacts?

Perhaps this occurs when it's a metacontact and the user signs out of AIM when their status on AIM was 'away', but their status on another protocol (say MSN) was 'online'. If the metacontact was using different clients for each service, then quitting iChat (AIM) would result in the contact coming back since their status would then be 'online'. If the metacontact was connected to all services using Adium, assume that the statuses were the same as above (away in AIM and online in MSN), and Adium happens to disconnect from AIM first, they would then 'come back' since their status is online again - just prior to disconnecting from MSN as well.

comment:22 in reply to:  21 Changed 12 years ago by Matt

Replying to jas8522:

Anyone who has seen this in the past:

  1. Have you seen it recently?

Yes, the problem still persists with multiple contacts.

  1. Can you find any reason why it might be happening some times but not others?

Absolutely none. Off the top of my head I can think of two people who I see this with. One uses iChat...the other uses something on Windows (probably official). With regard to reproducing, that means I have no idea how to reproduce it.

  1. Do you remember if it only happens with metacontacts?

No, both of them are actually NOT metacontacts.

That said, I'm not 100% sure what I'm talking about is descriptive of the original problem. I very well could be getting 'signed off' in addition to the 'returned' alerts, but I don't display 'signed off' ones. IMO, it's a fairly minor issue and if it can't be tracked down, then it can't be tracked down. I don't see any reason why this needs much time invested in it.

comment:23 Changed 12 years ago by Jordan

Milestone: Known problems which need steps to reproduceNeeds dev review

Then this seems like a good place for it for now...

comment:24 Changed 12 years ago by Eric Richie

I just saw this again with David. We were talking on gtalk. I have him as a meta but none of his account were away. When he signed off it said he left the conversation (as is to be expected when gtalk disconnects...) and then it said he "came back", followed immediately by the disconnect. I too have no idea.

comment:25 Changed 12 years ago by Matt

Is everyone getting a "X Disconnected" too? I saw it just now, as my friend who wasn't away signed off. I got a "X Came Back" followed by an "X Disconnected". I *think* she may have had an available message up, and uses iChat. Non-meta contact too, which makes it even more confusing.

comment:26 Changed 12 years ago by Carlos Morales

comment:27 Changed 12 years ago by Robert

Cc: evan@… removed
Milestone: Needs dev reviewNeeds feedback from users
pending: 01

Still happening 1.2.5/1.3svn?

comment:28 Changed 12 years ago by Zachary West

Resolution: fixed
Status: newclosed

(In [23990]) Fix the world's most oddly placed bang, fixing a longstanding issue where the wrong event would fire for a contact. Fixes #468. Fixes #5551.

comment:29 Changed 12 years ago by Robert

Milestone: Needs feedback from usersAdium X 1.3

comment:30 Changed 12 years ago by Evan Schoenberg

(In [24152]) Backported [23997]: Fix the case of a metacontact which was available on connect going away causing the "come back" event to be fired. This would occur when the cache had a nil-entry and an event fires causing the cache to be updated before the meta contact is fully away, which triggers the "came back" event. Refs #468.

Backported [23990]: Fix the world's most oddly placed bang, fixing a longstanding issue where the wrong event would fire for a contact. Fixes #468. Fixes #5551.

Note: See TracTickets for help on using tickets.