Adium

Opened 14 years ago

Closed 13 years ago

Last modified 11 years ago

#5454 closed defect (fixed)

"Could not send: a connection error occured" when closing MSN window after sending message

Reported by: adium Owned by: nobody
Milestone: Component: Service/MSN
Version: Severity: major
Keywords: msn connection error window close Cc:
Patch Status:

Description (last modified by David Smith)

Problem

When you close a MSN chat window immediately after sending a message, a connection error will be reported.

Steps to reproduce Login to MSN Open a chat window Type a message Immediately after hitting "enter", close the window (using command+w) You'll get a 'Could not send message' back, and the message is either sent or not sent (can't figure that one out).

I think Adium doesn't send the message correctly when you close the window too soon.

The debug window output relevant is as follows:

16:01:52: (Libgaim: msn) S: SB 069: USR 1 OK mahrain@hotmail.com MahRain%20-%20...万古长青
16:01:52: (Libgaim: msn) C: SB 069: CAL 2 bartzonnenberg@hotmail.com
16:01:53: (Libgaim: msn) S: SB 069: CAL 2 RINGING 327365923
16:01:53: gaim closeChat:MSN.bartzonnenberg@hotmail.com
16:01:53: closeChat: Removed <<<AIChat: 0x123675d0>:MSN.bartzonnenberg@hotmail.com>> [<NSCFSet: 0x155cef0> ()]
16:01:53: (Libgaim: msn) S: SB 069: JOI bartzonnenberg@hotmail.com Bart%20
16:01:53: (Libgaim: msn) Processing queue
16:01:53: (Libgaim: msn) Sending message
16:01:53: (Libgaim: msn) C: SB 069: MSG 3 A 153
16:01:53: (Libgaim: msn) C: SB 069: MSG 4 U 96
16:01:53: (Libgaim: msn) C: SB 069: OUT
16:01:53: (Libgaim: msn) Switchboard with unassigned conversation
16:01:53: adiumGaimConvWriteConv: Received Message could not be sent because an error with the switchboard occurred: from bartzonnenberg@hotmail.com [512]
16:01:53: [AIChat: 11bbe4d0 initForAccount]
16:01:53: chatWithContact: Added <<<AIChat: 0x11bbe4d0>:<new>>> [<NSCFSet: 0x155cef0> (<AIChat: 0x11bbe4d0>:<new>)]
16:01:53: gaim openChat:<AIChat: 0x11bbe4d0>:MSN.bartzonnenberg@hotmail.com for MSN.bartzonnenberg@hotmail.com
16:01:53: *** Conversation error type 6 (bartzonnenberg@hotmail.com): Message could not be sent because an error with the switchboard occurred:
16:01:53: adiumGaimConvWriteConv: Received <FONT FACE="MS Sans Serif"><FONT COLOR="#000000">nee half 10</FONT></FONT> from bartzonnenberg@hotmail.com [2048]
16:01:53: (Libgaim: msn) destroy httpconn (0x12389340)
16:01:54: gaim closeChat:MSN.bartzonnenberg@hotmail.com
16:01:54: closeChat: Removed <<<AIChat: 0x11bbe4d0>:MSN.bartzonnenberg@hotmail.com>> [<NSCFSet: 0x155cef0> ()]
16:02:04: (Libgaim: msn) C: NS 000: PNG
16:02:04: (Libgaim: msn) S: NS 000: QNG 50

Machine details:

MacBook Pro 1,5GB of memory Mac OS X Tiger 10.4.7 (fully updated).

Change History (22)

comment:1 Changed 14 years ago by David Smith

Description: modified (diff)

fix up formatting a bit

comment:2 Changed 14 years ago by David Smith

paulwilde on irc says he's seen this

comment:3 Changed 14 years ago by Evan Schoenberg

Milestone: Adium X 1.0Adium X 1.0.1

Not a regression.

comment:4 Changed 14 years ago by John Lunney

I see this on a daily basis, using the latest beta version of Adium (1.0b14).

comment:5 Changed 13 years ago by David

Problem was not present for me up until upgrading to 1.0b16, now at b17, and problem is still present.

MacBook Pro, 1GB RAM, Mac OS X Tiger 10.4.8

comment:6 Changed 13 years ago by Chris Forsythe

Milestone: Adium X 1.2Good idea for "later"

Moving to the good idea milestone, move back individually if you intend to work on these.

comment:7 Changed 13 years ago by Jordan

Milestone: Good idea for "later"Needs dev review
Patch Status: None
Version: 1.0b111.1svn

Definitely occurs in all the versions since 1.0 final. I have confirmed that the message does indeed send every time I've received this, so it might be best to detect and simply not show the error. If any further debug logging is required, let me know.

comment:8 Changed 13 years ago by Jordan

Summary: Connection error when closing MSN window after sending message"Could not send: a connection error occured" when closing MSN window after sending message

comment:9 Changed 13 years ago by Jordan

Milestone: Needs dev reviewWaiting on libpurple

comment:10 Changed 13 years ago by dirksierd

don't know if it's still relevant mentioning, but I'm having this problem aswell, console says: May 3 17:46:22 Dirk-Sierd /Applications/Adium.app/Contents/MacOS/Adium: doClip: empty path. But i'm getting this message anyhow all the time someone gets send / received. (#6847)

comment:11 Changed 13 years ago by Jordan

Version: 1.1svn1.0.2

General problem -> definitely not SVN specific, so setting back to last release version.

comment:12 Changed 13 years ago by joonas

I have this problem too. Even with new 1.0.3. version. I have G4 and 10.4.9.

comment:13 Changed 13 years ago by Jordan

Version: 1.0.21.0.3

Interestingly if you're using Skype software and you attempt to close a message window directly after (seems like 1second) sending a message it refuses to close and gives a system beep. Almost exactly as if they are trying to prevent something similar to what is happening here with the MSN connectivity.

I thought it was an interesting point to mention... it leads me to believe that either they've got a similar problem with the implementation of their messaging services as libpurple does with the MSN servers or there's something odd going on with the way Cocoa is currently handling connectivity. The latter guess also seems to tie in to the fact that I haven't heard of a single person using Pidgin (and couldn't find a related ticket on the Pidgin trac) encountering this problem.

Any thoughts?

comment:14 Changed 13 years ago by Michael Stevens

I'm not an adium user, but I was googling for error messages.

I'm frequently getting "Message could not be sent because an error with the switchboard occurred" when trying to send messages to MSN contacts on gaim and pidgin.

comment:15 Changed 13 years ago by Jordan

mstevens - I believe there was some nasty server issues related to MSN connectivity over the last few days. It seems to be resolved as of about noon yesterday... hopefully this is the case with you as well!

comment:16 Changed 13 years ago by Michael Stevens

I've been seeing this for quite a while, so I don't think that's the same problem.

The messages always actually seem to go through, I just get an error as well.

comment:17 Changed 13 years ago by radioharris

This problem always happens for me since Adium 0.6 Please write us a patch !

comment:18 Changed 13 years ago by radioharris

In the column Milestone of this ticket there is : Waiting on libpurple. But Proteus also uses this library but the bug is not present... so it seems to be specific to Adium...

comment:19 Changed 13 years ago by Eric Richie

This should now be fixed in libpurple. We'll be able to see if that carries through to us once we merge the new version.

comment:20 Changed 13 years ago by Eric Richie

http://cia.vc/stats/project/pidgin/.message/d0381 for those of you playing at home.

comment:21 Changed 13 years ago by David Smith

Resolution: fixed
Status: newclosed

(In [19783]) Updated libpurple to, if I'm understanding how this works correctly, c64484e549f605c8959a21553d3eb5aab736b69c. Silly monotone. Anyway, this fixes #5454 and a file transfer issue; possibly some other things as well

comment:22 Changed 11 years ago by (none)

Milestone: Waiting on libpurple

Milestone Waiting on libpurple deleted

Note: See TracTickets for help on using tickets.