Adium

Opened 15 years ago

Closed 14 years ago

Last modified 11 years ago

#532 closed defect (fixed)

Can't paste links into an inputline

Reported by: boredzo Owned by: anybody
Milestone: Adium X 1.0 Component: Adium Core
Version: Severity: normal
Keywords: paste hyperlink link input inputline field Cc: evan.s@…
Patch Status:

Description

when a link is copied (e.g. from an Adium text window), pasting into an inputline in an Adium chat window strips the link.

this is reproduceable in 0.90svn, [12213].

Change History (4)

comment:1 Changed 15 years ago by Evan Schoenberg

Cc: evan.s@… added

Not a bug... we paste plaintext by default. Hold option while pasting to paste formatted.

Of course, perhaps misguided functionality. Right now, the paste formatted is hidden until you press option. Perhaps it should be a separate menuitem at all times?

comment:2 Changed 14 years ago by Chris Forsythe

field_haspatch: 0
Milestone: Adium X 1.0

comment:3 Changed 14 years ago by Evan Schoenberg

Resolution: fixed
Status: newclosed

(In [14152]) The Paste menu item now pastes with formatting. The item under it is now "Paste and Match Style" (cmd-option-v). Closes #532 and makes our behavior more system-standard.

comment:4 Changed 11 years ago by Zachary West

Component: Core AdiumAdium Core
Note: See TracTickets for help on using tickets.