Adium

Opened 14 years ago

Closed 11 years ago

Last modified 10 years ago

#500 closed defect (fixed)

Contacts can not belong to more than one group

Reported by: terry@nuvio.com Owned by: Catfish_Man
Milestone: Adium 1.4 Component: Adium Core
Version: 1.0.1 Severity: normal
Keywords: contacts multiple groups Cc: irabinovitch@…
Patch Status:

Description

Our jabber server has everyone set up in different groups for us and some people belong to more than one group (so a message to the whole group will include them). It appears that Adium will only allow/display a contact in one group, regardless of how they are set up on the jabber server. This really plays havoc if you have a group that is an 'All Employees' group that everyone is in as well as their respective departments.

Change History (26)

comment:1 Changed 14 years ago by catfish_man

  • Milestone changed from Adium X 0.81 to Adium X 0.90

Bumping to 0.9

comment:2 Changed 14 years ago by durin42

  • Milestone changed from Adium X 0.90 (Old) to Adium X 1.0

I'm not sure how to handle this cleanly, bumping to 1.0 for further thought.

comment:3 Changed 14 years ago by cshbell

This is also discussed in 592, where it's a problem for people who use Sametime with company-wide messaging. It would be nice to see this given some more attention.

comment:4 Changed 14 years ago by anonymous

This ticket is one year old, I don't see why it is such a big problem. Pretty much every other client has no problem with that. Just allow us to add the same contact a second time or allow a contact to have multiple entries with the same value under Accounts when hitting CMD+I. If you really need something that distinguishes them, I'd be happy to have different aliases (so it's always the same account data, but the alias is not always the same).

comment:5 Changed 14 years ago by tick

  • field_haspatch set to 0
  • Milestone changed from Adium X 1.1 to Waiting on libgaim

comment:6 Changed 13 years ago by irabinov

Previous comments on this bug suggest it is a libgaim issue. Recent versions of GAIM (2.0.0beta3.1 Ubuntu) appear to have support for this. Has libgaim added this functionality in 2.x ?

comment:7 Changed 13 years ago by irabinov

I've just tested stock 1.5.0 of Gaim and it appears to have this bug resolved as well. Has anyone looked into how Gaim handles this situation? Is it definately a libgaim issue?

comment:8 Changed 13 years ago by irabinov

  • Cc irabinovitch@… added

comment:9 Changed 13 years ago by evands

  • Milestone changed from Waiting on libgaim to Adium X 1.2

This is definitely not a libgaim issue specifically, although it is a bit cumbersome to deal with I believe.

comment:10 Changed 13 years ago by irabinov

  • Patch Status set to None
  • Version changed from 0.81 to 1.0.1

Does Adium participate in any bounty programs? Would kicking some funding at this bug help at all?

comment:11 Changed 13 years ago by evands

We don't at present, but we really should set something up like that. We could start with just a wiki page listing tickets and bounties associated with them and then figure out something more elegant -- irabinov, do you know of any bounty systems which projects can join?

comment:12 Changed 13 years ago by irabinov

Either would work. Ubuntu seems to handle it on otheir own website, Asterisk bounties appear to get posted on the mailing list and on the voip-info.org. Other projects appear to use bountysource.com. I'm sure there are other programs out there, these are just the ones I've spotted with some quick googling.

comment:13 Changed 13 years ago by irabinov

I'll be happy to start the bounty program, by pledging $50 to anyone who patches adium to resolve this bug.

comment:14 Changed 13 years ago by tick

  • Milestone changed from Adium X 1.2 to Good idea for "later"

Moving to the good idea milestone, move back individually if you intend to work on these.

comment:15 follow-up: Changed 12 years ago by evands

  • Milestone changed from Good idea for "later" to Adium X 1.2.1
  • pending set to 0

Once 1.2 is out the door, I'd like to see this made a priority.

comment:16 in reply to: ↑ 15 Changed 12 years ago by irabinovitch

Awesome. I'd still be willing to kick in the bounty for it.

comment:17 Changed 12 years ago by evands

  • Milestone changed from Adium X 1.2.1 to Adium X 1.3

This will require a significant rewrite.

comment:18 Changed 12 years ago by djmori

comment:19 Changed 12 years ago by Catfish_Man

  • Milestone changed from Adium X 1.3 to Adium X 1.4
  • priority changed from normal to high

I don't see this happening in the 1.3 time frame. Too invasive, too delicate. Definitely needs to be a priority for 1.4 though. As we emphasize XMPP more, we'll start getting more and more complaints about this.

comment:20 Changed 11 years ago by Robby

This probably also relies on #5707.

comment:21 Changed 11 years ago by Catfish_Man

  • Owner changed from anybody to Catfish_Man
  • Status changed from new to assigned

Might as well assign this to me since I've been working on it.

comment:22 Changed 11 years ago by technodolt

Is there any concept of issue voting on here?

comment:23 Changed 11 years ago by Catfish_Man

No, but I'm pretty obsessed with getting this working, so I wouldn't worry about it.

comment:24 Changed 11 years ago by Catfish_Man

  • Resolution set to fixed
  • Status changed from assigned to closed

This is fixed. I will file a new bug for adding UI for putting them in more than one group.

comment:25 Changed 11 years ago by zacw

  • Component changed from Core Adium to Adium Core

comment:26 Changed 10 years ago by Robby

Ticket #13918 has been marked as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.