Adium

Opened 14 years ago

Closed 13 years ago

Last modified 10 years ago

#4770 closed defect (fixed)

Privacy settings are not saved after quitting and are reset

Reported by: katlynnhope@yahoo.com Owned by: evands
Milestone: Adium X 1.0.3 Component: libgaim-general
Version: Severity: normal
Keywords: privacy Cc:
Patch Status:

Description

I try to set the privacy for my accounts and each time Adium is quit and relaunched, the privacy settings all go back to "block certain contacts" for all the accounts when in fact I have previously set it to allow only contacts on my contact list for one or more accounts.

-- Maybe there needs to be a nice "Save Settings" button/command for the Privacy Settings ?

Change History (22)

comment:1 Changed 14 years ago by Chris Forsythe

Milestone: Adium 1.0 - After beta 1

Needs to be duplicated

comment:2 in reply to:  1 ; Changed 14 years ago by anonymous

Replying to tick:

Needs to be duplicated

http://trac.adiumx.com/ticket/4440 It is duplicated :) And I updated to 1.0b7 and the privacy settings are still reset after Adium quits/relaunches

comment:3 in reply to:  2 Changed 14 years ago by katlynnhope@…

Replying to anonymous:

Replying to tick:

Needs to be duplicated

http://trac.adiumx.com/ticket/4440 It is duplicated :) And I updated to 1.0b7 and the privacy settings are still reset after Adium quits/relaunches

Oops. Apparently, it's only with Yahoo! So, might just be Yahoo. Why does Yahoo suck?

comment:4 Changed 14 years ago by anonymous

Same problem here, except that it's with one of my aim accounts and not yahoo, except I don't even need to restart for the changes to disappear, I simply need to close the "Privacy Settings" window and open it back up again.

comment:5 Changed 14 years ago by tickswifey

Milestone: Adium 1.0 - After beta 1Adium X 1.0

comment:6 Changed 13 years ago by Evan Schoenberg

Milestone: Adium X 1.0Adium X 1.0.1

I can't reproduce this. Can someone please find steps to reproduce?

comment:7 Changed 13 years ago by Chris Forsythe

Milestone: Adium X 1.0.1Needs feedback from users

comment:8 Changed 13 years ago by Eric Richie

Resolution: worksforme
Status: newclosed

No response from user.

comment:9 Changed 13 years ago by jkorn

Greetings!

I have the exact same problem when modify Privacy Settings for Yahoo! accounts. I am connected to two different Yahoo! accounts at the same time - I set different privacy settings for each account - one is set to "Block certain contacts" and the other is set to "Allow only contacts on my contact list". If I restart Adium X, both accounts' privacy settings are reset to "Block certain contacts." I've had the problem on all versions of Adium X since Privacy Settings were first introduced.

I am currently running Adium X 1.0b14 on Max OS X 10.4.7 and it drives me crazy given the huge amount of spim I get.

Please fix! :)

Thanks!!!

comment:10 Changed 13 years ago by Eric Richie

Milestone: Needs feedback from usersNeeds dev review
priority: highnormal
Resolution: worksforme
Severity: criticalnormal
Status: closedreopened
Version: 1.0b51.0b14

We should probably look into this more from the sounds of it...

comment:11 Changed 13 years ago by Cernunnos

Same problem here with Adium 1.0 final.

I have two accounts, one ICQ and one MSN. When I set my ICQ privacy to "Allow only contacts on my contact list" and reconnect to ICQ the setting is gone.

What's very interesting is that i have exactly the same problem/behaviour under Windows with Gaim 1.5.

Is it possible that this settings is stored somewhere on the ICQ server or reseted from the ICQ server ? Can you make a version with log statement every time this settings change ?

The problem is easy to reproduce and I would be very happy to help you in testing if you want.

Thanks for your great work !

comment:12 Changed 13 years ago by Cernunnos

Ticket #5740 can be merged too (same problem)

comment:13 Changed 13 years ago by Good Vs. Evil

I am having this exact same problem with ICQ using Adium 1.0.1. I set my ICQ settings on multiple accounts to 'Only allow contacts on my contacts list' (since so much spam gets sent through ICQ authorization messages). Whenever I restart Adium -- even after cleanly quitting the application -- my privacy settings are reset to "Block certain contacts" and I'm hit with a bunch of ICQ spam before I can set it back.

comment:14 Changed 13 years ago by debuskjt

I'm having the exact same problem in Adium 1.0.2 in OS X 10.4.9. Every time I quit and restart Adium the Privacy Settings revert back to "Block certain contacts" from "Allow only contacts on my contact list." I use Google Talk, AIM, and Yahoo! Is it one of the protocols not honoring my preferences on their end?

Can you save my preference and then just resend it to each active service provider on connect?

comment:15 Changed 13 years ago by Evan Schoenberg

Component: Nonelibgaim-general
Milestone: Needs dev reviewAdium X 1.0.3
Owner: changed from nobody to Evan Schoenberg
Patch Status: None
Status: reopenednew

comment:16 Changed 13 years ago by Evan Schoenberg

Resolution: fixed
Status: newclosed

(In [19302]) Sometime before we had any privacy stuff implemented, we set newly loaded or created GaimAccounts to default to GAIM_PRIVACY_DENY_USERS for their privacy setting. Not only is that not needed with our shiny privacy stuff... it's actively harmful. Services which store the privacy list and settings locally -- such as Yahoo -- end up reverting on each launch to GAIM_PRIVACY_DENY_USERS regardless of the user's preference.

Fixes #4770

comment:17 Changed 13 years ago by Evan Schoenberg

(In [19305]) Merged [19300] (AINetworkDidChange notification), [19301], (inform libgaim of network changes, and enable nat-pmp support in adium-1.0), and [19302] (don't force Gaim accounts to Block Certain Contacts on load; fixes #4770

comment:18 Changed 11 years ago by mat79

i see the same thing in Adium 1.3.2 on OS X 10.5.5. The privacy settings are allways set back to the previous state after relaunching the app.

My MSN Settings are allways back to "block certain contacts"

comment:19 Changed 11 years ago by AUSTraveler

We also see the same behavior on Adium 1.3.2 where restarting Adium causes the privacy settings to revert back. However, we do not see mat79's behavior related to MSN settings. For us, that reverts to Allow Anyone just like the others.

comment:20 Changed 11 years ago by rsmartin

This hasn't been fixed, and is a royal pain. Using 1.3.2. No add-ins. All of my contacts are yahoo contacts. My accounts are yahoo accounts. Every single time I log out, when I log back in the privacy setting has reverted to "Block Certain Contacts" even though I have it set in Yahoo to allow only contacts in my list AND I keep setting Adium to "Allow Only Contacts On My List" - I discovered this because I keep getting spam through one of my two yahoo accounts.

Please fix this! Broken "privacy" options means they don't exist. Thank you.

comment:21 Changed 10 years ago by matto

This is present in 1.3.6. I have no add-ins. Using Mac OS 10.5.8. My AIM privacy settings are getting set to Allow Anyone every time I go away or restart the program. I can't afford to wait for this to be fixed - privacy issues are critical - and I have no choice but to use a different program in the meantime.

comment:22 Changed 10 years ago by mennyj

I'm having the same issue as matto. I'm using Adium 1.3.6 on Mac 10.5.8, and now (as of the past week, maybe) every time I re-start Adium, my privacy settings change to allow everyone to see me, whereas my setting is for my contacts only. When I go to the privacy settings area, the actual setting does not appear to be changed -- it still says "Allow only contacts on my contacts list" -- but that is not the case. I have to toggle it off that setting and then back again, in order for it to really take effect.

Thanks in advance for a quick fix! I don't want to have to change clients.

Note: See TracTickets for help on using tickets.