Adium

Opened 13 years ago

Closed 12 years ago

Last modified 11 years ago

#4740 closed enhancement (fixed)

View menu uses checks next to Show commands instead of dynamically changing to Hide

Reported by: earthsaver@mac.com Owned by: nobody
Milestone: Adium 1.3 Component: None
Version: 1.0b5 Severity: major
Keywords: view menu Cc:
Patch Status:

Description

I wonder why you chose to use checkmarks next to Show commands, such as Show Offline Contacts, instead of dynamically changing these commands to read "Hide" instead. I encourage the latter for a cleaner interface.

Change History (16)

comment:1 Changed 13 years ago by edr1084

  • Milestone set to Sometime after 1.0

comment:2 Changed 13 years ago by tick

  • Milestone changed from Good idea for "later" to Adium X 1.2
  • Severity changed from normal to blocker

I think the complaint here is valid. Look at the view menu in iTunes for instance, the described behavior occurs there.

However, is this the correct behavior? One has to wonder if my grandmother would get lost trying to find a way to disable showing the contact list because the text for it changed to hide, but "it was just there a minute ago". Decide before 1.2 and close or fix.

comment:3 Changed 12 years ago by evands

  • Patch Status set to None
  • pending set to 0

Show/hide rather than checks follows the way most applications are behaving as of 10.4.

comment:4 Changed 12 years ago by tick

I'd like to address this in 1.3 or 1.4 actually. Reason being is that we have enough on our plates with the mass amount of stuff for the SoC stuff.

What does everyone else think?

comment:5 Changed 12 years ago by edr1084

I agree. This certainly isn't hurting anyone so let's go ahead and push it back.

comment:6 follow-up: Changed 12 years ago by zacw

I prefer the checkmarks over a word change anyhow!

comment:7 Changed 12 years ago by tick

  • Milestone changed from Adium X 1.2 to Adium X 1.3

comment:8 in reply to: ↑ 6 Changed 12 years ago by tick

Replying to zacw:

I prefer the checkmarks over a word change anyhow!

What if we had a checkmark on the enabled state, and changed the checkmark and text on disabled state?

comment:9 follow-up: Changed 12 years ago by evands

The Mac OS X standard in 10.4 and 10.5 is to use Show Foo and Hide Foo, without checks. That's what we should do, too.

comment:10 in reply to: ↑ 9 Changed 12 years ago by cbarrett

Replying to evands:

The Mac OS X standard in 10.4 and 10.5 is to use Show Foo and Hide Foo, without checks. That's what we should do, too.

Err, really? I'm checking out Mail.app here and it's got "Organize by Thread" with a checkmark next to it. Where are you taking your hints from?

comment:11 Changed 12 years ago by evands

Show/Hide exclusively: Safari, Finder, Terminal, iTunes
Context dependent: Mail, Preview, TextEdit

The Mail "Organize by Thread" is because "Show Threads" vs "Hide Threads" is awkward. Show/Hide Mailboxes changes text, as does Show/Hide Deleted Messages, Toolbar, Fonts, and Colors. TextEdit uses Show/Hide for fonts and colors (panels) but checks for items related to the view.

comment:12 Changed 12 years ago by jas8522

Is this still a good idea, now that we've got a sort of hierarchy to the items in the view menu? ie: this could be confusing to do for the "Hide certain contacts" part...

comment:13 Changed 12 years ago by evands

I think it does still make sense. When showing all contacts, we should have:

Hide certain contacts
  Hide Offline Contacts <disabled>
  Show Away Contacts <disabled>
  etc..

and when hiding certain contacts, it changes to:

Show all contacts
  Hide Offline Contacts
  Hide Away Contacts
  etc.

comment:14 Changed 12 years ago by evands

  • Resolution set to fixed
  • Status changed from new to closed

(In [23254]) Use Show/Hide verb menu items rather than constant-title menu items with checkmarks to indicate enabled/disabled state in the View menu, bringing us in line with most Mac OS X apps. Fixes #4740

Also, moved the contact counting menu items to their own section of the view menu, which improves readability and scannability of the menu items.

comment:15 Changed 11 years ago by zacw

(In [26363]) Revert [23254]'s hatred of the -setState on NSMenuItems. The view menu is a mess this way; the checkmarks make it a lot easier to see what's going on (or explain to somebody what needs to occur). Refs #4740.

I prefer my blendens sufficiently aused.

comment:16 Changed 11 years ago by berdan

(I started writing this comment before zac's reversion, so it refers to the old behaviour.)

Having lived with this feature for a year now, I still find it confusing. You can't easily grasp the current status just by watching the menu items. "Does this mean that Away users are shown, or does clicking show them?". I'd be a lot happier with the menu item displaying the off state ("Hide offline users") and having a checkmark toggle on it.

Show/Hide might be more common in OS X, but in a list such as this (1.4svn has six intended menu items with hide or show in them) it's just confusing.

Note: See TracTickets for help on using tickets.