Adium

Opened 14 years ago

Closed 13 years ago

Last modified 12 years ago

#4711 closed defect (fixed)

Cached user icons use unreasonable amount of disk space

Reported by: Mike Kobb Owned by: nobody
Milestone: Component: None
Version: Severity: normal
Keywords: Cc:
Patch Status:

Description

Adium X 0.88

MacOS 10.4.7

Using AIM

Mockie (Brown - Alternate) message style

My user icon is taken from a .JPG file, with a section selected and cropped using the Adium interface. The piece of the file I have selected as my icon is about 348x348 pixels at the native resolution of the file, but of course Adium scales it down.

I noticed that each time Adium displays a user's icon, it seems to create a temporary TIFF version of the icon in ~/Library/Caches/Adium.

For most users' icons, this doesn't seem to be a big problem, because the icons coming over the network are small. But, for my own icon, it appears that the temporary TIFF is created at the icon's full original resolution (although respecting the crop), so that the TIFF for my icon is 196K!

When running Adium for many days with lots of messaging, I have seen the ~/Library/Caches/Adium folder take 400MB of disk space!

I would suggest that a different strategy be used that does not create a temporary version of the user's icon each time it's displayed in the window. Perhaps one instance could be shared?

Steps to reproduce: 1) In Photoshop or another editor, create a JPG file at 348x499 resolution. Save to a convenient location

2) In Adium, go to one of your accounts, and click "Choose Icon..." in the Personal tab.

3) Chose the JPG from step 1, and use the scale and drag controls to choose a square section of the image that's nearly full-width.

4) Approve all the changes, and send some messages. It's important that the other end of the conversation reply, since the TIFF files are generated each time a different icon is displayed, and at least in the message style I use, that's only when conversation switches from one party to the other.

5) Have a look in ~/Library/Caches/Adium/Default, and for each instance of the icon displayed in the message window, you should see a file named something like "TEMP-241L5Z.tiff", with a size of a few hundred K.

Change History (7)

comment:1 Changed 13 years ago by Eric Richie

Milestone: Needs feedback from users
Resolution: invalid
Status: newclosed

Your ticket references Adium .88. The current stable release is .89.1 and the current AdiumBeta is 1.0 b7. Please upgrade Adium and reopen this ticket if it's still a problem.

comment:2 in reply to:  1 Changed 13 years ago by anonymous

Resolution: invalid
Status: closedreopened

Updated to 0.89.1 as requested (Adium did not prompt me to upgrade, by the way, even though it was set to check automatically).

The problem is now slightly different. It no longer creates the large TIFF for each of my messages, but still creates one for each incoming message. This is definitely an improvement, but I still don't think it should be creating so many duplicate files.

comment:3 Changed 13 years ago by Eric Richie

Milestone: Needs feedback from usersNeeds Feedback - Received

comment:4 Changed 13 years ago by yinon

This seems to affect my installation of Adium 1.0.2 as well. I left Adium open for 7 days and found roughly 8000 120KB TIFFs using up 1012 MB of space in my ~/Library/Caches/Adium/Default directory. Each cached TIFF had the same md5sum.

comment:5 Changed 13 years ago by Evan Schoenberg

Patch Status: None

Related to #6732

comment:6 Changed 13 years ago by Evan Schoenberg

Resolution: fixed
Status: reopenedclosed

(In [19459]) This reuses cached images across chats if appropriate (e.g. for an account when that account is in multiple chats [common] or a contact is in multiple chats [less common]) and deletes temporary images as soon as they are not being used. Images are also written out as png instead of tiff.

Temporary images would be cleared when the chat closes except that AIWebKitMessageViewController is never deallocated at present do to the leak of AIMessageTabViewItem I described earlier on adium-devl.

Finally, status icons, which may be used by some message styles, are only written out to disk if they are actually going to be used.

Fixes #4711. Fixes #6732. Both techincally pending the leak fix, however, but we won't release 1.1 without hunting that down.

comment:7 Changed 12 years ago by (none)

Milestone: Needs Feedback - Received

Milestone Needs Feedback - Received deleted

Note: See TracTickets for help on using tickets.