Adium

Opened 14 years ago

Closed 12 years ago

Last modified 11 years ago

#4383 closed patch (fixed)

Add blocked status icon to the default (iBubble) set

Reported by: djmori Owned by: catfish_man
Milestone: Adium 1.3 Component: Xtras
Version: Severity: minor
Keywords: Cc:
Patch Status: Accepted

Description

A "blocked user" icon is yet to be added to this pack. I'l suggest checking the other default ones too as well.... I currently modified the packs myself, but I thinkg original authors should take care of this.

Attachments (7)

Picture 1.png (7.5 KB) - added by Carlos Morales 14 years ago.
Screenshot of the issue
blocked.png (639 bytes) - added by Jordan 12 years ago.
Blocked icon for iBubbles
iBubble Status.AdiumStatusIcons.zip (10.3 KB) - added by Jordan 12 years ago.
Entire set with the new blocked icon and updated plist.
chat bubbles blocked.png (701 bytes) - added by Jordan 12 years ago.
Blocked icon for chat bubbles
Chat Bubbles.AdiumStatusIcons.zip (33.0 KB) - added by Jordan 12 years ago.
Entire chat bubbles set with update plist
Stockholm.AdiumStatusIcons.zip (40.2 KB) - added by Jordan 12 years ago.
This one I'm not a huge fan of, but I think it might be better than the default one since it 'fits in' with this set.
blocked.2.png (549 bytes) - added by Jordan 12 years ago.
stockholm blocked icon

Download all attachments as: .zip

Change History (19)

Changed 14 years ago by Carlos Morales

Attachment: Picture 1.png added

Screenshot of the issue

comment:1 Changed 13 years ago by Eric Richie

Component: Adium UIXtras
Milestone: Adium X 1.0

comment:2 Changed 13 years ago by Chris Forsythe

Owner: changed from nobody to David Smith
Severity: normalblocker

See if you can get this taken care of cfm

comment:3 Changed 13 years ago by Paul Wilde

Summary: iBubble status icons (now shiped with adium) issueStatus icons that ship with Adium have no blocked state

comment:4 Changed 13 years ago by David Smith

Milestone: Adium X 1.0Adium X 1.0.1

Not a regression exactly, and not a huge issue (correct me if I'm wrong on that). I don't think we should block on it, although I did post a forum thread asking authors to update their icon packs.

comment:5 Changed 13 years ago by Chris Forsythe

Milestone: Adium X 1.0.1Sometime after 1.0

comment:6 Changed 12 years ago by Robert

Milestone: Good idea for "later"Adium X 1.2.x
Patch Status: None
pending: 0
Severity: blockermajor

I think this is quite a problematic bug as some users will think that blocking doesn't work.

comment:7 Changed 12 years ago by Eric Richie

Severity: majorminor

As shown in the screenshot, we do indeed have an icon for 'blocked' that shows if the xtra author has not included one. The clear gem with a red 'x' is the blocked icon, not an icon signifying that something is missing or anything like that. The issue of the icon looking different than the rest is purely cosmetic. I don't see how this is a 'major' issue.

David, I'll leave this one to your judgement.

comment:8 Changed 12 years ago by Jordan

Milestone: Adium X 1.2.xAdium X 1.3
Summary: Status icons that ship with Adium have no blocked stateAdd blocked status icon to the default (iBubble) set
Version: 1.0svn

I just made this for blocked - I think it gets the point across. Including the new image, and the updated iBubble set with the blocked icon. We may as well do this at the same time as the dock icon and emoticons update planned for 1.3 (I'm working on those with a couple of xtra authors).

Changed 12 years ago by Jordan

Attachment: blocked.png added

Blocked icon for iBubbles

Changed 12 years ago by Jordan

Entire set with the new blocked icon and updated plist.

comment:9 Changed 12 years ago by Jordan

Type: defectenhancement

Changed 12 years ago by Jordan

Attachment: chat bubbles blocked.png added

Blocked icon for chat bubbles

Changed 12 years ago by Jordan

Entire chat bubbles set with update plist

Changed 12 years ago by Jordan

This one I'm not a huge fan of, but I think it might be better than the default one since it 'fits in' with this set.

Changed 12 years ago by Jordan

Attachment: blocked.2.png added

stockholm blocked icon

comment:10 Changed 12 years ago by Jordan

Patch Status: NoneInitially Included
Type: enhancementpatch

Not a 'patch' per se, but all that is needed to fix this is attached.

comment:11 Changed 12 years ago by Evan Schoenberg

Resolution: fixed
Status: newclosed

(In [23253]) Added Stockholm, iBubble, and Chat Bubbles blocked status icons from jas8522. Fixes #4383. All status icon packs can use the default blocked status icon if they don't specify one, but these icons fit their packs better than the default one.

comment:12 Changed 11 years ago by Robert

Patch Status: Initially IncludedAccepted
Note: See TracTickets for help on using tickets.