Adium

Opened 14 years ago

Closed 12 years ago

Last modified 12 years ago

#4161 closed defect (fixed)

Empty Jabber message body is displayed incorrectly

Reported by: delta407@lerfjhax.com Owned by: am
Milestone: Adium 1.2.5 Component: Service/XMPP (Jabber)
Version: Severity: minor
Keywords: Cc:
Patch Status:

Description

Summary: Adium incorrectly displays a message conaining "<body/>" when an empty message is received. This may affect only empty-element tags -- that is, <body/> and not <body></body> -- however, both forms are defined to be equivalent.

Steps to reproduce:

  1. Use Adium to connect to a Jabber server.
  2. Have another Jabber user transmit the following: <message xmlns='jabber:client' from='user@domain/resource' to='tester@domain/Adium'><body/></message>

Expected behavior: An empty message is displayed, visually identical to receipt of a message containing "<body> </body>".

Actual behavior: A message is displayed, visually identical to receipt of a message containing "<body>&lt;body/&gt;</body>".

Change History (11)

comment:1 Changed 13 years ago by Eric Richie

Milestone: Sometime after 1.0

comment:2 Changed 13 years ago by Andreas Monitzer

Resolution: fixed
Status: newclosed

Doesn't occur in the Smack-based plugin, since it actually uses a proper XML parser.

comment:3 Changed 13 years ago by Arjen van Reeven

This behaviour returned when Smack was dropped.

comment:4 Changed 13 years ago by Eric Richie

Milestone: Good idea for "later"Summer of Code 07
Patch Status: None
Resolution: fixed
Status: closedreopened
Version: 0.891.1svn

comment:5 Changed 12 years ago by Jordan

Milestone: Summer of Code 07Needs feedback from users
pending: 1

Does this still happen with 1.2.3 or the 1.2.4 AdiumBeta?

comment:6 Changed 12 years ago by Arjen van Reeven

Able to reproduce this in 1.2.3. Adium displays '<body/>' when sending either an empty body tag (<body></body>) or a self-closing body tag (<body />).

comment:7 Changed 12 years ago by Jordan

Version: 1.1svn1.2.3

Any change with 1.2.4b2? (AdiumBeta)

The libpurple update might be parsing this differently now - which is why I ask.

comment:8 Changed 12 years ago by Arjen van Reeven

Still happens with 1.2.4b2

comment:9 Changed 12 years ago by Jordan

Milestone: Needs feedback from usersAdium X 1.2.5
Owner: changed from nobody to Andreas Monitzer
pending: 10
Status: reopenednew
Version: 1.2.31.2.4b2

comment:10 Changed 12 years ago by Evan Schoenberg

Resolution: fixed
Status: newclosed

(In [23210]) Ignore /BODY tags when decoding HTML. Fixes #4161

comment:11 Changed 12 years ago by Evan Schoenberg

(In [23211]) Merged [23210]: Ignore /BODY tags when decoding HTML. Fixes #4161

Note: See TracTickets for help on using tickets.