Adium

Opened 15 years ago

Closed 14 years ago

Last modified 13 years ago

#4 closed enhancement (fixed)

AIM file transfer instability/not working

Reported by: tick Owned by: somebody
Milestone: Adium X 1.0 Component: Service/AIM
Version: Severity: normal
Keywords: ft file transfer xfer fixedByJoscar Cc:
Patch Status:

Description

Sometimes AIM file transfer works. Sometimes it does not. Sometimes it goes and sits on the couch and takes a smoke break.

Change History (27)

comment:1 Changed 15 years ago by anonymous

Milestone: Adium X 0.90Sometime after 1.0

comment:2 Changed 15 years ago by David Smith

Keywords: transfer added

comment:3 Changed 15 years ago by David Smith

Keywords: ft, file transfer, file xferft file transfer xfer

comment:4 Changed 15 years ago by David Smith

Component: component1Core Adium

comment:5 Changed 15 years ago by Evan Schoenberg

Component: Core AdiumAIM

comment:6 Changed 15 years ago by uspam@…

Milestone: Sometime after 1.0Adium X 0.82
Severity: normalenhancement
Version: 0.81

I'd be your unholy slave if aim file xfers worked and I could ditch that silly iChat once and for all.

comment:7 Changed 15 years ago by Chris Forsythe

Milestone: Adium X 0.82Sometime after 1.0

DO NOT CHANGE MILESTONES TO BUGFIX RELEASES ON FEATURES

comment:8 Changed 15 years ago by anonymous

IMHO, this bug is more important than anything else currently under development for Adium. UI polish and bugfixes are great, but what's the point if you don't support core IM functionality?

I'm sorry, it's just not worth it to launch iChat every time I need to send a file. I'm going to stop using Adium until you properly support file transfer on AIM and Bonjour. Any idea how long it will take? Why isn't this a higher priority?

comment:9 Changed 15 years ago by Wengero

FileTransfer is right there in the side bar trac nav, that sould explain everything

comment:10 Changed 15 years ago by Scott

Sounds to me like the libgaim folks need to get with it on this one. I also think it should be higher on your priority list. Whether you can do anything about it directly or not. Releasing 1.0 without it seems pretty idiotic, since 1.0 should be a fairly complete implementation of IM functionality. Also, File Transfer isn't an "Advanced Feature". It has been around in all of the IM applications and protocols since very early on.

comment:11 Changed 15 years ago by adamiser

Please read FileTransfer. While I'd love for all (currently) 500 tickets to be resolved with the 1.0 release, I doubt it will happen. It's not about us being idiots. You need to remember that there are very few developers on this project working in their spare time with no compensation and that there are very many users each with individual needs and requests.

Demanding that things happen faster or according to your personal prioritization is rude and will have no positive impact on this project. Contact me via email if you're willing to pay us full time salaries for our work on this application or if you have patch files for open issues and requests.

comment:12 Changed 14 years ago by Synapse

Hopefully the Gaim summer of code stuff has helped on this one. I wouldn't know, I don't really use AIM that much.

comment:13 Changed 14 years ago by al_qahtani@…

If one attempts to transfer a file around 10-12mb or greater to an AOL user the transfer will eventually abort without completing. The same may also occur if sending to a .Mac user, though I haven't tried.

The error may also occur if sending files over other protocols, but I have not tested it. Just attempt sending a 15mb file; it will likely abort around 12mb. I cannot remember, but it may appear as if the other side canceled, though they didn't.

comment:14 Changed 14 years ago by michelle.kurmas@…

for some contacts, AIM file transfer will work and for some contacts it won't. I can get the tranfer to work for those contacts if I fire up iChat, so the problem isn't with the transfer. This is extrememly frustrating, hopefully an solution can be found soon.

comment:15 Changed 14 years ago by jacob.wadenpfuhl@…

Mac OS 10.2.8 PowerBook G4

Adium just crashes everytime I try to use file tranfer...do you guys have a fix for this coming anytime soon?

comment:16 Changed 14 years ago by David Smith

field_haspatch: 0

File transfer on 10.2.x will never work properly. It will very likely be improved for version 1.0, but 1.0 will not run on 10.2

comment:17 Changed 14 years ago by Chris Forsythe

The fix will not be supported on 10.2.8. Update your OS.

comment:18 Changed 14 years ago by skrauntor

I've just updated from 0.88 to 0.89 with hopes that this bug of transfering file to AIM is fixed.

previously the file would transfer but just before it finished, the app would crash-n-burn. once i can find a victim to test this again, i will...and give an update

peace.respect skrauntor

10.4.4 | 500Mhz Power PC G4 | 1.12 GB SDRAM

comment:19 Changed 14 years ago by David Smith

0.89 has no file transfer related changes. 1.0 will.

comment:20 Changed 14 years ago by Luke

I can transfer with AIM and MSN no problem. The only problems I have are when transfering with Trillian users. It never works, no mater what protocal they are using. He can transfer with other AIM and MSN users, just when we go between Adium X and Trillian it fails.

comment:21 Changed 14 years ago by alexius

I have the ame problem, specifically with Trillian. This goes both for sending and recieving, and happens even with the latest version of Trillian.

comment:22 Changed 14 years ago by Evan Schoenberg

Keywords: fixedByJoscar added
Milestone: Sometime after 1.0Adium X 1.0

comment:23 Changed 14 years ago by David Smith

Milestone: Adium X 1.0

demilestoning fixedByJoscar, we can just do a keyword search after the merge.

comment:24 Changed 14 years ago by Augie Fackler

Resolution: fixed
Status: newclosed

(In [15524]) Merge joscar to trunk, causing much rejoicing. Fixes #2377. Fixes #2488. Fixes #2463. Fixes #2413. Fixes #2231. Fixes #2230. Fixes #4. Fixes #2903.

comment:25 Changed 14 years ago by wengero

Milestone: Adium X 1.0

comment:26 Changed 14 years ago by chasmis@…

Resolution: fixed
Status: closedreopened

File transfer has NEVER worked for me until today. And today it worked miraculously, but I noticed a more direct bug: When being sent a file via AIM (in this case, both times, it was an MP4 video file), I can open it directly from Adium, play it through completely no problem, but once the video finishes (reaches it's last frame), adium crashes. Strange, indeed. It happened twice, different video, but from same user (same person sending and same person receiving each time.). Love Adium, eternal.

comment:27 Changed 14 years ago by David Smith

Resolution: fixed
Status: reopenedclosed
Note: See TracTickets for help on using tickets.