Adium

Opened 14 years ago

Closed 9 years ago

Last modified 8 years ago

#3590 closed enhancement (fixed)

Disable event alerts for individual contacts or groups

Reported by: enakamura@gmail.com Owned by:
Milestone: Adium 1.5 Component: Events
Version: Severity: normal
Keywords: Cc:
Patch Status:

Description

It would be very useful if there was an easy way to disable event alerts for certain users. As it stands, it's only possible to set general alerts for all users, and individual alerts that activate *in addition to* the general alerts. I.e. if you have a general Growl alert for the "Contact Signs On" event, and an individual sound alert for when a specific user signs on, both the Growl and the sound alerts will trigger when he comes on.

However when you want to *ignore* all notifications from a certain user, there is no easy way to do so unless you disable the general alerts and set individual alerts for everybody except the one you want to ignore, which is a huge hassle if you have a large list.

I think it would be logical to have a tickbox in the user's Get Info window that disables general alerts for that particular user. When that option is selected the individual alerts for that user would trigger *instead* of the general alerts, as opposed to *along with*.

Change History (13)

comment:1 Changed 13 years ago by edr1084

  • Milestone set to Sometime after 1.0

comment:2 Changed 12 years ago by jas8522

  • Milestone changed from Good idea for "later" to Adium X 1.4
  • Patch Status set to None
  • pending set to 0
  • Summary changed from Improvement to Event Alerts to Mute individual contact option
  • Version 1.0svn deleted

comment:3 Changed 12 years ago by cheesy

Per #757 which was duped to this, I'd like to be able to apply this to groups as well as just individual contacts, with a sort of inheritance hierarchy. I actually had a suggestion for a more flexible approach, though this is much more understandable to non computer geeks.

comment:4 Changed 12 years ago by djmori

comment:5 Changed 11 years ago by Robby

  • Component changed from None to Events
  • Milestone changed from Adium X 1.4 to Good idea for "later"
  • Owner nobody deleted
  • Summary changed from Mute individual contact option to Disable event alerts for individual contacts or groups

All the events tickets can be "handpicked" from "Good idea for 'later'".

comment:6 Changed 11 years ago by yelly

If I understood it correctly, this could be implemented as a part of #10734 (i.e., a "contacts is not" or "contacts is not in group" conditional).

comment:7 Changed 10 years ago by Robby

Ticket #11393 has been marked as a duplicate of this ticket.

comment:8 Changed 10 years ago by Robby

yelly, I think so, too. However, we don't know when Zac manages the rewrite, so in the meanwhile a "Do Nothing" event would probably be a good option for many people.

I think wixardy is working on this.

comment:9 Changed 9 years ago by Frank Dowsett <wixardy@…>

  • Resolution set to fixed
  • Status changed from new to closed

(In a71c719e9271) Add a "Do Nothing" event. Technically a "do nothing further" event as it will keep the events that have already been added. Fixes #3590.
I don't know if it will need a better name or description or implementation.

comment:10 Changed 9 years ago by wixardy

  • Milestone changed from Good idea for "later" to Adium 1.5

comment:11 Changed 9 years ago by Robby

Ticket #7430 has been marked as a duplicate of this ticket.

comment:12 Changed 9 years ago by wixardy

Ticket #14647 has been marked as a duplicate of this ticket.

comment:13 Changed 8 years ago by aone

Thanks for that! Really!!!

Note: See TracTickets for help on using tickets.