Adium

Opened 15 years ago

Closed 12 years ago

Last modified 7 years ago

#331 closed task (cantreproduce)

Bookmark for frequently accessed group chats

Reported by: boote@internet2.edu Owned by: erik006
Milestone: Adium 1.2 Component: Adium UI
Version: Severity: normal
Keywords: group chat Cc: aphor@…
Patch Status:

Description

It would be useful to have a way to "bookmark" frequently accessed group chats so they can be entered by simply clicking on an entry instead of having to go through the File->Join Group Chat menu and dialog.

This could be a window similar to the "contacts" window - or they could even be implemented within the contacts window. If they are put in the "contacts" window, then there are problems with the online vs not-online question for a group so the symantics are a little strange.

Change History (34)

comment:1 Changed 15 years ago by aphor@…

Milestone: Adium X 0.90

group chat status in contact list

The status indicator in the contact list means available/idle/not available but online/offline. It makes sense to implement the status indicator that the group contact appears

  • offline if there is no group (zero members)
  • available if anyone is in the group
  • away if the group is locked
  • idle if all of a group's members are marked idle or away

As I don't know how each of the chat protocols would allow querying a group's status, maybe in the interim group status should be shown as offline until the user joins.

This is a glaring hole in the feature set. Can we please get this on the roadmap?

comment:2 Changed 15 years ago by Augie Fackler

Milestone: Adium X 0.90 (Old)

comment:3 Changed 14 years ago by Chris Forsythe

field_haspatch: 0
Milestone: Adium X 1.0

I don't know about this one, but assigning it to a milestone for now.

comment:4 Changed 14 years ago by Chris Forsythe

Cc: aphor@… added

A list of previous group chats could be added to the join group chat window. It's not quite what you want, but it makes some sense to put it there.

Aphor, you really need to make a new ticket, the comment you added to this ticket does not apply to this specific ticket, and will be ignored here.

comment:5 Changed 14 years ago by Evan Schoenberg

Milestone: Adium X 1.0Adium X 1.5

comment:6 Changed 14 years ago by Skyler

Should have #1195, there should be a way to distinguish between contacts and chatrooms. They shouldn't look like contacts. They're not.

comment:7 Changed 14 years ago by doughboy

I am coming from Linux/Gaim. Gaim simply put them in the contact list. It was simple and elegant. We have several chat rooms on our XMPP server at work that I have to go to from time to time and it would be nice to have this.

comment:8 Changed 13 years ago by Graham Perrin

I'll add my name to the list of people requesting this feature.

An example, the Access Grid Support Centre weekly open test sessions; I can't memorise marble-beer-house(sam.ag.manchester.ac.uk)@conference.mcs.anl.gov and I shouldn't have to reference it *outside* Adium.

Everything else about Adium is so neat, so intuitive, I'm surprised that it's not possible to bookmark chat rooms.

Thanks Graham

comment:9 Changed 13 years ago by Charlie Allom

because i can't find an CC ability - me too!

comment:10 Changed 13 years ago by Eric Richie

Sorry guys but Trac is NOT a voting system, so please stop "adding your name". Thanks.

comment:11 in reply to:  10 ; Changed 13 years ago by Andrew Stadler

Replying to edr1084:

Sorry guys but Trac is NOT a voting system, so please stop "adding your name". Thanks.

With all due respect, the Adium wiki says, "We try to prioritize requests such that those which influence a large number of users take top priority." This certainly encourages folks to chime in and let the Adium team know that a particular feature is important to them.

If adding names to a bug is not the right way to do this, what is?

comment:12 in reply to:  11 Changed 13 years ago by Chris Forsythe

Replying to stadler:

Replying to edr1084:

Sorry guys but Trac is NOT a voting system, so please stop "adding your name". Thanks.

With all due respect, the Adium wiki says, "We try to prioritize requests such that those which influence a large number of users take top priority." This certainly encourages folks to chime in and let the Adium team know that a particular feature is important to them.

If adding names to a bug is not the right way to do this, what is?

Could you explain how you took that sentence as a request for "votes" so that we can rectify that problem?

comment:13 Changed 13 years ago by Evan Schoenberg

I can see how this would imply a request for votes in the context of an enhancement request -- how can we know how many users want a particular feature if, after a single user puts in a request, we ask no others to speak up?

comment:14 Changed 13 years ago by Vicki Brown

Patch Status: None

I would like to be able to attach a particular alert preset to a specified chat session. The situation that brought this request to my mind was a group chat that was very busy (and thus setting off the alert constantly). I don't want to stop alerting on individual chats but I would have loved to make this group chat "shut up" in terms of alert sounds!

Peter Hosey suggested that attaching a particular preset to a particular chat would be a good feature to include when we add the ability to add group chats to the contact list and asked me to add this RFE to the ticket.

comment:15 Changed 13 years ago by Andreas Monitzer

Owner: changed from anybody to Andreas Monitzer

SoC2007!

comment:16 Changed 13 years ago by Andreas Monitzer

Owner: changed from Andreas Monitzer to erik006

Actually, this should be handled in a protocol-independent manner, so it's better to solve that in the groupchat SoC project.

comment:17 Changed 13 years ago by Andreas Monitzer

Milestone: Adium X 1.5Summer of Code 07

comment:18 in reply to:  description Changed 13 years ago by Ilan Rabinovitch

I'd be willing to kick in a bounty for this, as long as Jabber is supported.

comment:19 Changed 13 years ago by Joe Hildebrand

See XEP-48, for Jabber protocol for this.

comment:20 Changed 12 years ago by Ilan Rabinovitch

Was this by any of chance included in the MUC SOC project per Erik's recommendation?

comment:21 in reply to:  20 Changed 12 years ago by erik006

Component: Core AdiumAdium UI
Milestone: Summer of Code 07Adium X 1.2
pending: 0
Type: defecttask
Version: 0.811.2svn

Matter of fact, this feature is still being worked on as we speak. Due to running into several difficulties along the way, progress on this was slower than anticipated. However, bookmarks will be in working order very soon, although this result won't show up in trunk very soon. This *should* be part of Adium 1.2.

Summer of Code '07 is over, milestone 1.2

comment:22 Changed 12 years ago by Chris Forsythe

Can we push this to 1.3? Bookmarking is shaky as it is, automated bookmarking seems like it should wait until bookmarking is further along.

comment:23 Changed 12 years ago by Evan Schoenberg

I don't believe this is for "automated bookmarking" - this is the bookmarking feature itself.

comment:24 in reply to:  23 Changed 12 years ago by Chris Forsythe

Replying to evands:

I don't believe this is for "automated bookmarking" - this is the bookmarking feature itself.

Bah, I read the title as some kind of automation technique. :)

So, forget my question. :P

comment:25 Changed 12 years ago by Colin Barrett

A status update from Erik on bookmarking would definitely be appreciated. It sounds like it's "at risk".

comment:26 Changed 12 years ago by Evan Schoenberg

#7863 discusses some current issues with the implementation.

comment:27 Changed 12 years ago by Evan Schoenberg

Sorry, a bit of lysdexia got me. That's #7836

comment:28 Changed 12 years ago by Jordan

Resolution: worksforme
Status: newclosed

As evan suggested, this feature is basically in place with approximately 2~3 bugs remaining to be fixed. They are outlined in #7836, as such I'm going to close this in favor of that development ticket.

comment:29 Changed 12 years ago by googelybear

As this has been implemented for 1.2 I would very much like to use it, but even after I searched for about half an hour I couldn't find it anywhere in the ui. So where is it hidden? btw. what about an option to automatically re-join previously opened chats when adium is started? Or even better make this configurable on a per group-chat basis - or is this alreaddy implemented and I couldn't find it?

comment:30 Changed 12 years ago by Ilan Rabinovitch

I'd love to check this out as well.

comment:31 in reply to:  29 Changed 12 years ago by khemicals

Replying to googelybear:

  1. In a chat box, in the upper right-hand corner area, right-click and select the customize toolbar option
  2. drag the 'add bookmark' icon onto the window
  3. click done
  4. then click the new add bookmark icon
  5. Enter a name for the chat, associate it with a group
  6. Done. It should now appear in your contacts list

comment:32 Changed 12 years ago by Ilan Rabinovitch

I had offered a bounty on this feature. Would the developer prefer the donation go to the project or to him directly?

comment:33 Changed 7 years ago by Robert

I know this is five or six years in, but a donation to the project would be appreciated.

comment:34 Changed 7 years ago by Ilan Rabinovitch

No problem. I've made a donation via the paypal link on the Adium site. Thank you for your help with this.

Note: See TracTickets for help on using tickets.