Adium

Opened 15 years ago

Closed 12 years ago

#272 closed defect (fixed)

Bonjour in Contact List without Bonjour Account

Reported by: atari2600@conigs.com Owned by: nobody
Milestone: Adium 1.2 Component: Service/Bonjour
Version: Severity: normal
Keywords: Cc:
Patch Status:

Description

Bonjour is showing up in my contact list when I am not connected to Bonjour (I am only connected to my AIM account). I have even removed bonjour from my accounts list, but the problem persists.

Change History (15)

comment:1 Changed 15 years ago by Endorphinity

Severity: minormajor
Version: 0.810.82

The annoying problem persists with version 0.82.

comment:2 Changed 14 years ago by Zachary West

Keywords: bonjour removed
Severity: majornormal

comment:3 Changed 14 years ago by Chris Forsythe

Milestone: Adium X 1.0

comment:4 Changed 14 years ago by Evan Schoenberg

field_haspatch: 0
Milestone: Adium X 1.0

Need some sort of steps to reproduce on this... It doesn't happen for me.

comment:5 Changed 14 years ago by Zachary West

I've had it happen. Usually when I'm disconnected and reconnect.

comment:6 Changed 14 years ago by Chris Forsythe

Milestone: Adium X 1.4

comment:7 Changed 14 years ago by Colin Barrett

Milestone: Adium X 1.4Sometime after 1.0

comment:8 Changed 14 years ago by Chris Forsythe

Milestone: Sometime after 1.0Adium X 1.4

Is this a dupe of #117, or am I reading it wrong?

comment:9 Changed 14 years ago by Chris Forsythe

Bah, I meant #177

comment:11 Changed 13 years ago by Chris Forsythe

Milestone: Adium X 1.4Good idea for "later"

Milestone Adium X 1.4 deleted

comment:12 Changed 12 years ago by Zachary West

Component: Other ProtocolBonjour
Milestone: Good idea for "later"Adium X 1.2
Patch Status: None
pending: 0

This is still an issue. Gonna throw on 1.2, if there's time to fix it before 1.2, cool.

To reproduce:

  1. Connect a bonjour account.
  2. Disconnect or disable the bonjour account.
  3. Note new bonjour contacts show up in the contact list.

comment:13 Changed 12 years ago by Evan Schoenberg

(In [21387]) Added some debug logging to the logout process of Bonjour. Refs #272

comment:14 Changed 12 years ago by Evan Schoenberg

Milestone: Adium X 1.2Adium X 1.2.1

comment:15 Changed 12 years ago by Evan Schoenberg

Milestone: Adium X 1.2.1Adium X 1.2
Resolution: fixed
Status: newclosed

I believe I fixed this problem this weekend.

Note: See TracTickets for help on using tickets.