Adium

Opened 14 years ago

Closed 12 years ago

Last modified 10 years ago

#2640 closed defect

ISO Characters in Contact Names Appear Incorrectly

Reported by: anonymous Owned by: nobody
Milestone: Component: Adium UI
Version: Severity: normal
Keywords: ISO characters german umlaute names contact list Cc:
Patch Status:

Description

I'm just evaluating the 1.0svn and recognized, that now the "umlaute and special chars" (like ö ä ü ß...) in the names on my contactlist look weird.

Attachments (3)

17 15.50.16.jpg (1.3 KB) - added by anonymous 14 years ago.
for example "ö" is now shown like this..
2006-01-17-15.53.32.jpg (18.3 KB) - added by anonymous 14 years ago.
alias & "umlaute" problem (contact details)
statusmessage.jpg (8.0 KB) - added by anonymous 14 years ago.
Umlauts in status messages are also displayed wrong

Download all attachments as: .zip

Change History (20)

comment:1 Changed 14 years ago by Evan Schoenberg

Please see ReportingBugs.

comment:2 Changed 14 years ago by Evan Schoenberg

Resolution: invalid
Status: newclosed

(And please reopen with your additional information if appropriate).

Changed 14 years ago by anonymous

Attachment: 17 15.50.16.jpg added

for example "ö" is now shown like this..

Changed 14 years ago by anonymous

Attachment: 2006-01-17-15.53.32.jpg added

alias & "umlaute" problem (contact details)

comment:3 Changed 14 years ago by anonymous

Resolution: invalid
Status: closedreopened

another strange thing is, that also the contact (see screenshot) has an "alias" (entered in 0.87) (and shown there correctly with "ö") in 1.0svn the "Alias" field is empty... ?! (see attachment 2006-01-17-15.53.32.jpg)

Changed 14 years ago by anonymous

Attachment: statusmessage.jpg added

Umlauts in status messages are also displayed wrong

comment:4 Changed 13 years ago by Jordan

Keywords: german umlaute status transfer contact list added
Milestone: Needs feedback from users
Patch Status: None

This may be fixed for the contact list, but it's supposedly still an issue with the away messages and file transfers. Can anyone confirm this with 1.0.2?

See #6146 and #5452 for additional info.

comment:5 Changed 13 years ago by Jordan

When this is confirmed for 1.0.2, I'll still have to set this to waiting on libpurple, as that is where the issue originates!

comment:6 Changed 13 years ago by Jordan

Version: 1.0svn1.0.1

comment:7 Changed 13 years ago by Robert

I have the problem in 1.0.2.

comment:8 Changed 13 years ago by Jordan

Milestone: Needs feedback from usersWaiting on libpurple
Version: 1.0.11.0.2

Thanks Robby. This will basically be the ticket for reference regarding this problem with Umlaute and will be updated whenever it is fixed in libpurple.

comment:9 Changed 13 years ago by Robert

This is the Pidgin ticket that deals with this problem. It's milestoned for 2.0.1 so, fortunately, we can get expect a fix soon. :)

comment:10 Changed 13 years ago by Jordan

That's #p829

comment:11 Changed 13 years ago by Robert

Maybe the name of this ticket should be changed so that it's clearer that this is a general problem of non-UTF-8 characters, not only German umlauts.

comment:12 Changed 12 years ago by Zachary West

pending: 0
Summary: German UmlauteISO Characters in Contact Names Appear Incorrectly

comment:13 Changed 12 years ago by Robert

I have a friend who uses QIP. His status messages are displayed correctly. Strangely enough, when he sends me messages the umlauts are displayed incorrectly, Cyrillic or something...

comment:14 Changed 12 years ago by Robert

This is #p1645 now.

comment:15 Changed 12 years ago by Robert

Keywords: ISO characters names added; status transfer removed
Milestone: Waiting on libpurpleNeeds feedback from users
pending: 01

I only encounter encoding problems with ICQ in away messages, maybe also in chats when chatting to QIP users, I am not sure about that. The former bug is covered in #6051.

Anyway, this ticket is about contact names in the contact list. I haven't experienced a problem with them for ages.

Please check if this bug as it is described here can still be found in 1.0.6 or 1.2.2.

comment:1 Changed 12 years ago by trac-robot

pending: 10
Status: reopenedclosed

This ticket was closed automatically by the system. It was previously set to a Pending status and hasn't been updated within 14 days.

comment:2 Changed 10 years ago by Robert

Milestone: Needs feedback from users

Remove "Needs feedback from users" milestone

Note: See TracTickets for help on using tickets.