Adium

Opened 15 years ago

Closed 15 years ago

Last modified 12 years ago

#2634 closed defect (fixed)

Emoticons in status (French version)

Reported by: Alex Owned by: nobody
Milestone: Adium X 1.0 Component: None
Version: Severity: minor
Keywords: Cc:
Patch Status:

Description

In The french version of Adium, when you are away, or busy, the status is "Parti(e)" or "Occupé(e)" and the (e) is replaced by an emoticon.

Attachments (1)

Emoticons.plist (14.2 KB) - added by bordolien 15 years ago.
The (e) is not considered anymore in the list of AdiuMSN emoticons.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 15 years ago by anonymous

won't anyone fix this?? it's really really anoying and it'd take seconds to fix

comment:2 Changed 15 years ago by David Smith

Milestone: Adium X 1.0

comment:3 Changed 15 years ago by rockinabox

Fix it in seconds, then, and submit a patch.

Changed 15 years ago by bordolien

Attachment: Emoticons.plist added

The (e) is not considered anymore in the list of AdiuMSN emoticons.

comment:4 Changed 15 years ago by anonymous

Changing emoticons.plist looks more like a workaround to me. The real issue here is that Adium replaces text with emoticons for everything that gets added to the conversation window, including info messages from Adium itself. In my opinion, the real way to fix this would be to only look for emoticons in nicknames and messages.

Btw, i'm not the "anonymous" who reported this bug.

comment:5 Changed 15 years ago by bordolien

It is a workaround but I do not think there are many words written with an emoticon shortcut in any language. There were two shortcuts to display an envelop : (E) and (e).

The problem is that french adjectives can take an 'e' at the end. So the (e) had to be removed from the Emoticons.plist, which does not affect anybody else I suppose ;)

comment:6 Changed 15 years ago by anonymous

This is already fixed for Adium 1.0 (because the emoticon parser doesn't convert emoticons sandwiched inside words now). Can someone mark this ticket fixed please?

comment:7 Changed 15 years ago by David Smith

Resolution: fixed
Status: newclosed

Sweet. I was hoping something like that would be the case (I remember when that fix went in, wasn't sure if it applied).

Note: See TracTickets for help on using tickets.