Adium

Opened 15 years ago

Closed 14 years ago

Last modified 14 years ago

#255 closed defect (fixed)

Use standard cursor positioning keyboard shortcuts in custom status message window

Reported by: carlj7 Owned by: evands
Milestone: Adium X 1.0 Component: Adium Core
Version: Severity: minor
Keywords: key shortcut cursor text custom status Cc:
Patch Status:

Description (last modified by Peter Hosey)

Currently, the behavior of cursor positioning keyboard shortcuts within the text area of the custom status window (the CMD-Y window) is non-standard.

  • If CMD-right and left are set to switch between tabs, focus will be shifted to the message window. This behavior is non-standard, but correct, since when the CMD-[ and ] are used to control switching between tabs, CMD-right and left behave normally. However, the behavior of CMD-up and down is incorrect, since it never has any effect. The proper effect is for the cursor to be place either at the beginning of the text area (CMD-up) or bottom (CMD-down).
  • Control-right and left work in the standard manner. However, control-up and down do nothing, which is non-standard. They should act like page up and page down.
  • Option-right and left work in the standard manner. However, option-up and down apparently attempt to work as in the message window, where it displays previously sent messages. Since there is no previous message for the custom status window to return to, it blanks the current contents of the window, with no option for restoring the contents. Standard behavior is to move to the beginning (option-up) or end (option-down) of the current paragraph, then continue to other paragraphs as the input is repeated.

Change History (9)

comment:1 Changed 15 years ago by adamiser

Duplicate of #115, but with more information so I'm closing the original.

comment:2 Changed 15 years ago by anonymous

Milestone: Adium X 0.90

comment:3 Changed 14 years ago by Evan Schoenberg

Milestone: Adium X 0.90 (Old)Adium X 0.90

AIMessageEntryTextView needs to have setters which allow one to enable/disable the non-standard message-window-centric behaviors.

comment:4 Changed 14 years ago by Evan Schoenberg

Component: Plug-InsAdium Core
Owner: changed from anybody to nobody
Version: 0.84

comment:5 Changed 14 years ago by Evan Schoenberg

[13514] begins fixing this.

comment:6 Changed 14 years ago by Evan Schoenberg

Owner: changed from nobody to Evan Schoenberg
Status: newassigned

comment:7 Changed 14 years ago by Evan Schoenberg

Resolution: fixed
Status: assignedclosed

(In [13524]) Fixed the custom status window to use standard cursor positioning keys (instead of it trying to use various modified responses useful in the message window). Fixes #255

comment:8 Changed 14 years ago by Evan Schoenberg

(In [13525]) Merged [13524]: Fixed the custom status window to use standard cursor positioning keys (instead of it trying to use various modified responses useful in the message window). Fixes #255

comment:9 Changed 14 years ago by Peter Hosey

Description: modified (diff)
field_haspatch: 0

Preformatting [ and ] so that hopefully Trac doesn't eat them as if they were a link.

Note: See TracTickets for help on using tickets.