Adium

Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#2473 closed defect (fixed)

Adium crashes when "Show header" is left checked in Messages preferences

Reported by: eric@meyerweb.com Owned by: catfish_man
Milestone: Adium X 1.0 Component: Xtras
Version: Severity: major
Keywords: crash Cc:
Patch Status:

Description

I submitted a few crash reports about this, but they were all sent before I understood what was really happening.

While I was testing a new message theme, I was working on the header file. What I eventually figured out was that if I left "Show header" checked and then quit Adium, Adium would crash after I re-launched and hit command-comma to call up the preferences (which would automatically bring up Messages, or at least try). Since this did not happen with other themes (Terminal being one), I suspect it has to do with my header markup. It is:

<ul id="headerinfo">
<li>Chat session: %chatName%</li>
<li>Initiated by: %sourceName%</li>
<li>Recipient: %destinationName%</li>
<li>Started: <abbr title="%timeOpened{%Y%m%d%H%M%S%FZ%z}%">%timeOpened%</abbr></li>
</ul>

Obviously, I can't be sure that the actual markup is at fault, but as I say, not every theme crashes with "Show header" pre-checked so it seems like this would be the problem. I can supply the theme if needed; just let me know.

Despite this being a crasher, I left the priority and severity at their defaults because I don't know the protocols around here. I'll leave those to whoever takes the bug.

Change History (6)

comment:1 Changed 14 years ago by eric@…

Found the exception log from my most recent crash. Here she be:

OS Version:	Version 10.3.9 (Build 7W98)
Language:	en
Exception:	NSInvalidArgumentException
Reason:	*** -[NSCFString replaceCharactersInRange:withString:]: nil string (or other) argument
Stack trace:
     1	0x979e87d0
     2	0x97925e28
     3	-[AIWebkitMessageViewStyle fillKeywordsForBaseTemplate:chat:] (in WebKit Message View)
     4	-[AIWebKitMessageViewController _primeWebViewAndReprocessContent:] (in WebKit Message View)
     5	-[AIWebKitMessageViewController preferencesChangedForGroup:key:object:preferenceDict:firstTime:] (in WebKit Message View)
     6	-[AIWebKitMessageViewController initForChat:withPlugin:] (in WebKit Message View)
     7	+[AIWebKitMessageViewController messageViewControllerForChat:withPlugin:] (in WebKit Message View)
     8	-[ESWebKitMessageViewPreferences _configureChatPreview] (in WebKit Message View)
     9	-[ESWebKitMessageViewPreferences viewDidLoad] (in WebKit Message View)
    10	-[AIModularPane view] (in Adium)
    11	-[AIModularPaneCategoryView setPanes:] (in Adium)
    12	-[AIPreferenceWindowController tabView:willSelectTabViewItem:] (in Adium)
    13	-[AIPreferenceWindowController selectCategoryWithIdentifier:] (in Adium)
    14	-[AIPreferenceWindowController showWindow:] (in Adium)
    15	0x92f276fc
    16	0x92f5cf48
    17	0x92fa17f4
    18	0x92fa8124
    19	0x92f871dc
    20	0x92ea4840
    21	0x92ead0d0
    22	0x92f697bc

comment:2 Changed 14 years ago by David Smith

Component: NoneXtras
Keywords: crash added
Owner: changed from nobody to David Smith
Severity: normalmajor
Version: 0.87

Hm, fun. Crashed in the string replacement code. Thanks for leaving the priority and such alone :)

/me goes off to try to make a style that does this.

comment:3 Changed 14 years ago by David Smith

Milestone: Adium X 1.0

Reproduced with 0.87, gonna try it with 1.0svn now.

comment:4 Changed 14 years ago by David Smith

Reproduced in 1.0svn (joscar branch), doing a debug build now to try to track it down.

comment:5 Changed 14 years ago by David Smith

Resolution: fixed
Status: newclosed

(In [14513]) Making word replacement not crash when there's no account associated with the chat. Fixes #2473

comment:6 Changed 14 years ago by David Smith

(In [14514]) Merging [14513] into the 0.8x branch on the off chance that we release another 0.8x. Refs #2473

Note: See TracTickets for help on using tickets.