Adium

Opened 15 years ago

Closed 14 years ago

Last modified 14 years ago

#2463 closed defect (fixed)

rate limited after changing songs willy nilly

Reported by: anonymous Owned by: eharris
Milestone: Adium X 1.0.2 Component: None
Version: Severity: minor
Keywords: rate limiting, iTunes, changing songs quickly Cc: jmpp@…
Patch Status:

Description

if status is set to "Current iTunes Track" Adium rate limits after skipping over a couple of songs

Change History (22)

comment:1 Changed 15 years ago by Chris Forsythe

Milestone: SVN issues

Ya, this is a server side thing with AIM, if you change your song it will update on the server. Talk to the server too often, and viola, no more mr nice aim server.

Maybe we could update the server after the user stops selecting?

comment:2 Changed 15 years ago by Chris Forsythe

Summary: rate limitrate limited after changing songs willy nilly

comment:3 Changed 15 years ago by Evan Schoenberg

Keywords: fixedByJoscar added

joscar automanages rate limiting.

comment:4 Changed 15 years ago by David Smith

Milestone: SVN issues

de-milestoning fixedByJoscar

comment:5 Changed 15 years ago by Augie Fackler

Resolution: fixed
Status: newclosed

(In [15524]) Merge joscar to trunk, causing much rejoicing. Fixes #2377. Fixes #2488. Fixes #2463. Fixes #2413. Fixes #2231. Fixes #2230. Fixes #4. Fixes #2903.

comment:6 Changed 14 years ago by Jeremy

Resolution: fixed
Status: closedreopened

In 1.0b15, Oct 29 Build, I'm getting the originally-described behavior when skipping through several songs at a time in iTunes.

comment:7 in reply to:  6 Changed 14 years ago by Eric Richie

Replying to ibiwan:

In 1.0b15, Oct 29 Build, I'm getting the originally-described behavior when skipping through several songs at a time in iTunes.

The "official" b15 is Nov 11, try downloading from the beta page just to make sure the additional changes don't cause a different result.

comment:8 Changed 14 years ago by Frederic Wenzel

confirming the bug for b15. Still occurs after clicking through a few songs in iTunes.

comment:9 Changed 14 years ago by Juan Manuel Palacios

Cc: jmpp@… added
Keywords: rate limiting iTunes changing songs quickly added; fixedByJoscar removed
Version: 1.0svn1.0b17

Adium moved back to libgaim for AIM connectivity after b15, so I'm deleting joscar references in this ticket's details as appropriate. I'm experiencing this exact same error with b17, AIM servers complain with rate limiting errors if I skip two or three songs a tad too quickly ( %_iTunes is my status message script... I suppose it also happens with %_music). After that, more errors keep pouring in until I stop, without disconnecting me though.

-jmpp

comment:10 Changed 14 years ago by Robert

Bug still exists in b15, too, by the way.

comment:11 Changed 14 years ago by Juan Manuel Palacios

"Last action you attempted could not be performed because you are over the rate limit. Please wait 10 seconds" is the exact error I'm seeing, and just now I confirmed that if I change the songs one too many times AIM servers do disconnect me ;-)

-jmpp

comment:12 Changed 14 years ago by cavemoneky50

Just noting, this is still an issue for me and is present in current beta builds.

comment:13 in reply to:  12 Changed 14 years ago by julian

While this bug still drives me somewhat nuts and I agree with tick's idea of updating the server *after* the user has finished selecting songs, you can work around it by pausing iTunes before skipping through songs.

comment:14 Changed 14 years ago by daniel

This is happening to me right now with 1.0.

Also, and this might not be a bug, but I can't seem to disable the itunes functionality. So now skipping songs always gives me that annoying window. Should a new ticket be opened for this?

comment:15 in reply to:  14 Changed 14 years ago by julian

Replying to pilgrim:

This is happening to me right now with 1.0.

Also, and this might not be a bug, but I can't seem to disable the itunes functionality. So now skipping songs always gives me that annoying window. Should a new ticket be opened for this?

Have you tried clicking the Status menu, then selecting a status other than the iTunes one?

comment:16 Changed 14 years ago by Adam Israel

Pausing iTunes before skipping songs does not work. I still get the rate limit error, using 1.0.1. The only work-around seems to be to change the status to not iTunes, change songs in iTunes, and then change the status back to iTunes.

From the looks of the error, there needs to be 10 seconds between status message updates.

comment:17 Changed 14 years ago by Evan Schoenberg

Milestone: Adium X 1.0.2

This indicates a bug in the oscar rate limiting code in libgaim... but should also be easy to suppress via throttling within Adium, much as we already do for MSN display names.

comment:18 Changed 14 years ago by Elliott Harris

Owner: changed from nobody to Elliott Harris
Status: reopenednew

comment:19 Changed 14 years ago by Elliott Harris

Status: newassigned

This is fixed. I've decided on a time limit of 3 seconds. Once the song has played for three seconds, your status will be updated. Committing once I stop leaking somewhere.

comment:20 Changed 14 years ago by Elliott Harris

Resolution: fixed
Status: assignedclosed

(In [19087]) Fixes #2463

comment:21 in reply to:  20 Changed 14 years ago by menesis

Patch Status: None

Thank you very much! :)

comment:23 Changed 14 years ago by Zachary West

Component: MSNNone
Milestone: Adium X 1.0.3Adium X 1.0.2
priority: highestlow
Severity: blockerminor
Note: See TracTickets for help on using tickets.