Adium

Opened 15 years ago

Closed 13 years ago

Last modified 13 years ago

#2427 closed defect (fixed)

Can not send multi-line messages via Bonjour

Reported by: anonymous Owned by: nobody
Milestone: Adium 1.2 Component: Service/Bonjour
Version: Severity: normal
Keywords: Cc:
Patch Status:

Description

when I paste multi-line text into a bonjour chat between Adium and an iChat client, the text does not come through. The window on the iChat side claims "you left the chat." For example, I opened a chat from Adium to another machine running ichat. I then created a sticky note that said simply "stickets<return>again". I typed cmd-a (select all) in stickies, and then cmd-v in adium, followed by return. The text did not come through, and the ichat client reported that I left the chat.

I'm using Adium .87 on a 1.5 GHz Powerbook G4 running OS X 10.4.2, and iChat on a 1.25 GHz mac mini running 10.4.2. There is no console output when this occurs.

Change History (9)

comment:1 Changed 15 years ago by william.westman.malmi@…

Exactly same issue with Adium .87 using Mac OS X 10.4.3 sending to either iChat AV or Adium .87.

After multi-line message has been sent, receiver can't send messages back to sender with Bonjour until after a few minutes.

comment:2 Changed 15 years ago by Peter Hosey

sounds like newlines need to be escaped somehow.

comment:3 Changed 14 years ago by Chris Forsythe

Component: Other ProtocolBonjour
Milestone: Waiting on libezv

comment:4 Changed 14 years ago by Evan Schoenberg

Summary: multi-line paste does not work in bounjour chatCan not send multi-line messages via Bonjour

From cabbey in #1965: 1.0b14 still has this. Here's a reproducable method to generate this problem using two systems running adium:

  1. user A on machine A opens bonjour chat with user B on machine B
  2. user A sends a single line message (it comes through OK)
  3. user B sends a single line response (it comes through OK)
  4. user A sends a multiline message, such as a copy/paste from terminal or firefox or whatever.
  5. user B will see that user A is typing, but never gets the multi line message, or any other message from there forward.

At this point the conversation has become one way only, B can send to A successfully, but A can not send anything to B, single or multiline. I've found two ways out of this: either user quits and restarts, or the user that sent the multi-line text cycles their bonjour status through offline and back to available. Steps 1 through 3 above really aren't needed, they just ensure that the connection is up and working.

I see no console output for this with the default startup options (if there's a debug switch somewhere let me know and the wife and I will trace both sides).

comment:5 Changed 13 years ago by Chris Abbey

workaround to get you back to functional state (at least in >= 1.0.2):

change bonjour status to disabled, then back to active.

comment:6 Changed 13 years ago by Chris Abbey

With the list of directions I mentioned, and 1.0.4 on both sides, the messages seem to be sent correctly according to a network dump, just not received.

comment:7 Changed 13 years ago by proton

Milestone: Waiting on libezvSummer of Code 07
Patch Status: None

The messages aren't sent correctly because Adium generates an HTML version that is not valid XML.

This isn't actually a bug in libezv, but Adium and the Adium Bonjour plugin.

comment:8 Changed 13 years ago by Erich Kreutzer

Milestone: Summer of Code 07Adium X 1.2
pending: 0
Resolution: fixed
Status: newclosed

comment:9 Changed 13 years ago by Chris Abbey

I just built the 1.1 branch with this patch applied, seems to work like a charm.

Note: See TracTickets for help on using tickets.