Adium

Opened 15 years ago

Closed 12 years ago

Last modified 12 years ago

#225 closed defect (fixed)

Idle preference not saved

Reported by: anonymous Owned by: nobody
Milestone: Adium 1.2.2 Component: Service/AIM
Version: Severity: normal
Keywords: Cc:
Patch Status:

Description

Each time I relaunch the application, I have to redo my idle preferences. Namely, I choose not to let others know I am idle after X minutes, however everytime I restart the box is checked. Is there a way to have this preference saved?

Change History (20)

comment:1 Changed 15 years ago by David Smith

Milestone: Adium X 0.81

Please don't set milestones when filing tickets

comment:2 Changed 15 years ago by adamiser

This preference is indeed not working correctly.

comment:3 Changed 15 years ago by anonymous

Milestone: Adium X 0.83

comment:4 Changed 15 years ago by Evan Schoenberg

Cc: evan.s@… adam@… added

Can anybody reproduce this? I can't.

comment:5 Changed 14 years ago by wootest

Resolution: worksforme
Status: newclosed

comment:6 Changed 14 years ago by Chris Forsythe

Resolution: worksforme
Status: closedreopened

comment:7 Changed 14 years ago by wootest

Resolution: worksforme
Status: reopenedclosed

comment:8 Changed 14 years ago by wootest

(The ticket was ostensibly opened because someone thought Adam had been able to reproduce it. However, he hadn't.)

comment:9 Changed 14 years ago by David Smith

Milestone: Adium X 0.83

comment:10 Changed 14 years ago by klatt@…

Resolution: worksforme
Status: closedreopened

This happens to me on tiger 10.4.2 and adium .84

comment:11 Changed 14 years ago by Chris Forsythe

Milestone: Adium X 1.0

Setting to 1.0 for now, but we need to try to reproduce this or close it for good.

comment:12 Changed 14 years ago by Chris Forsythe

field_haspatch: 0

Can anyone get this to happen in .86 or svn head?

comment:13 Changed 14 years ago by Evan Schoenberg

Milestone: Adium X 1.0
Resolution: worksforme
Status: reopenedclosed

I really can't reproduce this. The status preferences are localized, so it could be a localization-specific issue. If you, theoretical bug reporting reader, reopen this because you have the problem in this ticket, please include the language in which Adium runs on your system.

comment:14 Changed 14 years ago by Evan Schoenberg

Cc: evan.s@… adam@… removed

comment:15 Changed 14 years ago by m@…

Resolution: worksforme
Status: closedreopened

I am having this problem in 0.88 on the english version of 10.4.4. I set the idle time to 5 mins, then if I restart Adium it resets to 1 min.

comment:16 Changed 13 years ago by Evan Schoenberg

Resolution: fixed
Status: reopenedclosed

This really does work for me every time in 1.0 beta. If you are still seeing this issue, please describe precisely how you are changing the value and then what else you do before you quit adium.

comment:17 Changed 13 years ago by phy1729

This happens to me also. I am Mac 10.4.9 Adium 1.0.4. When I open Adium, open prefs, go to the status tab, and set Let others know that I am idle after 5 min to 10. Then I close Adium and reopen the change is not saved. I went into the plist and changed it there and it has held. I have changed to 5 and back to 10 with no problems now.

comment:18 Changed 12 years ago by Evan Schoenberg

Milestone: Adium X 1.2.2
Patch Status: None
pending: 0
Resolution: fixed
Status: closedreopened

comment:19 Changed 12 years ago by Evan Schoenberg

Resolution: fixed
Status: reopenedclosed

(In [22539]) Don't use an NSNumber key in a dictionary which will be saved as a preference, as this prevents the entire preference group from saving; you must use an NSString. We now have logging which points the problem out.

Fixes #9082 (Custom status pre-population with previous message. Fixes #225 (yes, a ticket from 3 years ago!) which was previously very, very mysterious - the preference in question is in the same group as the last-status preference, which is why it wouldn't save.

comment:20 Changed 12 years ago by Evan Schoenberg

(In [22540]) Merged [22539]: Don't use an NSNumber key in a dictionary which will be saved as a preference, as this prevents the entire preference group from saving; you must use an NSString. We now have logging which points the problem out.

Fixes #9082 (Custom status pre-population with previous message. Fixes #225 (yes, a ticket from 3 years ago!) which was previously very, very mysterious - the preference in question is in the same group as the last-status preference, which is why it wouldn't save.

Note: See TracTickets for help on using tickets.