Adium

Opened 14 years ago

Closed 8 years ago

Last modified 8 years ago

#2177 closed enhancement (fixed)

Block whole groups in adium in one go

Reported by: anonymous Owned by:
Milestone: Adium 1.5 Component: Adium UI
Version: Severity: normal
Keywords: Cc:
Patch Status: Accepted

Description

In messenger plus on windows, there's a feature to block/unblock
an entire group, available by right clicking on the group name. is
there an equivalent short-cut on adium that I haven't yet discovered -
for groups of contacts not regularly spoken to this would be a useful
feature. thanks

PS I've noticed that when I ctrl-click on the group name there is an
option saying 'Block' but it is always greyed out.......why is this?!

Attachments (1)

blockGroups.diff (8.1 KB) - added by squid890 10 years ago.
Patch to block groups

Download all attachments as: .zip

Change History (19)

comment:1 Changed 14 years ago by sebhelyesfarku@…

I agree, would be a useful feature to block/unblock an entire group.

comment:2 Changed 14 years ago by boredzo

  • Component changed from None to Adium UI
  • Milestone set to Sometime after 1.0
  • Severity changed from major to normal
  • Summary changed from block whole groups in adium (msn) in one go to block whole groups in adium in one go
  • not a major issue.
  • not MSN-specific.

at the moment, there is no UI support for blocking an entire groupful of contacts. I agree that this would be nice (although on what occasion would you need to do this?), so for now, I'm leaving the ticket open for further discussion.

comment:3 Changed 14 years ago by Sebhelyesfarku

at the moment, there is no UI support for blocking an entire groupful of contacts. I agree that this would be nice (although on what occasion would you need to do this?)

for e.g. when somebody uses one account for everything and there's a "work" and a "friends" group, and in non-working hours all the work collegaues better to be blocked

comment:4 Changed 12 years ago by djmori

comment:5 Changed 11 years ago by Robby

  • Patch Status set to None
  • pending set to 0
  • Summary changed from block whole groups in adium in one go to Block whole groups in adium in one go
  • Type changed from defect to enhancement

comment:6 Changed 11 years ago by tequila.slammer

I think the group should allow blocking/unblocking itself, then the ui part will be fairly easy.
Blocking the entire group means blocking all contacts in this group. But what if some contact is moved away from the group while the group is blocked? Should it be unblocked or remain blocked?
I'd try and implement this feature learning about adium internals in the process. Won't be fast, though, but newbs need to start somewhere, right? :)

comment:7 Changed 11 years ago by Robby

tequila.slammer, nice to hear you are interested in contributing! :)

You are of course welcome to join the Adium IRC channel (AdiumIRCChat) where you can ask developers for some guidance.

comment:8 Changed 10 years ago by squid890

I've written a patch that allows for blocking of groups in Adium (blockGroups.diff)

This is my first open source patch, so be kind!

comment:9 Changed 10 years ago by Robby

  • Patch Status set to Needs Dev Review

comment:10 Changed 10 years ago by squid890

I've cleaned up my previous patch somewhat, specifically on the coding style tips from Catfish_Man. Old link now links to the updated patch, but here is the link again anyway.
BlockGroupsV2

Changed 10 years ago by squid890

Patch to block groups

comment:11 Changed 10 years ago by Robby

  • Milestone changed from Good idea for "later" to Adium 1.5

comment:12 Changed 9 years ago by Robby

  • Owner nobody deleted

comment:13 Changed 9 years ago by wixardy

Ticket #11366 has been marked as a duplicate of this ticket.

comment:14 Changed 8 years ago by Adrian Godoroja <robotive@…>

(In 831ee75de731) Added support for Blocking/Unblocking all contacts in a group.
Patch by squid890, r=robotive. Refs #2177.

comment:15 Changed 8 years ago by robotive

  • Patch Status changed from Needs Dev Review to Accepted
  • Resolution set to fixed
  • Status changed from new to closed

comment:16 Changed 8 years ago by Robby

Thanks, squid890. Which name would you like to be credited with?

comment:17 Changed 8 years ago by squid890

Hi, I'd like to be credited as Conor Branagan. Thanks!

comment:18 Changed 8 years ago by Robert Vehse

(In 5eb5713c114f) Credit Conor Branagan for his patch, some minor changelog improvements. Refs #2177.

Note: See TracTickets for help on using tickets.