Adium

Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#2015 closed enhancement (fixed)

"Status Menu Item" (menu extra) should be skinnable.

Reported by: wootest Owned by: wootest
Milestone: Adium X 1.0 Component: Adium UI
Version: Severity: normal
Keywords: Cc: wootest+adium@…, evan.s@…
Patch Status:

Description

Yes, this might seem nuts to some of you. But might I remind you that this is the IM messenger that's "so customizable you'll crap your pants", where even the app icon is changed? I saw an Xtra that substituted the icon for a balloon, like that of iChat's own menu extra. And from the looks of it, a lot more are wanted, so I think that a skinnable menu extra is warranted.

I'm willing to do this - I'm just making this ticket to see if it's worth doing (or rather, if it's an idea that'll be accepted into the final code).

Change History (19)

comment:1 Changed 14 years ago by Zachary West

Definitely worth doing, I feel it's lacking. From what I hear, zaudragon began working on it/playing around with it, but no idea on the status. Related to (but not a duplicate of) #173.

comment:2 Changed 14 years ago by Zachary West

That is to say, I have no idea if he even began working on it at all. I showed him the ticket, we'll see when he's around what he says.

comment:3 Changed 14 years ago by Colin Barrett

Milestone: Adium X 1.0
Owner: changed from nobody to Colin Barrett

We *were* the IM messenger that was so customizable you'll crap your pants. Not anymore. That said, there's enough of a demand for this, especially with 3rd parties already themeing it, that it should probably be done. Since the EMD is still sort of "mine," and I already have another ticket for it, I'll assign this to myself.

comment:4 Changed 14 years ago by Chris Forsythe

wootest, do you think you could handle this and #173 ?

comment:5 Changed 14 years ago by wootest

tick: I do think I could handle this, but I'm unsure about the standalone menu item.

cbarrett: I'd like to talk to you about this, send me an email on this ticket's CC with an IM handle and let's talk.

comment:6 Changed 14 years ago by Chris Forsythe

cbarrett has #173 halfway done, but these should be done at the same time.

comment:7 Changed 14 years ago by wootest

I've talked with cbarrett, and I'll implement this, submit it as a patch here and show it to him, and he'll implement it in his version as well.

comment:8 Changed 14 years ago by wootest

Owner: changed from Colin Barrett to wootest
Status: newassigned

comment:9 Changed 14 years ago by Chris Forsythe

Cc: evan.s@… added
field_haspatch: 0

Is this something we actually want?

comment:10 Changed 14 years ago by Zachary West

Yes. The Xtras right now require editing the bundle, or (ugh) running an included .app for no reason.

comment:11 Changed 14 years ago by Chris Forsythe

Is that because everyone just hates our current icon though, that's the question I should have asked.

comment:12 Changed 14 years ago by Zachary West

I don't think it's a matter of hate, it's a matter of preference. Not everybody likes one dock icon, one emoticon set, one message style, etc.

comment:13 Changed 14 years ago by wootest

Just an update: I have some code, but it's an amazing kludge and it actually doesn't update when the state changes, despite using almost identical code. I'll either try to rework this, or start over, or let someone better versed with Adium's state system pick it up.

comment:14 Changed 14 years ago by Evan Schoenberg

Implied in wootest's comment, but to make it explicit: The patch implementing this should allow the status item to indicate Adium's global available vs. away state (as iChat does) rather than just online/offline.

comment:15 Changed 14 years ago by Colin Barrett

Right. The plan is to support all of the applicable keys from the status icon packs (obviously things like "typing" and "mobile" aren't particularly useful).

Speaking of this, tangentally, is there any timeline on when the svnfilter commands i sent you are going to be applied? I have a few different checkouts of Adium, they take up a *lot* of space... Hopefully svk will help with that.

comment:16 Changed 14 years ago by Evan Schoenberg

Excellent.

Colin, thanks for reminding me. I've got the beginning of the fix running now (the beginning being making a hotcopy backup before proceeding). Our repository is big so this may take a while.

comment:17 Changed 14 years ago by Chris Forsythe

Milestone: Adium X 1.0Adium X 1.2

Menu item stuff to 1.2

comment:18 Changed 14 years ago by Evan Schoenberg

Resolution: fixed
Status: assignedclosed

(In [14692]) Let's try this out. The status menu item now uses the current status icon set and core image hotness to get its white-version alternate image.

Also, it is actually removed from the menu bar if toggled off rather than set to a length of 0.

Closes #2015 (or rather makes it irrelevant).

comment:19 Changed 14 years ago by Colin Barrett

Milestone: Adium X 1.2Adium X 1.0

Moving this to 1.0.

Note: See TracTickets for help on using tickets.