Adium

Opened 14 years ago

Closed 13 years ago

Last modified 12 years ago

#2013 closed defect (fixed)

Adium requires passwords to be entered in lowercase

Reported by: subanm@mac.com Owned by: apmsuban
Milestone: Adium X 1.0.5 Component: Service/AIM
Version: Severity: normal
Keywords: password TicketTaskForce Cc: msuban@…
Patch Status:

Description (last modified by Joshua Lock)

Unable to login in with adium. Password window appears everytime. I am able to use iChat or AOL to login into same screen name. Password has been entered in all three the same. Only Adium prompts me for a password and then broadcast incorrect screen name or password.

Potentially a problem caused by the AIM login having been, or currently being, an AOL screen name.

Change History (50)

comment:1 Changed 14 years ago by David Smith

Milestone: Adium X 0.85.1

Please don't set the milestone

comment:2 Changed 14 years ago by pipian@…

I have the same issue, though it is only with one account (not all of them). It works fine with my password in iChat and Gaim on Windows and Linux (1.4.0+) and has worked with the latter two since ~0.7.

comment:3 Changed 14 years ago by subanm@…

OK,

I think I figured it out on my own.

It seems that Adium doesn't like case sensitive passwords. Now this isn't consistant with all my passwords with other accounts. On one of them. So I used my password without using the caps part of the password.

mas

comment:4 Changed 14 years ago by Evan Schoenberg

Resolution: invalid
Status: newclosed

That doesn't make any sense. Passwords are always case sensitive.

comment:5 Changed 14 years ago by pipian@…

I'm reasonably certain that case-sensitiveness had no part in my issue, however, restarting fixed the issue for some reason.

comment:6 Changed 14 years ago by Colin Barrett

field_haspatch: 0
Resolution: invalid
Status: closedreopened

Restarting Adium? The computer?

also: invalid means the ticket was filled out incorrectly. this should be set as worksforme.

comment:7 Changed 14 years ago by Colin Barrett

Resolution: worksforme
Status: reopenedclosed

comment:8 Changed 14 years ago by pipian@…

Restarting the computer. Also, for some reason, the issue has started up again after my connection to the OSCAR server went down temporarily. Might it have something to do with either a long password (say, greater than 12 characters) or long AIM screenname (16 characters) or both?

comment:9 Changed 14 years ago by anonymous

Resolution: worksforme
Status: closedreopened

Same here since about 2 weeks... I reverted to 0.85 and it does the same on my ICQ account and on ONE of my AIM accounts. The other work fine. Might be related to the fact that AIM released a new messenger app, Triton, and that they are trying to force users to use it instead of alternative clients... it's a real bummer.

comment:10 Changed 14 years ago by joc-renee@…

Going to all lowercase worked for me as well. Running OS X 10.4.3 and Adium .87

comment:11 Changed 14 years ago by Peter Hosey

Summary: Adium login failed - AOL or iChat OKAdium requires passwords to be entered in lowercase

anonymous: see #2023.

comment:12 Changed 14 years ago by Evan Schoenberg

This and #1902 are likely the same issue if they exist.

comment:13 Changed 14 years ago by anonymous

i have exactly the same problem.

lowercase makes no difference.

restarting makes no difference.

why won't someone at Adium answer this? its so annoying.

comment:14 Changed 14 years ago by anonymous

I have the same problem. I wish someone would could help. Sometimes when I apply the password, it says gaim error

comment:15 Changed 14 years ago by Colin Barrett

The main problem in solving this bug is that none of the developers can reproduce this. If anyone who is experiencing this would be so kind as to lend one of the developers your username and password for testing, that could help out a lot.

comment:16 Changed 14 years ago by alfonso41999@…

THIS IS RETARDED!!!!!! its lowercase and everything but it signs on the off, and always asks for the password!!! WHY DONT THE DEVLOPERS SEE THIS!!!!!!!!!!!!!

comment:17 Changed 14 years ago by Colin Barrett

I can't reproduce this though, and to my knowledge nobody else on the development team can.

We're not ignoring you, we can't fix something when we have no idea what's broken. If you can reproduce this reliably, please post the steps.

comment:18 Changed 14 years ago by fyn_galon@…

Adium won't open my AIM account at all.

Works fine in iChat and in AOL.

Opened alternate AIM account for test, which works fine.

Yahoo account works fine.

This is my first time trying to use Adium. I have tried uninstalling, reinstalling, repairing permissions and restarting. I have tried 89c and 89.1 (twice, currently installed)

Changed my password via AOL 3 or 4 times, all lowercase alpha-numeric, 10 characters or fewer. Changed my iChat keychain password, likewise.

It requests the password three or four times, then gives the error message: [my account name] "Gaiam error - incorrect nickname or password"

Running OS 10.4.6 on G4 mirror door.

Help?

comment:19 Changed 14 years ago by just.jbrady@…

I am having the same problem. Since last Thursday I have not been able to use aim on adium. I can use yahoo, but can not log onto aim. Every time I do it tries to connect then disconnects. After I try to many times it tells me I have been signing on and off too many times and need to wait 10 minutes. Then it still never works. It never says what is wrong just continues asking for a passwrok. I can log onto regular aim programs with no problem.

If anyone figures this problem out please let me know. Or if you need more specifics I can try to give them.

comment:20 Changed 14 years ago by adium

I'm having the exact same issue, lowercase letters have not effect, that must be something different. Oddly enough one aol/aim account works, and the other two don't. It prompts me for a password several times then gives me a GAIM error. The aol account works fine in iChat and Aol. Please help!

comment:21 Changed 14 years ago by edward.vielmetti@…

Same problem here - iChat works, but Adium prompts every time and can't log in.

comment:22 Changed 14 years ago by lim@…

I have several AIM accounts. It seems that the "primary" AIM screen names works, but the screen names that were created (many years ago) underneath a primary account does not work. I.e. the secondary accounts are the ones that have trouble with Adium. That is the only difference between the accounts. Passwords are the same.

I have the following accounts, they all have the same password, so case sensitivity does not seem to be the issue: Primary1 - a "primary" AOL account (i.e. signed up for AOL with this account) S1 - a SN created under Primary1 S2 - a SN created under Primary1 Primary2 - a primary created using AIM (not AOL)

Primary1 and Primary2 works in Adium. S1 and S2 fails to login under Adium All the accounts work using AOL Instant Messenger.

One additional note. I did let Primary1 (and thus S1 and S2) lapse. I.e. it was an AOL account which I let lapse after a few years. At that point those accounts were locked down and I couldn't use them for a long time (months). Then AOL a few months ago announced they were opening it up, and I managed to "get them back". Accounts and Password info was never deleted.

comment:23 Changed 14 years ago by Eric Richie

Milestone: Needs feedback from users

have any of you guys tried this in the latest AdiumBeta?

comment:24 Changed 14 years ago by lim@…

I'm using version 0.89.1, is there a later version to try?

comment:25 Changed 14 years ago by lim@…

Oh, never mind, you provide the link. I'll go try it.

comment:26 in reply to:  24 Changed 14 years ago by Eric Richie

Replying to lim@alumni.caltech.edu:

I'm using version 0.89.1, is there a later version to try?

yes, click AdiumBeta

comment:27 Changed 13 years ago by interruptive_cow@…

I have the exact same problem. I have three AOL accounts, one Google Talk, and one Yahoo Messenger. All of them except one AOL account log in. Adium just asks for the password over and over and over. All these accounts work everywhere else. The problem account is the only real AOL account, the rest are AIM. The password is all lowercase but does have numbers. But one of the other accounts has the exact same password. I have tried restarting the program as well as the computer. I guess the next thing I will try is using the beta version. Right now I'm using 0.89.1.

Email me if theres some kind of fix.

comment:28 Changed 13 years ago by interruptive_cow@…

Ok I just downloaded the beta. No dice. Exact same thing as with version 0.89.1.

comment:29 in reply to:  28 Changed 13 years ago by j-luna at rocketmail dot com

I have this same problem as well. I just wanted to add my post so that the developers see that this is a reccurring issue. This username/password is also from an actual aol account, and it is NOT the primary screenname on the account.

comment:30 Changed 13 years ago by interruptive_cow@…

I forgot to mention, my problem account isn't the primary account either.

comment:31 Changed 13 years ago by Eric Richie

Milestone: Needs feedback from usersNeeds dev review
priority: highnormal
Severity: majornormal
Version: 0.851.0b14

comment:32 Changed 13 years ago by Eric Richie

Milestone: Needs dev reviewNeeds feedback from users
Version: 1.0b14

Changed things a little too quickly... Is this still a problem in b14?

comment:33 Changed 13 years ago by Eric Richie

Resolution: worksforme
Status: reopenedclosed

No response from user.

comment:34 Changed 13 years ago by Dan Guido

Resolution: worksforme
Status: closedreopened

This issue still exists in 1.0b24 (tested January 28, 2007 @ 11:10pm EST).

A long password with lowercase letters and numbers fails to work on Adium, but works with the official AIM client and iChat.

Using the same screen name and a shorter password, still of all lowercase letters, allows me to login successfully on Adium.

This screen name is the only IM account in this Adium install, and the Adium install is a completely fresh install of 1.0b24 on Mac OSX 10.4.8 PowerPC with all patches.

It seems that there are issues with Adium's handling of password length as well as alpha case. Can we get a dev to look at this?

Thanks.

comment:35 in reply to:  description Changed 13 years ago by smurfman

I have this problem with the 1.0 release of Adium.

I have yahoo and aim accounts with identical screen names and passwords. The yahoo account works fine, the aim account fails to login. I tried creating a new aim account, the username and password had the same format (number/letter combination, capitalisation) as my actual account, and it worked fine. I changed the password on my account but the problem persists. The new test account automatically created a corresponding email account so I added one to my old account - still could not log in.

Perhaps this is a problem which only affects old accounts?

comment:36 in reply to:  description Changed 13 years ago by smurfman

Inspired by a comment from a friend I've just fixed my problem by deleting and re-creating my account within Adium.

I originally created my account by importing from Fire which appeared to set my login server to toc.oscar.aol.com. When I re-created my account by hand it was set to login.oscar.aol.com. Not sure if the change of login server was the problem but deleting my account details in Adium and re-creating them by hand seems to have fixed the problem.

comment:37 Changed 13 years ago by Dan Guido

The server being set to toc.oscar was NOT the problem with me. I verified it was set to login.oscar.aol.com before reporting the error.

comment:38 Changed 13 years ago by mlf

Those of you with this problem: And any time in the past, was the name you're trying to sign into AIM with now at one time also an AOL screenname? Such as comments 22 and 27 above, thank you.

Yes, the login server should be login.oscar.aol.com. TOC is an older protocol.

comment:39 Changed 13 years ago by Dan Guido

Yes, my sn is also an AOL sn.

comment:40 Changed 13 years ago by Avi

I too am having the same problem. Login server is set to login.oscar*, and my password does not contain any numbers, but it does contain a non-alphanumeric character. Also, my screen was *previously* (but not anymore) an AOL screen name.

Hope this helps!

comment:41 Changed 13 years ago by Eric Richie

Milestone: Needs feedback from usersNeeds Feedback - Received

comment:42 Changed 13 years ago by Joshua Lock

Description: modified (diff)
Keywords: TicketTaskForce added
Milestone: Needs Feedback - ReceivedNeeds feedback from users
Patch Status: None

Potentially a problem caused by the AIM login having been, or currently being, an AOL screen name. Please test?

comment:43 Changed 13 years ago by Joshua Lock

Milestone: Needs feedback from usersNeeds Feedback - Received

comment:44 Changed 13 years ago by minniemoo81

I was having the same problem, which just started today. I started Adium, and all accounts but AIM started. AIM prompted me for a password. When I entered it, it said invalid password, despite working on my actual AIM account. I tried to enter all lower-case, but that didn't work. So I tried all lower-case, but then left off all but the first 8 characters of my password. This worked. I think there is only a certain length the password can be on Adium's AIM, but it lets you enter the whole thing anyway. Or maybe not, but it worked!

comment:45 Changed 13 years ago by Evan Schoenberg

If you are seeing this issue, please email me your AIM screen name (I don't need the password or any other identifying information, just let me know you're sending it in reference to this ticket, #2013). We're going to investigate the source of the problem but need to know the names of some accounts which are seeing it. Thanks!

comment:46 Changed 13 years ago by Eric Richie

Milestone: Needs Feedback - ReceivedAdium X 1.1
Resolution: fixed
Status: reopenedclosed

This should finally be fixed in [19783].

comment:47 Changed 13 years ago by Evan Schoenberg

Milestone: Adium X 1.1Adium X 1.0.4
pending: 0

comment:48 Changed 13 years ago by Peter Hosey

Milestone: Adium X 1.0.4Adium X 1.0.5

AdiumVersionHistory says 1.0.4 was r19781, which was two revisions before the fix was committed to trunk in r19783. That changeset was never merged to the 1.0 branch, but I think we can assume *cough* that it was included in r19958.

comment:49 Changed 13 years ago by Evan Schoenberg

You're right, boredzo - it wold have been included in r19958 by virtue of it containing the current libpurple at that point. Thanks for the remilestoning.

comment:50 Changed 12 years ago by Karen Dec

I just installed Adium 1.1.4 on a Mac Pro running Leopard (10.5.1). I have both Yahoo and AIM accounts that I set up. The Yahoo account worked fine after setup, but AIM kept telling me my password was incorrect. However, on the AIM live page I was able to log in just fine with that password. The original AIM password was 7 characters starting with an uppercase character (as in: Xxxxxxx). I changed it (using AOL's web page) to something else that was 8 characters, starting with an uppercase letter and ending with a number, as in: Xxxxxxx1. I updated the new password in Adium, but still got the same results (incorrect password). I went back on AOL and changed it again, this time to 7 characters, all lowercase. Upon entering this new password in Adium, suddenly it worked! I should also mention that my Yahoo password is the 8 character version starting with an uppercase letter and ending with a number and it worked fine from the get-go. This was only an issue with AIM in Adium. One final note: my AOL screen name that I use for AIM *is* a sub-account of a primary AOL user name, if that makes any difference (I saw some others mentioned that above).

Note: See TracTickets for help on using tickets.