Adium

Opened 15 years ago

Closed 14 years ago

Last modified 11 years ago

#197 closed defect (cantreproduce)

Blocking a user through Adium makes it impossible to unblock

Reported by: FJ Owned by: cbarrett
Milestone: Component: Service/AIM
Version: Severity: major
Keywords: block unblock buddy list Cc:
Patch Status:

Description

Blocking a user through Adium adds it to the official AIM "blocked" list. However, once it is put here, no amount of removing that user from the block list actually does remove the block — it reappears immediately at launch. Also, control-clicking the user into Adium does not display any "Unblock" menu but, instead, "Block" as if the user were not block.

As a reference to ticket #185, a user blocked through Adium does not appear online, in both Adium and AIM while a user blocked through AIM does appear online in Adium but not AIM. This behavior appears to be inconsistent with the reason invoqued for closing ticket 185 — i.e. blocked users always appear in the Adium Buddy list.

Attachments (2)

.2 (0 bytes) - added by anonymous 15 years ago.
.3 (0 bytes) - added by anonymous 15 years ago.

Download all attachments as: .zip

Change History (19)

comment:1 Changed 15 years ago by FJ

Workaround: to force the deblocking of the user, one can use the official AIM client to set the block settings to "Allow anyone", validate that change, then alter the blocking list and validate it again. This seems to force a refresh of the blocking settings — tested and reproduced on 2 machines.

comment:2 Changed 15 years ago by David Smith

Severity: normalmajor

This is a dupe of #103, but is more useful, so I'm marking #103 as the dupe. #19 also references this in a more general way. Changing priority to major, since this is a pretty serious issue.

comment:3 Changed 15 years ago by David Smith

Summary: Blocking a user through Adium makes it impossible to deblockBlocking a user through Adium makes it impossible to unblock

Switching to "unblock" in the summary since that's more commonly used.

comment:4 Changed 15 years ago by anonymous

The same problem persists with the MSN component; There is no unblock option.

comment:5 Changed 15 years ago by Colin Barrett

Owner: changed from nobody to anonymous
Status: newassigned

This code is all bus' up. Needs to be reworked and made awesome. *looks hopefully to Adam for nicer meta contact code, and to Gaim for a better privacy API*

comment:6 Changed 15 years ago by Colin Barrett

Owner: changed from anonymous to Colin Barrett
Status: assignednew

comment:7 Changed 15 years ago by jmelloy

Resolution: fixed
Status: newclosed

comment:8 Changed 15 years ago by Colin Barrett

Milestone: Adium X 0.82

merged jeff's fix into the 0.8 branch. (Hopefully) fixed blocking should be in 0.82 :)

Changed 15 years ago by anonymous

Attachment: .2 added

Changed 15 years ago by anonymous

Attachment: .3 added

comment:9 Changed 14 years ago by flip.sasser@…

Resolution: fixed
Status: closedreopened

I still can't unblock a contact blocked with an AIM screenname - I can block them again w/Adium but it doesn't allow unblocking.

comment:10 Changed 14 years ago by Colin Barrett

What version of Adium are you using? Is the person you're trying to block a metacontact (aka a combined contact) ?

comment:11 Changed 14 years ago by Colin Barrett

Milestone: Adium X 0.82Adium X 0.86

comment:12 Changed 14 years ago by anonymous

I do not have this problem. Blocking and unblocking works correctly with .84

comment:13 Changed 14 years ago by David Smith

Resolution: worksforme
Status: reopenedclosed

Can't reproduce. Post with more info and reopen if you can.

comment:14 Changed 14 years ago by David Smith

Milestone: Adium X 0.86

comment:15 Changed 14 years ago by anonymous

WE need you to unblock our AIM its not fair!!!

comment:16 Changed 14 years ago by David Smith

field_haspatch: 0

We don't control AOL's servers.

comment:17 Changed 14 years ago by Uncle Foobar

Ran into this with Adium x.89, an otherwise excellent program that i'm quite enamored with.

I don't understand how AOL can't unblock; I have to get the AIM client, log in and set it...?

Foob

Note: See TracTickets for help on using tickets.