Adium

Opened 15 years ago

Closed 14 years ago

Last modified 10 years ago

#19 closed task (invalid)

Improve blocking and privacy setting support

Reported by: tick Owned by: durin42
Milestone: Component: Adium Core
Version: Severity: major
Keywords: Cc:
Patch Status:

Description (last modified by David Smith)

Improve blocking and privacy setting support

Includes:

  • Blocking a user through Adium makes it impossible to unblock (#197)
  • Block all users not on contact list (#129)
  • Fix jabber blocking (broken in 1.0svn) (#852)

Change History (84)

comment:1 Changed 15 years ago by Evan Schoenberg

Component: component1Core Adium

comment:2 Changed 15 years ago by David Smith

A forum user notes that when he or she couldn't unblock users in Adium, they appeared multiple times on the block list in iChat. Not sure if this is useful info, but it seemed potentially so.

comment:3 Changed 15 years ago by solysh@…

Just had that problem myself. Nice to see you guys on top of things. Unblocked a user on Adium but it didnt successfully unblock, so I was unfortunately forced to log into iChat to unblock them, which worked.

comment:4 Changed 15 years ago by David Smith

See #197

comment:5 Changed 15 years ago by anonymous

See #129

comment:6 Changed 15 years ago by Augie Fackler

Milestone: Adium X 0.90 (Old)Adium X 0.90
Owner: changed from Ivan to Augie Fackler
Status: newassigned

comment:7 Changed 15 years ago by David Smith

priority: lowesthigh
Severity: normalblocker

comment:8 Changed 15 years ago by David Smith

Type: defecttask

comment:9 Changed 15 years ago by anonymous

Since bug 129 was marked as a duplicate of this bug, here's a description of what was requested in that bug, which is technically different than the description of this bug:

option to block all users not on contact list

comment:10 Changed 15 years ago by anonymous

Absolutely a MUST HAVE. Please implement it BEFORE 0.9. Adium is about the only client that DOESN'T have this capability.

comment:11 Changed 15 years ago by Tezz (tezz27000@…

just want 2 make sure that seeing which of your contacts have added you is included here

comment:12 Changed 15 years ago by anonymous

how can i unblock users?

comment:13 Changed 15 years ago by anonymous

yes

comment:14 Changed 15 years ago by anonymous

Just adding my $0.02

Adium is so-nearly perfect, offering the best feature-set of any OSX IM client ... I can only add my encouragment and hope that you're able to repair the blocking & privacy issues. My specific findings (note: I'm running Tiger):

  • The 'Block Buddy' function fails completely. I have tried this with 3 different account and 4 different clients on the receiving end (i.e. the "buddy" end ... and the clients I tried were iChat, Fire, Trillian, & gaim). Unfortunately, in no case does blocking a buddy within Adium accomplish anything --> the 'buddy' on the other end is still able to see my online status, and is still able to IM me without problem. (As a "sanity-check", I have verified that I can successfully block buddies with both iChat and Fire).
  • As one of the posters above mentioned: it is most important to many of us to be able to block everyone but those on our buddy lists. More precisely, what I'd really like to see is the series of Security options that iChat provides in its Accounts Preferences. iChat does this well, in that it allows (a) many options for who to block/pass, and (b) different security settings for each of your accounts, if you have more than one. However, in reference to (b), *ONLY* Adium has good support for multiple accounts --- e.g. separate icons & simultaneous connections --- and so I'm dying for the privacy-support to be beefed up so I can switch to Adium permanently!

Thanks for all your hard work, we users appreciate it very much! Naomi C.R. Makins (makins@…)

comment:15 Changed 15 years ago by anonymous

please please please add being able to block everyone who is not on your buddy list. it creeps me out when i know people are looking at my away messages and such when i don't want them to be. thanks.

comment:16 Changed 15 years ago by anonymous

Blocking doesn't seem to do anything at all. I'm using .86, and no matter how many times I block someone... their messages still come through. While looking at their message and looking at the 'Info' it gives me a choice to unblock. So, it thinks they are blocked. All it does is not show them in my buddy list.

If I block username 'foo', I shouldn't see any messages from username 'foo'.

comment:17 Changed 15 years ago by trekie

Ok, i signed onto the version of aim for mac after trying to block someone four times.... It appears to be blocking numbers (66, 16, 15, and 14) Hope this helps

Also, it appears to differ from screenname to screename over the service. My main screename has those four above, while one of my sub-names only has 3. It seems Adium isn't affecting all.... not sure if I'm right, but again, hope this helps.

comment:18 Changed 15 years ago by trekie

Edit to last: Cleared them, it appears each user has a number that gets added to the blocked list when i try to block them. I'm going to see if theres some order (aim buddy list order, aphabetrical by alias, alph by SN, or added order...

As far as I can tell (by testing some of the more recent adees is that it is by order added, not alpabetical by either. The two are registered as 100 and 107. The person who got 107 I KNOW is the last person I added, yeterday in fact, and the person who has 107 seems to be about right. I would therefore propose that what adium is indeed blocking is the number, in terms of adding order, of the person you block. As evidence I would put forward the fact that the two screnames i tested began with T and X (the t was 100 and the X was 107, but they have many more than 5 screenames between them.) The Aliases began with A and L. The A had 100, the L had 107. Again, many more than 5 Aliases between them. Third, they do NOT appear to be random, as a third screename, added between the two, gave a result of 105.

In additon, I must point out that these were all done on my main scrrenname, others have much the same buddy list, but not PERFECTLY the same. it may be that they use differant numbers. i also have a hunch that if I added up all the buddies on them, it would be greater than 107. Having now done this, it turns out to be 154. This may mean they are registered in the order that they are retrieved from the AIM server???? I have the beta console up, so ill quit and restart and see if i can get anything.

Having done that heres a piece of the log describing my block list being sent: (Libgaim: oscar) ssi: adding deny buddy 105 to local list (Libgaim: oscar) ssi: adding deny buddy $screenname$ to local list (Libgaim: oscar) ssi: adding deny buddy $screenname$ to local list

$screenname$ obviously represents a screenname.

Later it gets my list of buddies.... Ill test the first person who shows up..... (I'm assuming that a line like this is the retrieval from the server: (Libgaim: oscar) ssi: adding buddy $screenname$ to group Buddies to local list ) And I come up with : 32! So, It would appear that this is the order in which you have added people to your buddy list, the best way to test this will be to add people to a screenname with no buddies. Ill try this now.

It appears I've been wrong over the entire time: not sure about anything now, but a screename that had four buddies (including itself) returned this result when they were blocked (itself is the last): (Libgaim: oscar) ssi: About to add a deny (Libgaim: oscar) ssi: status is 0x0000 for a 0x0008 action with name 43 (Libgaim: oscar) ssi: About to add a deny (Libgaim: oscar) ssi: status is 0x0000 for a 0x0008 action with name 100 (Libgaim: oscar) ssi: About to add a deny (Libgaim: oscar) ssi: status is 0x0000 for a 0x0008 action with name 101 (Libgaim: oscar) ssi: About to add a deny (Libgaim: oscar) ssi: status is 0x0000 for a 0x0008 action with name 36

Will work more, get a clearer write up, try with other services (I have AIM, MSN and Jabber/Googletalk) Apologies for spelling, hope you can understand it

comment:19 Changed 15 years ago by anonymous

Ok, A bit more experimenting done: this error shows up in MSn although it returns an error there due to the fact that all screen names must be in the format name@…. This is what shows up:

Unable to add "36".
The screen name specified is invalid. 
adiumGaimNotifyMessage: type: 0

Unable to add "36".
The screen name specified is invalid. 

Jabber/Googletalk (mine is set up as Jabber, as i set it up before the googletalk addition) works. That is, it is the only service I use that can successfully block users. This may be because it is the only one with one screen name? can someone else verify this?

Just tried to block a user who was on only one list, and it worked.... Not sure why, but could this be a problem wiht how Adium checks for multiple accounts? (this was on aim) I would therefore put forward that instead of being a bug with all, the bug i'm seeing only exists when multiple screenames on the same service are used. Ill make a copy of adium and make new settings and test tomorrow.

comment:20 Changed 15 years ago by Chris Forsythe

field_haspatch: 0

Awesome work guys, keep it up :)

comment:21 Changed 15 years ago by Evan Schoenberg

The number issue is fixed in current source by a recent patch from Kiel :) The unique object ID for metacontacts (which is a number) was being sent to the server instead of the contained contact's screennames.

comment:22 Changed 15 years ago by trekie

Just downloaded .87b5, its fixed.

THANKS!!!

comment:23 Changed 15 years ago by David Smith

Resolution: fixed
Status: assignedclosed

comment:24 Changed 15 years ago by David Smith

Resolution: fixed
Status: closedreopened

Oops, forgot there was more to this than that one issue.

comment:25 Changed 15 years ago by anonymous

Please add the option to block all people not on your buddy list. I get multiple sex and porn ads to my AIM screenname every day and blocking each sender does nothing when they change screennames every time they send a message. I used to block everyone except my buddies when I used AIM, and I really miss that preference option. Otherwise I love Adium, it's great!

comment:26 Changed 15 years ago by anonymous

I will also second the request to add the option to block everyone not on your user list. I am currently getting spammed via my ICQ connection and don't seem to be able to do anything about it :(

comment:27 Changed 15 years ago by anonymous

I'd like to third that request for blocking people not on my user list - I'm getting far too many ICQ spams which has only started in the past week. It's caused me to temporarily switch to Proteus. I want my ducky back though. :)

comment:28 Changed 15 years ago by David Smith

Ya, it's being done.

comment:29 Changed 15 years ago by cooperstephenjames@…

In regards Yahoo Messaging: Adium 0.87 will allow to use the block feature on Yahoo users. It requires that the user is removed from the contact list and added to the Ignore list.

AdiumX does not have any feature to allow Yahoo users to be removed from the yahoo ignore list. (The Windows version of Yahoo does permit this), the only way to un-ignore a user is to go to a rather obscure part of the messenger.yahoo.com website.

Can the feature to manipulate the yahoo ignore list be added to Adium X?

comment:30 Changed 15 years ago by macaddict

I realize it may have been repeated previously, but to have adium hide the username of people you have ignored/blocked from the chatrooms (like yahoo) would also be a nice feature.... or at least put a line through the name to indicate that they have been ignored.....

Thanks guys.. what a great program.......

comment:31 Changed 15 years ago by Peter Hosey

Description: modified (diff)

comment:32 Changed 15 years ago by anonymous

sorry i cant read all of this

how do I block some one on my msn account in adium on a mac?

comment:33 Changed 15 years ago by Peter Hosey

anonymous: right-click on them; click Block.

comment:34 Changed 15 years ago by artist

I have read through all of this and was unable to learn 'how to unblock a user'. I plan to block a user contactin me whom I don't know. But in the case it is a friend just being a butthole, I will need the ability unblock him/her. Is there a list of blocked users in Adium with options to unblock ?

comment:35 Changed 15 years ago by David Munch

Add the person to your list, right-click and choose 'Unblock'.

We should have a block-list in the preferences though, where one could add/remove people. it does make sense from a HIG POW.

comment:36 Changed 15 years ago by anonymous

So is this feature in 1.0 or not? Stupidly confusing these tickets

comment:37 Changed 15 years ago by David Munch

Anonymous: You really should help making them more stupidly confusing by not telling what you are talking about! This ticket is about several things you know.

comment:38 Changed 15 years ago by Kiel Gillard

David Munch: Already in 1.0svn. Check out the Block List Editor in the Contact menu IIRC.

A simpler and easier way of blocking and unblocking is coming :-D

comment:39 Changed 15 years ago by pcw

What's the progress with not allowing messages from people who are not on your contact list (ICQ)?

comment:40 Changed 15 years ago by anonymous

It would be nice if there was something showing that a contact is blocked... a litte lock add on it's picture, by example...

comment:41 Changed 15 years ago by anonymous

I take it you mean svn1.0 has the block list editor, but not white listing, right? Or am I just not seeing an option?

comment:42 Changed 15 years ago by Kiel Gillard

It would be nice if there was something showing that a contact is blocked... a litte lock add on it's picture, by example...

Yet another card I'll soon be playing. Hang tight, I'm just waiting for my computer to return.

...but not white listing, right?...

What is white listing? Does it mean blocking users not on contact list? If that's the case, the block list editor doesn't. It's just an interface for managing blocked contacts.

comment:43 Changed 15 years ago by anonymous

Everytime I try to block a user I get an "Unknown conversation error.". After that, the user I tried to block is still able to see my status and to write messages. In fact, the block system doesn't work right!

comment:44 Changed 15 years ago by Peter Hosey

anonymous: what version of Adium? what service(s)?

see ReportingBugs.

comment:45 Changed 15 years ago by anonymous

I'd like to request a feature that when a window pops up from an unsollicited contact you could have a block button in the menu across the top. Thanks

comment:46 Changed 15 years ago by anonymous

I was wondering if this was asked back before who knows when, why this has not been implimented. I love Adium, i think it far superior to Trillian and GAIM except for this feature. It's rather annoying getting 15 messages from some random people. I hoped that this feature was added to the last update of 0.89 but apparently it's due out in 1.0?? I know it would slow things down to check user database if incoming name matched name on the list but still, i'd take the performance hit for privacy. And since the incoming message is assigned to a specific account (which would then be searched through it's appropriate user database), the performance hit should be minimal. Please see this through before 1.0??

comment:47 Changed 15 years ago by anonymous

theres nothing planned before 1.0 unless theres a major bug that needs to be fixed right away

comment:48 Changed 15 years ago by anonymous

Adding to the above comment, ICQ is the culprit, AIM i'm not having difficulties but it's not to say tested in any way at this point. Just ICQ, i don't care if they can see my status online or not; really, i jsut dont want to see their soliciting messages. Thnx guys!!

comment:49 Changed 15 years ago by mx

yes, blocking all uses not in contact list must be a priority

comment:50 Changed 15 years ago by anonymous

I have a request that is related to all the various tickets surrounding this ticket but ICQ specific. I do not have this problem with any other service. I have been waiting for an option to be able to block people from contacting me that are not in my contact list. ICQ is most susceptible to spam over any other service because ICQ uses IDs that are fairly sequential. You can just go through sequentially and spam everyone all day long. I have a fairly LOW ICQ number because I got my ICQ number way back before or around 1996 (don't exactly remember when, but it's a low number).

comment:51 Changed 15 years ago by leekandham@…

Adium seems to not be blocking the "unknown people" (i.e. those people I don't know who have sent me a message without authorisation) on ICQ whom I've asked to be blocked.

comment:52 Changed 15 years ago by silur66@…

You have to fix this issue fast. Spamming on icq is now well beyond unbearable. People I work with recommend I change client, but I like Adium!

comment:53 Changed 15 years ago by anonymous

Quote: "You have to fix this issue fast."

The devs have already said that it will be fixed in 1.0. It is pointless to complain about it.

comment:54 Changed 15 years ago by anonymous

I'm a new Adium user and love the product but started getting spammed. Read through this thread and have a request - Should there be a 0.9 I'd like this one escalated so its included in the release. Its a major irritant for such an awesome client.

comment:55 Changed 15 years ago by BenGrimsbo@…

blocking doesn't even work. At least for ICQ...

Block this users, doesn't block this user. They can still message me o_o

comment:56 Changed 15 years ago by anonymous

Another suggestion (that I think is not on the TODO-list?):

I've started receiving "Authorization requests" from ICQ-spammers. Not messages, but repeated, repeated, repeated requests to authorize them (it even feels like a program in the other end, not a person), and it's quite boring to hit "Deny" over and over again.

But - the block menu option (may it work or not) is greyed out when it comes to request s. It would be really nice to be able to block requests as well, not having to authorize them first to be able to block them.

Well, just my 2 cents. Thanks guys for a wonderful piece of software!

comment:57 Changed 15 years ago by mz@…

Yeah, block all users not on contact list is very important. But not only messages, requests too. I miss this feature! Spam is terrible! Each night i got about 10-20 spam messages - if i was online(away).

comment:58 Changed 15 years ago by andreas@…

Have a button on the "Authorisation Request" dialog to Accept / Ignore / Block.

comment:59 Changed 14 years ago by YogeshD

Its annonying not to be able to block all users who are not in contact list. Adium was almost perfect in all regards, but these is a major issue as one cannot stop the excessive spamming and distractions from strangers. If users don't mind the spam then keep using Adium as its good. Otherwise check out FIRE IM client for OSX, http://fire.sourceforge.net/

comment:60 Changed 14 years ago by anonymous

This is retarted that nobody has adressed this yet. This request is so important and has been around for almost a year.

comment:61 Changed 14 years ago by David Smith

Quit whining, it's in 1.0.

comment:62 Changed 14 years ago by dbomb

If the block list editor is opened before an account is signed on, you have to close and reopen the window for the blocked contacts from that account to appear. The block list editor also does not remember where you place it.

comment:63 Changed 14 years ago by seraphine

I can't seem to get the block option to work on my Adium. I keep getting IMs from people I have supposedly blocked. It gives me an option to unblock them, so I don't understand what's happening. Please let me know if there's something I can do to fix this. :) thanks

comment:64 Changed 14 years ago by David Smith

Description: modified (diff)

comment:65 Changed 14 years ago by David Smith

Description: modified (diff)

comment:66 Changed 14 years ago by David Smith

Milestone: Adium X 1.0Adium X 1.0 Beta

comment:67 Changed 14 years ago by anonymous

hello, is anyone doing anything about the blocking problem? why is it so difficult to fix? is anyone even answering these questions or are people all just complaining to no avail? i want to be able to block people. why in the world is there a pseudo block option that does not work? if the option is there, it should work, meaning the people who are blocked should not be able to see that i am on line. is someone going to fix this or what?

comment:68 Changed 14 years ago by David Smith

Read the milestone. Notice how it says 1.0 beta. Notice how the blog says 1.0 beta is coming soon. THIS IS NOT ROCKET SCIENCE.

comment:69 Changed 14 years ago by anonymous

I really hope all these whiny ppl actually donate something to Adium. I'm not a developer, but even I'm pretty annoyed at all the dumb queries posted here. If you're not going to post something useful, at least make it thankful. THANK YOU catfish_man, et al.

comment:70 Changed 14 years ago by Augie Fackler

(In [16017]) Die evil line of code. Thanks for the catch CFM, I think this line has been causing problems with the privacy UI. Refs #19.

comment:71 Changed 14 years ago by Evan Schoenberg

(In [16231])

  • Blocking a contact now switches the privacy setting for that account to one which allows blocking, if it isn't already on one.
  • Code cleanup.

Refs #19

comment:72 Changed 14 years ago by Evan Schoenberg

Resolution: fixed
Status: reopenedclosed

(In [16232]) Privacy Settings window overhaul.

  • All changes now apply immediately
  • Fixed bugs with 'All' accounts menu item, metacontacts, allow lists, accounts in multiple privacy settings, etc.
  • Prettified the accounts menu through the use of AIAccountMenu
  • Contacts table and associated buttons now show/hide as appropriate for the selected privacy setting. Account column in the table shows/hides as appropriate.
  • Miscellaneous other improvements
  • Moved the menu item from "Block List Editor..." under Contact to being "Privacy Settings..." under Adium.
  • Documentation and code cleanup

Fixes #19. Please don't reopen #19; let's create smaller, focused tickets for any remaining or new privacy issues.

comment:73 Changed 14 years ago by Chris Forsythe

Milestone: Adium X 1.0 BetaAdium X 1.0

Moving to 1.0 main

comment:74 Changed 14 years ago by anonymous

Resolution: fixed
Status: closedreopened

I can not figure out how to view the people I have blocked and how to unblock them!

Help?

comment:75 Changed 14 years ago by Marcel Zurreck

Click Adium -> Privacy Settings

comment:76 Changed 14 years ago by Eric Richie

Resolution: invalid
Status: reopenedclosed

comment:77 in reply to:  72 Changed 14 years ago by anonymous

Does this mean #129 (block all users not on contact list) was still not resolved? It was originally a separate ticket, but combined to this one (#19) later on.

Replying to evands:

Fixes #19. Please don't reopen #19; let's create smaller, focused tickets for any remaining or new privacy issues.

comment:78 Changed 14 years ago by David Smith

129 is resolved. Should work fine in all 1.0 betas.

comment:79 in reply to:  3 Changed 14 years ago by anonymous

well i blocked this guy on muh buddy list and now i want to unblock him how can i do that

comment:80 Changed 14 years ago by www.reparejoi@…

well i want to unblock this guy cause i accidentally blocked him so can u help and how can i do that

comment:81 Changed 14 years ago by anonymous

to unblock someone just go to the adium menu, click privacy settings, highlight the contact you want to unblock then click the minus sign at the bottom. works for the adium x 1.0b5

comment:82 in reply to:  13 Changed 14 years ago by anonymous

Replying to anonymous:

yes

yes

comment:83 Changed 11 years ago by Zachary West

Component: Core AdiumAdium Core

comment:84 Changed 10 years ago by Robert

Milestone: Adium X 1.0
Note: See TracTickets for help on using tickets.