Adium

Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#1751 closed defect (fixed)

Mail/Address Book Hang

Reported by: stillm@fas.harvard.edu Owned by: nobody
Milestone: Adium X 1.0 Component: Adium Core
Version: Severity: normal
Keywords: Cc:
Patch Status:

Description

whenever i send a message in mail.app, adium temporarily freezes (the spinning rainbow ball) for about 15 seconds. after this time, it works just fine, but the program is temporarily incapacitated every time i send an email. i'm using 0.85b2, but i think i've noticed the problem on previous versions as well.

it is similar to the quite lengthy (~30-60 seconds) freezes that i get every time i add a new AIM address or photo to someone's address book entry (i don't know if other people get this, or if it is just me).

Attachments (1)

Sample of Adium.txt (29.2 KB) - added by stillm@… 15 years ago.
sample of problem

Download all attachments as: .zip

Change History (16)

comment:1 Changed 15 years ago by Chris Forsythe

Milestone: Adium X 0.86

This happens to me as well.

comment:2 Changed 15 years ago by Chris Forsythe

If you could get us a sample of Adium when this occurs, it would help.

Changed 15 years ago by stillm@…

Attachment: Sample of Adium.txt added

sample of problem

comment:3 Changed 15 years ago by stillm@…

i just added a sample of the problem. i've never used activity monitor before, so i hope i did everything correctly...

comment:4 Changed 15 years ago by David Smith

Hm, the sample points to the address book integration being at fault, and Tick mentions that he gets a similar lag when editing AB cards. Maybe we could run that on a thread or something.

comment:5 Changed 15 years ago by anonymous

I've been getting this too when writing names/addresses to the To: -field in Mail.app and running Adium 0.85bXs at the same time... never thought it was Adium though, but now when I think about it, Adium was always running on background. The beach ball starts spinning for a while and the whole composing window goes unresponsive in Mail.app - everything else works. Unable to reproduce it now, but it seems it only happens once or twice every session. Running 0.85 beta-testers only and 10.3.9.

comment:6 Changed 15 years ago by Evan Schoenberg

This is possibly related to #1770

comment:7 Changed 15 years ago by joachimb@…

I get this too, and also when editing cards i AB. Adium seems to beachball whenever anything adressbook-framework-related happens.

Adress book-framework-related stuff should *DEFINITELY* run in a separate thread.

comment:8 Changed 15 years ago by Evan Schoenberg

Could people seeing this issue please give a rough estimate of how many contacts with IM names listed on the card are in their address book and how many cards total are in their address book?

comment:9 Changed 15 years ago by stillm@…

697 address book contacts, maybe 400 of them with IM names.

comment:10 Changed 15 years ago by David Smith

Summary: adium hangs after i send messages in mail.appMail/Address Book Hang

comment:11 Changed 15 years ago by tim@…

I experience the same kind of hang and I have the strong impression it is directly related to the size of the address book. I have around 1500 addresses and lots of images in it. Each change makes Adium hang for up to 3 minutes making it completely unusable.

I have noticed this behaviour for a long time now. It's not related to a recent change. And its getting worse as my address book grows. It seems to be a lack of optimization that really shows when things become huge.

comment:12 Changed 15 years ago by Peter Hosey

I don't think this is related to #1770. this seems like it's just sheer volume of Address Book objects crippling Adium briefly. I agree with joachimb that we should look at putting it on a thread.

comment:13 Changed 15 years ago by Evan Schoenberg

Thing is, the AB update notification supposedly tells us what has changed, and we should just be updating those specific records. Something about that process isn't working right, I imagine -- moving it to a thread should not be necessary.

comment:14 Changed 15 years ago by Evan Schoenberg

Milestone: Adium X 0.86Adium X 1.0
Resolution: fixed
Status: newclosed

Ah. Changes aren't appropriate to be merged back; this issue is already fixed for Adium 1.0.

comment:15 Changed 15 years ago by Evan Schoenberg

(In [13815]) Further (above the significant improvements in 1.0svn versus .8x) improved performance when updating in response to an address book modification. Refs #1751

Note: See TracTickets for help on using tickets.