Adium

Opened 2 years ago

Closed 22 months ago

Last modified 5 weeks ago

#16907 closed defect (duplicate)

Facebook Authorisation keeps repeating

Reported by: lgladdy Owned by:
Milestone: Component: Service/Facebook
Version: 1.5.10 Severity: normal
Keywords: Cc:
Patch Status:

Description

Summary

When I want to connect Adium to Facebook the authorization seems to work and then the authorization windows appears again.

Steps to reproduce

  1. Fill in the username password in the mask for the facebook authorization and hit login
  2. Facebook window asks whether to save the browser -> hit save browser
  3. The authorization window appears again and says: please enter your email and password.

Expected results

Authorization of the facebook account finalizes.

Actual results

Authorization does not work and authorization window shows up over and over again.

Regression

This seems to be a re-emergence of #16368 which was closed.

Attachments (1)

Снимок экрана 2015-08-13 в 12.54.29.png (53.2 KB) - added by CTAC 21 months ago.
Facebook requests to enable cookies

Download all attachments as: .zip

Change History (40)

comment:1 follow-ups: Changed 2 years ago by lgladdy

This seems likely to be related to the deprecation of Facebook chat over XMPP (https://developers.facebook.com/docs/chat)

The server consistently returns Not Authorised, even after authorisation has taken place.

This is likely the end of Facebook chat support, but i'll let a dev confirm it and close if necessary - though Facebook connection options should then be removed.

Last edited 2 years ago by lgladdy (previous) (diff)

comment:2 Changed 2 years ago by AdiumFacebookFedUp

I am experiencing this right now. Same reproduction steps, same results. OS 10.10.3, Adium ver. 1.5.10

comment:3 Changed 2 years ago by koltreg

I am also experiencing this issue. OS 10.10.3 Adium ver. 1.5.10

comment:4 Changed 2 years ago by pykt

Same on 1.5.11b2.

comment:5 Changed 2 years ago by Robby

Ticket #16908 has been marked as a duplicate of this ticket.

comment:6 in reply to: ↑ 1 Changed 2 years ago by Robby

Replying to lgladdy:

This seems likely to be related to the deprecation of Facebook chat over XMPP (https://developers.facebook.com/docs/chat)

The server consistently returns Not Authorised, even after authorisation has taken place.

This is likely the end of Facebook chat support, but i'll let a dev confirm it and close if necessary - though Facebook connection options should then be removed.

I just spoke to our lead developer and he confirmed that indeed appears to be the case.

comment:7 Changed 2 years ago by fr33thought33

Please ad me to the list. same thing here. Thanks.

comment:8 follow-up: Changed 2 years ago by kubofonista

But what for now ?

Is any new FB API and will be implemented or permanently end of FB Chat in Adium ?

comment:9 in reply to: ↑ 8 ; follow-up: Changed 2 years ago by lgladdy

Replying to kubofonista:

But what for now ?

Is any new FB API and will be implemented or permanently end of FB Chat in Adium ?

There is no replacement - Facebook want you to use their apps so they can control what you see and how you see it.

At the moment, it's still possible to login with the very-legacy username and password auth manually to chat.facebook.com:5222 - but I doubt Adium's devs would want to commit time to change from OAuth to that when Facebook are clearly working through shutting down the chat API completely and it could end up broken forever in the next few days.

You can add a new XMPP account to Adium, and use "<your Facebook username>@chat.facebook.com" as the login - you'll need to go to options and add "chat.facebook.com" under "Connect Server" and tick Require SSL/TLS. But, i'd expect this to stop working soon too.

Last edited 2 years ago by lgladdy (previous) (diff)

comment:10 follow-up: Changed 2 years ago by kubofonista

Maybe will it be possible to implement it unofficial - for example by spoofing messenger.com ajax requests?

comment:11 in reply to: ↑ 10 Changed 2 years ago by Robby

Replying to kubofonista:

Maybe will it be possible to implement it unofficial - for example by spoofing messenger.com ajax requests?

Perhaps. But I don’t think this a possibility Adium’s developer will pursue.

comment:12 in reply to: ↑ 9 Changed 2 years ago by bhstone1

Replying to lgladdy:

Replying to kubofonista:

But what for now ?

Is any new FB API and will be implemented or permanently end of FB Chat in Adium ?

There is no replacement - Facebook want you to use their apps so they can control what you see and how you see it.

At the moment, it's still possible to login with the very-legacy username and password auth manually to chat.facebook.com:5222 - but I doubt Adium's devs would want to commit time to change from OAuth to that when Facebook are clearly working through shutting down the chat API completely and it could end up broken forever in the next few days.

You can add a new XMPP account to Adium, and use "<your Facebook username>@chat.facebook.com" as the login - you'll need to go to options and add "chat.facebook.com" under "Connect Server" and tick Require SSL/TLS. But, i'd expect this to stop working soon too.

This works, at least for now. Thank you.

comment:13 Changed 2 years ago by coderanger

For those looking for a solution after FB inevitably shuts down the last vestiges of XMPP, http://fbmacmessenger.rsms.me/ is at least using a supported interface and might be slightly more helpful than watching a browser tab.

comment:14 Changed 2 years ago by Robby

Ticket #16910 has been marked as a duplicate of this ticket.

comment:15 Changed 2 years ago by rmueller

The Facebook protocol of Miranda NG is still working without problems. Does it use a different connection method? http://trac.miranda-ng.org/browser/trunk/protocols/FacebookRM

comment:16 Changed 2 years ago by etk

cc me, same problem here. Using lgladdy's workaround for now, but until when ?

comment:17 Changed 2 years ago by saizai

Same problem. Also, trying to use @chat.facebook.com XMPP, it authorizes & starts connecting, but then errors out with "Server closed this connection." (Please CC me.)

ETA: For devs, could you use the same strategy as fb-mac-messenger? It's FOSS, wraps FB's messenger. Seems like a reasonable workaround.

Last edited 2 years ago by saizai (previous) (diff)

comment:18 Changed 2 years ago by tomasio

same here, running MacOS 10.8.5 /w Adium 1.5.11b2 (16.04.15). Please add me to the subcriber’s list of this bug, if there is any.

comment:19 follow-ups: Changed 2 years ago by michaelgoerz

so what is the appropriate venue for raising a shit-storm to make Facebook reconsider this nonsense?

comment:20 in reply to: ↑ 19 ; follow-up: Changed 2 years ago by koltreg

Replying to michaelgoerz:

so what is the appropriate venue for raising a shit-storm to make Facebook reconsider this nonsense?

their shareholder meeting as you wave several thousands of dollars in stocks around

comment:21 in reply to: ↑ 20 Changed 2 years ago by michaelgoerz

Replying to koltreg:

Replying to michaelgoerz:

so what is the appropriate venue for raising a shit-storm to make Facebook reconsider this nonsense?

their shareholder meeting as you wave several thousands of dollars in stocks around

Are there any known shareholders that might be susceptible to a reminder that this kind of action is a very bad idea? I wouldn't mind writing them a few emails.

comment:22 in reply to: ↑ 19 Changed 2 years ago by lgladdy

Replying to michaelgoerz:

so what is the appropriate venue for raising a shit-storm to make Facebook reconsider this nonsense?

The time for this was a year ago when they announced it - and there was - and Facebook ignored it. Bottom line is they can't inject their ads and tracking if you're using XMPP :P

comment:23 Changed 2 years ago by jbourgui

That's too bad that ad revenue trumps usability. I for one will likely just stop using FB messenger on my desktop because not constantly switching browser tabs to answer chats is the entire reason for Adium, IMHO. Sheesh. I'll watch this thread to see if there's any eventual solution; I really hope there is.

Thanks to all the Adium devels who I'm sure are investigating options!! :)

comment:24 Changed 2 years ago by pattmyn

Not sure if this helps at all, but the folks over on the Trillan team have a legit method they're using to hook into the Facebook chat and it's working fine.

comment:25 Changed 2 years ago by Sirius6034

I can confirm the same problem with my FB account. (Adium 1.5.10 / MAC OS X 10.10.3)

comment:26 in reply to: ↑ description ; follow-up: Changed 2 years ago by karloz61

para poder usar el adium con un chat de facebook messenger desde junio 2015 se necesita
primero elimine de adium su cuenta de facebook (ya no anda mas asi) y agreguela nuevamente pero como una cuenta XMPP (Jaber) con los datos de login "nombrefacebook @ chat.facebook.com" y su contraseña de facebook y listo anda (2/junio/2015)


to use facebook chat account in adium from june 2015 you need first remove your facebook account from adium (no work more) and second create a XMPP( jaber) account whit the login data "yourname @ chat.facebook.com" and your password for facebook ynd ready to connect again facebook chat in adium


para usar no chat do Facebook, desde, junio/2015, voce precisa eliminar su cuenta de facebook on adium, e Adicionar Conta tipo XMPP "Jaber", escriba os dados da sua conta do Facebook meunome @ chat.facebook.com e Digite sua senha do Facebook
e ya esta pronto! pra conversar no Facebook chat via Adium

Last edited 2 years ago by karloz61 (previous) (diff)

comment:27 in reply to: ↑ 26 Changed 2 years ago by jbourgui

Karloz61's solution worked great for me, thanks so much! In order to find your facebook "yourname", that's the string that is after facebook.com/yourname or your.name in your profile, FYI. (I included the . in mine and it works)

Thanks again! :)

-joe

Replying to karloz61:

to use facebook chat account in adium from june 2015 you need first remove your facebook > account from adium (no work more) and second create a XMPP( jaber) account whit the login > data "yourname @ chat.facebook.com" and your password for facebook ynd ready to connect > again facebook chat in adium

comment:28 Changed 23 months ago by meastman

Is any new FB API and will be implemented or permanently end of FB Chat in Adium ?

There is no replacement - Facebook want you to use their apps so they can control what you see and how you see it.

Once libpurple adds support for Facebook's new Messenger protocol as part of a GSOC project, will Adium switch to that?

https://developer.pidgin.im/ticket/16676
https://developer.pidgin.im/wiki/SummerOfCode2015

comment:29 Changed 23 months ago by Robby

It usually takes a while for finished GSoC projects to land in a Pidgin release. But I’m sure Adium would pick up Facebook support then.

comment:30 Changed 23 months ago by IndyHCKM

For me the solution to this was contained above - although I had to sort of mesh two suggestions (which I think were the same suggestions, but maybe each contained parts too complicated for me to understand):

  1. Remove your old facebook account in Adium’s accounts pane.
  2. Add an XMPP (Jabber) account.
  3. Use these credentials:

Jabber ID: [your.name]@chat.facebook.com
Password: [your normal facebook password]

For the ID, use the user ID that allows you to link people to your facebook page using the url www.facebook.com/[your.name] - brackets should not be included, periods should.

  1. under the Options pane of the new XMPP (Jabber) account make sure the Connect Server setting contains “chat.facebook.com” and the Security: Require SSL/TLS is checked.

These four steps allowed me to connect, send, and receive messages on facebook, thereby resolving the problem of looping authentication. Hopefully it persists.

comment:31 Changed 22 months ago by coderanger

Is anyone else no longer able to connect using the workaround? Looks like they might have finally shut down the last vestiges of XMPP.

comment:32 Changed 22 months ago by jbourgui

Same for me, no longer working.

-joe

comment:33 Changed 22 months ago by queuetoo

I'm curious if it's possible to implement this program's code to get Messenger working again in Adium... As of this morning, this app works while Adium, including the work around, doesn't.

https://github.com/rsms/fb-mac-messenger

comment:34 Changed 22 months ago by sphynx

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #16921.
Trying to keep the current XMPP access working appears to be a waste of time, so I'm forward-duping all Facebook chat related tickets to #16921.

Last edited 22 months ago by sphynx (previous) (diff)

comment:35 Changed 21 months ago by sphynx

Ticket #16925 has been marked as a duplicate of this ticket.

Changed 21 months ago by CTAC

Facebook requests to enable cookies

comment:36 Changed 21 months ago by CTAC

Now, facebook requesting me (audium) to "enable cookies" and does not allow adium to connect (

comment:37 Changed 16 months ago by jolysaverio

Hello,

I use Adium 1.5.10 Mac OS 10.11.2 and I can not connect with a jabber account with the following parameters:

username = ... @ chat.facebook.com
Pass = ...
Server: chat.facebook.com
enable SSL

He asks me every time the password is correct when he and the message he told me not to allow

comment:38 in reply to: ↑ 1 Changed 13 months ago by tomasio

Replying to lgladdy:

(...) This is likely the end of Facebook chat support, but i'll let a dev confirm it and close if necessary - though Facebook connection options should then be removed.

Sorry to read, I was a frequent Adium User since it came out, but after Twitter Timeline support is buggy and now FB chat is dead, I am leaving. Keep up that good work, though :)

comment:39 Changed 5 weeks ago by Robert Vehse <robertvehse@…>

(In e48bfdcf9f20) Remove Facebook protocol code and JSONKit. Facebook no longer supports third-party access via XMPP. References #16907. References #16921.

Note: See TracTickets for help on using tickets.