Opened 3 years ago

Last modified 23 months ago

#16827 new crash

Bonjour connections hang Adium and stop *all* IP networking on machine

Reported by: sr105 Owned by:
Milestone: Adium 1.5.11 Component: Service/Bonjour
Version: 1.5.10 Severity: major
Keywords: 10.10 Yosemite Cc:
Patch Status:



Adium hangs on trying to connect using Bonjour on 10.10. I don't think the bug is actually in Adium, but it *appears* to the casual user that Adium no longer works. If a bonjour account is set to auto-connect on app open, Adium immediately beachballs. The reason I don't think this is Adium's fault is because is actually takes down ALL networking on the machine.

I submitted the following to Apple:

I upgraded to OSX 10.10 and kept noticing that I would have networking for 5-10 minutes max and then it would just stop. I could request DHCP renewals, but nothing else worked. After some trial and error, I tracked the problem down to discoveryd.

Steps to reproduce

  1. Start (latest version 1.5.10)
  2. Preferences...
  3. Accounts tab
  4. Add a Bonjour account (little + icon in the lower left corner)
  5. accept defaults, OK

Adium will try to connect, discoveryd will ramp up to 100% and all networking on the Mac will quickly cease.


This didn't happen with OS X 10.9.5.


Networking fix: killall discoveryd

Change History (15)

comment:1 Changed 3 years ago by timpotter

I would like to confirm this, I was frustrated hunting down this networking issue and didn't realize that its Adium that is triggering it.

I've unloaded and reloaded discoveryd, and that would resolve networking.

Not starting Adium keeps networking alive.

comment:2 Changed 3 years ago by timpotter

Also, for anyone that needs to start Adium to disable the Bonjour account, (there probably is a fancier way of doing this) hold shift while clicking on Adium in the dock.

That will not start any of the accounts and you can disable Bonjour and start the rest of your services.

comment:3 Changed 3 years ago by miknight

I hit this problem too. Since Adium starts on login for me, I didn't actually realise this problem had anything to do with Adium until I stumbled across this bug report (I thought it was an isolated Yosemite bug).

The way I was working around it was by running the following every time I booted into OS X:

sudo launchctl unload -w /System/Library/LaunchDaemons/
sudo launchctl load -w /System/Library/LaunchDaemons/

(The fix in the issue description is nicer but I included this in case it helps people when searching.)

After having disabled my Bonjour account, I no longer experience the problem.

comment:4 Changed 3 years ago by Robby

  • Milestone set to Adium 1.5.11

comment:5 Changed 3 years ago by Robby

  • Keywords 10.10 Yosemite added

comment:6 Changed 2 years ago by mwclark4453

Having the same problem. Just uninstalled Adium for now because my twitter and yahoo accounts are also failing so don't need it as much. Will install new version when it releases. Wanted to watch the ticket but didn't see a way so figured a comment would add me to the 'watch' list.

Good luck with the patch.

comment:7 Changed 2 years ago by yannickw

+1 this is a major bug.

comment:8 Changed 2 years ago by lambda

Has anyone filed a ticket with Apple yet? It seems like it's their bug if an arbitrary application can hang all DNS lookups by causing discoveryd to get wedged.

comment:9 Changed 2 years ago by sr105

Apple Bug #18599454

Last edited 2 years ago by mathuaerknedam (previous) (diff)

comment:10 Changed 2 years ago by Robby

Thanks, sr105. Did Apple respond?

comment:11 Changed 2 years ago by sr105

yes, duplicate. that bug # is the active one. also search "ars technica dns broken 10.10"

comment:12 Changed 2 years ago by sphynx

sr105: Apologies for the overzealous spam filter that ate your link. We're dealing with a sudden spike in spam, causing a lot of non-spam to be incorrectly rejected too.

Here's the link to Ars Technica:

comment:13 Changed 2 years ago by sr105

eh. no worries. it seems to be the unfortunately necessary trend lately.

comment:14 Changed 2 years ago by Robby

I reckon this would be solved by OS X 10.10.4’s (currently in beta) return to mDNSResponder from discoveryd?

comment:15 Changed 23 months ago by mitar

I use 10.10.3. For me the system kept working as it should. If I enable Bonjour in Adium only Adium starts working slower, but the system and networking works without a problem. I can operate Adium slowly, patiently, clicking on menus to disable Bonjour. If I do that, it starts working fast after app restart. I can then enable Bonjour again to make it slow again.

Note: See TracTickets for help on using tickets.