Adium

Opened 8 months ago

Closed 7 months ago

Last modified 3 months ago

#16744 closed defect (fixed)

Auto-scrolling not working on macOS 10.15 Catalina

Reported by: Robby Owned by:
Milestone: Adium 1.5.10.5 Component: Adium Core
Version: Severity: regression
Keywords: Cc:
Patch Status:

Description

Summary

From user "bobfoster" at https://forums.cocoaforge.com/viewtopic.php?f=13&t=27155:

Previously, in chats when the list of text boxes was scrolled to the bottom, any additional messages, either typed by user or received from other users, was added to the bottom and the list was scrolled up to reveal it. After upgrading to Catalina yesterday, this autoscrolling behavior has stopped working. When user types a message and hits return, the new message is hidden. Likewise, messages from other users are not revealed by scrolling up. So one has to constantly manually scroll up to see the message thread.

Additional detail from user "spelunker":

After opening Adium for the first time there is a space, often, above the first messages. The new messages scroll until the top 'old' message hits the top of the window. Scrolling thereafter stops.

I've also noticed that the "other party is typing" indicator switches on when they are, but the "you have not read old messages" colour for unread messages seems no longer to work

Regression

New to macOS 10.15 Catalina.

Change History (7)

comment:1 Changed 8 months ago by strayduck

I've confirmed that this bug persists on Apple's supplemental 10.15 releases that were available up to October 24.

comment:3 Changed 7 months ago by Robert

Resolution: fixed
Status: newclosed

comment:4 Changed 6 months ago by smmilton

comment:5 Changed 5 months ago by george.colpitts@…

Is there an ETA for 1.5.10.5? This makes Adium unacceptable on Catalina, the workaround only works with the default theme and most users don't want to fix it manually. It's been two months since it was fixed and over two years since the last version of Adium so it would be really nice if we could get a new release.

comment:6 Changed 4 months ago by countofsanfrancisco

Hi,

Yes, is there an ETA for 1.5.10.5? The workaround doesn't work for me when I tried it.

Thanks!

comment:7 Changed 3 months ago by sandinak

Seconded .. that patch is not working correctly.

Last edited 3 months ago by sandinak (previous) (diff)
Note: See TracTickets for help on using tickets.