Adium

Opened 6 years ago

Last modified 6 years ago

#16678 new defect

Yahoo Account Not Connecting

Reported by: JamesH Owned by:
Milestone: Component: Service/Yahoo
Version: Severity: normal
Keywords: yahoo Cc:
Patch Status:

Description

Summary

I was having the CPU utilization issue, so I downloaded the beta (1.5.10b1), and now Adium won't connect to my Yahoo account.

Steps to reproduce

  1. Start Adium
  2. Go to Preferences / Accounts and observe the failure to connect to Yahoo.

Expected results

Yahoo would connect and behave normally.

Actual results

Yahoo does not connect. In Preferences / Accounts, it says "Error: Error reading from login.yahoo.com: Undefined error: 0". It bounces between "Reconnecting" and "Connecting" status, consistently failing on each connect attempt, and each time escalating the reconnect delay time.

Regression

beta (1.5.10b1)

Notes

I'm attaching console logs.

Change History (17)

comment:1 Changed 6 years ago by James Haskell

One other note: I tried clearing my preferences as described in Troubleshooting (i.e. renaming the Adium 2.0 folder and the plist file). Yahoo was still unable to connect - the ill behavior did not change.

comment:2 Changed 6 years ago by duyt1001

I have the same issue here. On my old Macbook (running OSX 10.9.2) yahoo was working until about 2 weeks ago. On my new macbook I just downloaded adium 1.5.9, yahoo was still failing. And cpu utilization was high -- 130-150%.

comment:3 Changed 6 years ago by Robert

Resolution: duplicate
Status: newclosed

Closed as duplicate of #16431.

comment:4 in reply to:  3 Changed 6 years ago by James Haskell

Replying to Robby:

Closed as duplicate of #16431.

How is this a duplicate of 16678???? 16431 is closed, with a supposed solution provided by the new beta release. I'm having problems WITH THE BETA RELEASE. Could you please take a moment and explain to me why my issue is not considered an open issue??

Version 0, edited 6 years ago by James Haskell (next)

comment:5 Changed 6 years ago by Thijs Alkemade

Component: Adium CoreService/Yahoo
Keywords: yahoo added
Resolution: duplicate
Status: closednew
Version: 1.5.10b1

JamesH: There have been two issues, which are rather intertwined:

  1. Adium using 100% CPU and failing to connect to Yahoo!.
  2. Adium failing to connect to Yahoo!, but no CPU spikes.

The first one is fixed in the beta, which was #16431. The second one doesn't seem to have a cannonical ticket, but it is definitely on our radar and gets reported often. I shall reopen this one to keep track of that.

The debug log here was quite helpful, and I think I've found the issue: CDSA gives us error -9816, which is errSSLClosedNoNotify, which means the server closed the connection without shutting down the TLS connection properly. If I remember correctly, some people from Pidgin reported that NSS didn't have any issue with connecting, but GnuTLS did. That could be explained by the fact that NSS doesn't report this error but GnuTLS seems to do so, as can be seen on this libpurple ticket.

comment:6 Changed 6 years ago by Thijs Alkemade

JamesH: Also, I'm very sorry this happened, but it appears the debug log contained your Yahoo! password in plain. =/

I've deleted the debug log, but I would also recommend you change your password as we can not guarantee who has seen it.

comment:7 Changed 6 years ago by Kary Rogers

I spent some time yesterday trying to look into this issue with my very limited knowledge of how Adium works. Ya know, because I've had very few problems with it in all the years I've used it, so cheers to that.

From what I understand of this issue, it's related to GnuTLS. But from what I can tell, Adium builds libpurple with --enable-gnutls=no. If Adium's libpurple doesn't use GnuTLS, then would this issue be something else?

Side question: what does Adium use for SSL? NSS is disabled in the configure options as well for libpurple.

comment:8 in reply to:  5 Changed 6 years ago by Robert

CDSA

comment:9 Changed 6 years ago by Thijs Alkemade

Adium uses its own SSL plugin based on Apple's CDSA. It's not related to GnuTLS, it's just that NSS doesn't check an error condition that GnuTLS and CDSA do check.

comment:10 Changed 6 years ago by Kary Rogers

Ok, understood. Frankly, I have no real desire to go down the head-to-desk banging hole of dealing with yahoo support.

My debug log doesn't have any mention of CDSA. Just:

16:52:08: (GLib): (16:52:08) yahoo: Authentication: In yahoo_auth16_stage1_cb
16:52:08: (Libpurple: yahoo) Authentication: In yahoo_auth16_stage1_cb
16:52:08: (GLib): (16:52:08) yahoo: Login Failed, unable to retrieve login url: Error reading from login.yahoo.com: Undefined error: 0
16:52:08: (Libpurple: yahoo) Login Failed, unable to retrieve login url: Error reading from login.yahoo.com: Undefined error: 0
16:52:08: (GLib): (16:52:08) connection: Connection error on 0x1098f38f0 (reason: 0 description: Error reading from login.yahoo.com: Undefined error: 0)
16:52:08: (Libpurple: connection) Connection error on 0x1098f38f0 (reason: 0 description: Error reading from login.yahoo.com: Undefined error: 0)
16:52:08: Connection Disconnected: gc=98f38f0 (Error reading from login.yahoo.com: Undefined error: 0)

I'm running a nightly build so debugging is enabled. How can I enable CDSA debug logging?

comment:11 Changed 6 years ago by Dossy Shiobara

+1

comment:12 Changed 6 years ago by Jim

I'm seeing similar unable to connect to YahooIM today.

  • Adium : 1.5.10b1
  • OS X : 10.8.5

Here's a sample from the debug log on my system

'
10:16:43: (Libpurple: util) Response headers: 'HTTP/1.1 200 OK
Date: Mon, 14 Apr 2014 17:16:43 GMT
Set-Cookie: B=cv78sgt9ko5vr&b=3&s=oj; expires=Thu, 14-Apr-2016 17:16:43 GMT; path=/; domain=.yahoo.com
P3P: policyref="http://info.yahoo.com/w3c/p3p.xml", CP="CAO DSP COR CUR ADM DEV TAI PSA PSD IVAi IVDi CONi TELo OTPi OUR DELi SAMi OTRi UNRi PUBi IND PHY ONL UNI PUR FIN COM NAV INT DEM CNT STA POL HEA PRE LOC GOV"
Cache-Control: private
Pragma: no-cache
Expires: Thu, 05 Jan 1995 22:00:00 GMT
Vary: Accept-Encoding
Content-Type: text/html
Age: 0
Connection: close
Server: ATS

'
10:16:43: (GLib): (10:16:43) cdsa: receive failed (-9816): Undefined error: 0
10:16:43: (Libpurple: cdsa) receive failed (-9816): Undefined error: 0
10:16:43: (GLib): (10:16:43) yahoo: Authentication: In yahoo_auth16_stage1_cb
10:16:43: (Libpurple: yahoo) Authentication: In yahoo_auth16_stage1_cb
10:16:43: (GLib): (10:16:43) yahoo: Login Failed, unable to retrieve login url: Error reading from login.yahoo.com: Undefined error: 0
10:16:43: (Libpurple: yahoo) Login Failed, unable to retrieve login url: Error reading from login.yahoo.com: Undefined error: 0
10:16:43: (GLib): (10:16:43) connection: Connection error on 0x10a80beb0 (reason: 0 description: Error reading from login.yahoo.com: Undefined error: 0)
10:16:43: (Libpurple: connection) Connection error on 0x10a80beb0 (reason: 0 description: Error reading from login.yahoo.com: Undefined error: 0)
10:16:43: Connection Disconnected: gc=a80beb0 (Error reading from login.yahoo.com: Undefined error: 0)
10:16:43: <ESPurpleYahooAccount:76087e0 1>:{YAHOO_USERNAME} accountConnectionReportDisconnect: Error reading from login.yahoo.com: Undefined error: 0
10:16:43: (GLib): (10:16:43) account: Disconnecting account {YAHOO_USERNAME} (0x107b5c870)
10:16:43: (Libpurple: account) Disconnecting account {YAHOO_USERNAME} (0x107b5c870)
10:16:43: (GLib): (10:16:43) connection: Disconnecting connection 0x10a80beb0
10:16:43: (Libpurple: connection) Disconnecting connection 0x10a80beb0
10:16:43: (GLib): (10:16:43) yahoo: In yahoo_buddy_icon_upload_data_free()
10:16:43: (Libpurple: yahoo) In yahoo_buddy_icon_upload_data_free()
10:16:43: Disconnected: gc=a80beb0
10:16:43: <ESPurpleYahooAccount:76087e0 1>:{YAHOO_USERNAME}: Telling the core we disconnected
10:16:43: -[AIContactObserverManager endListObjectNotificationsDelaysImmediately]:144: 
10:16:43: <ESPurpleYahooAccount:76087e0 1>:{YAHOO_USERNAME}: Disconnected ("Error reading from login.yahoo.com: Undefined error: 0"): Automatically reconnecting in 5.000000 seconds (0 attempts performed)
10:16:43: (GLib): (10:16:43) connection: Destroying connection 0x10a80beb0
10:16:43: (Libpurple: connection) Destroying connection 0x10a80beb0
10:16:46: <ESPurpleYahooAccount:76087e0 1>:{YAHOO_USERNAME}: Updating status for key: isOnline
10:16:46: <ESPurpleYahooAccount:76087e0 1>:{YAHOO_USERNAME}: Updating status for key: Enabled
10:16:46: <ESPurpleYahooAccount:76087e0 1>:{YAHOO_USERNAME}: Updating status for key: FullNameAttr
10:16:47: (GLib): (10:16:47) util: Writing file accounts.xml to directory /Users/{user}/Library/Application Support/Adium 2.0/Users/Default/libpurple
10:16:47: (Libpurple: util) Writing file accounts.xml to directory /Users/{user}/Library/Application Support/Adium 2.0/Users/Default/libpurple
10:16:47: (GLib): (10:16:47) util: Writing file /Users/{user}/Library/Application Support/Adium 2.0/Users/Default/libpurple/accounts.xml
10:16:47: (Libpurple: util) Writing file /Users/{user}/Library/Application Support/Adium 2.0/Users/Default/libpurple/accounts.xml

comment:13 Changed 6 years ago by Kary Rogers

BTW, this issue is not present on Mac OS X 10.9.2 with the beta 1.5.10b1. I would assume the CDSA library has been updated or changed in some way on that version. I suppose I'm gonna have to bite the bullet and upgrade.

comment:14 Changed 6 years ago by Trey Raymond

Any chance some updated code here could help older mac os users without requiring an os update? http://opensource.apple.com/ Not sure what adium is using specifically.

comment:15 Changed 6 years ago by Jeffry Engert

I just took the plunge to 10.9.2; created a new user account, and I still can't get on to yahoo with Adium 1.5.9; I'll give 1.5.10 a try tomorrow.

comment:16 Changed 6 years ago by Jeffry Engert

10.9.2 and the beta build (I used nightly but I would assume both work) worked for me as well. Is the requirements going to change to mac OS 10.9 and up?

comment:17 in reply to:  16 Changed 6 years ago by Robert

As far as we can tell, the connection issue has nothing to do with the version of OS X being used.

Replying to jengert:

[…] Is the requirements going to change to mac OS 10.9 and up?

Sometime in the future, sure, but not for further 1.5.x releases and not for 1.6.

Note: See TracTickets for help on using tickets.